Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Offset-list

I am totally confused with Offset-List. Please help how to configure it.

2 REPLIES

Re: Offset-list

Suppose you have a topology R1---R2 and R2 advertises 2.2.2.2 to R1 via RIP.

By default RIP would set the metric as 1 (1 hop)

With Offset list you can change the metric that is advertised

R1

interface FastEthernet0/0

ip address 10.10.10.1 255.255.255.0

router rip

version 2

network 10.0.0.0

no auto-summary

R2

interface FastEthernet0/0

ip address 10.10.10.2 255.255.255.0

router rip

version 2

network 2.0.0.0

network 10.0.0.0

no auto-summary

The route on R1 shows the metric as 1

R0#sh ip route

2.0.0.0/24 is subnetted, 1 subnets

R 2.2.2.0 [120/1] via 10.10.10.2, 00:00:22, FastEthernet0/0

Now say u apply an offset-list to increase the metric for the route 2.2.2.0/24 by 3 hop counts

On R1

access-list 1 permit 2.2.2.0 0.0.0.255

router rip

version 2

offset-list 1 in 3 FastEthernet0/0

R0#sh ip route

2.0.0.0/24 is subnetted, 1 subnets

R 2.2.2.0 [120/4] via 10.10.10.2, 00:00:12, FastEthernet0/0

from the output you can see that the metric has increased. This way it can be used to prefer a certain path

HTH

Narayan

New Member

Re: Offset-list

Got it. You are a Champion. Thanks a lot.

133
Views
5
Helpful
2
Replies