Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

one ISP for http and one ISP for email

Hi,

I have a little difficult, i have 1 2811 with that receive an E1 from one ISP and another E1 from one ISP i want to route by one email services and for another only ftp, www,etc.

somebody can suggest a config,

3 REPLIES

Re: one ISP for http and one ISP for email

You could try policy based routing & route maps, I have not done it..but in theory it's possible I think. You will have to test - the config could look something like the below...

interface FastEthernet0/0

ip address 192.168.1.254 255.255.255.0

ip policy route-map diverse-isp

!

access-list 101 remark ISP 1 Traffic

access-list 101 permit tcp 192.168.1.0 0.0.0.255 any eq smtp

access-list 101 permit tcp 192.168.1.0 0.0.0.255 any eq pop3

access-list 101 permit tcp 192.168.1.0 0.0.0.255 any eq 143

!

access-list 102 remark ISP 2 Traffic

access-list 102 permit tcp 192.168.1.0 0.0.0.255 any

!

route-map diverse-isp permit 10

match ip address 101

set ip next-hop 1.1.1.1

!

route-map diverse-isp permit 20

match ip address 102

set ip next-hop 2.2.2.2

!

Hall of Fame Super Gold

Re: one ISP for http and one ISP for email

Ricardo

I can move this discussion beyond the theory that Andrew phrases since I did this for a customer last week. Policy Based Routing (with route maps) will do exactly what you want. It works well. And it is possible to simplify the configuration slightly from what Andrew suggests.

I would start by looking at whatever routing logic you are using. Is it based on static default routes (ip route 0.0.0.0 0.0.0.0) or on some dynamic routing protocol? For which ever approach you have taken configure it so that the route through ISP 2 is the preferred route and the route through ISP 1 is a backup (you want a primary and backup route not 2 equal default routes with load sharing). Then you configure PBR to identify the traffic that should go to ISP 1 (Email or whatever) and set its next hop to ISP 1. So the config would keep access-list 101 and route-map instance 10 but would not need access-list 102 or route-map instance 20.

HTH

Rick

Community Member

Re: one ISP for http and one ISP for email

thanks rick

i want to use a dynamic routing to use one isp as a backup in case of faliure, also i has two ip public as MX (case of backup).

94
Views
0
Helpful
3
Replies
CreatePlease to create content