Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

%OSPF-5-ADJCHG

Hi,

I am having "%OSPF-5-ADJCHG" error log in my WAN router from quite time. i have configured tunnels across my WAN networks,What i observed that always ospf shows LOADING to FULL, I never observed that any single time it has gone into down state. There is also no disruption in the traffic repoted by users during this OSPF LOADING to FULL state.

I would appreciate if anyone can sugest why always i find LOADING to FULL error log without going to ospf to down state. I have also verified from my all past logs.

WAN Device  Cat-6506

s72033-adventerprisek9_wan-mz.122-33.sxh2a.bin

Mar 10 09:56:01.644 UAE: %OSPF-5-ADJCHG: Process 130, Nbr 1.1.1.2 on Tunnel25 from LOADING to FULL, Loading Done

Mar 10 09:56:01.928 UAE: %OSPF-5-ADJCHG: Process 1, Nbr 172.16.0.6 on Tunnel26 from LOADING to FULL, Loading Done

Regards

nad

8 REPLIES
Cisco Employee

Re: %OSPF-5-ADJCHG

Hi,

We don't log by default all the changes between the different OSPF adj states. Please use log-adjacency-changes detail under the OSPF routing instance to have more details. Also check the neighbor logs to see if the session really went down or not.

HTH

Laurent.

Re: %OSPF-5-ADJCHG

Hi Laurent,

log-adjacency-changes detail under the OSPF is already configured. Also i have verified that i cannot see any OSPF loading or flapping at other end.

but it only happened at one end.

Rg

Nad

Re: %OSPF-5-ADJCHG

Is OSPF stuck in loading ?

Can you make sure whether the preferred routes are learned via Tunnel interfaces ?

Please use "debug ip ospf adj" and try to see whats happening ?


Can be due to MTU mismatches if its stuck in loading or

Corrupt LSA's can also be a reason.

Re: %OSPF-5-ADJCHG

Hi,

Yes, Prefered routes are learned are only learned by tunnel interfaces. I have verifed there is no issue in MTU, otherwise i face issues in my production traffic,

Regarding debug, it is difficult to test due to managemnet approval.

Rg

Nad

Re: %OSPF-5-ADJCHG

Hi,

Also just want to clarify that OSPF is not stucking in loading face but i am only getting these logs "Loading to FULL" across on side.There is no production and MTU issue.

Regards

Nad

Cisco Employee

Re: %OSPF-5-ADJCHG

Hi,

It's strange that you don't see any OSPF transition state on the other peer. running debug ip ospf adj on both side would definitely help here to see what's going one. My guess based on what you told us is there are some Hello which are dropped somewhere.

HTH

Laurent.

Re: %OSPF-5-ADJCHG

Corrupted LSA's can also cause this problem at loading.

Have read about this....but this is also a possibility.

Re: %OSPF-5-ADJCHG

Nadeem,

Make sure you have 'ip ospf mtu-ignore command' on both tunnel interfaces.

Be sure to check this http://www.cisco.com/en/US/tech/tk365/technologies_tech_note09186a00800949f7.shtml.

Thanks & Regards

Zeeshan Sanaullah

2016
Views
0
Helpful
8
Replies