Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

OSPF Adjacency Error Please Help

I have a 3725 that is running Frame-Relay over ATM.The 3725 is an ABR between area0 and area3. The other side of the link is an 1841 which is also in area3.I have configured both links to ip ospf network point-to-point. Below is my configuration on both links. If I do a clear ip ospf process on the 3725 both adjacency states come to full. But after the 40 second timer comes around the 1841 re-initializes the OSPF process and it goes through exchanging LS updates but the 1841 gets caught into Loading stage while the 3725 show FULL. Here is the error I get once the 40 second dead timer runs. This happens on both sides of the link for an error. I have checked duplicate routerid's

Cannot see ourself in hello from 1.1.1.162 on ATM1/0.41, state INIT

OSPF: Build router LSA for area 3, router ID 1.1.1.9, seq 0x8000187E

process 100

I have tried configuring these a nonbroadcast links and same issue.

Cisco 3725

interface ATM1/0.41 point-to-point

description 233478 VCI 41

ip address 10.30.1.161 255.255.255.252

ip ospf network point-to-point

ip ospf priority 100

ip ospf mtu-ignore

ip ospf 100 area 3

no snmp trap link-status

pvc 1/41

vbr-nrt 1540 1540

encapsulation aal5snap

router ospf 100

log-adjacency-changes

no capability lls

area 0 authentication message-digest

summary-address 172.28.0.0 255.255.240.0

redistribute connected subnets

redistribute static metric 100 subnets

network 10.30.1.192 0.0.0.3 area 3

network 10.30.10.0 0.0.0.15 area 0

Cisco 1841

interface Serial0/0/0

no ip address

encapsulation frame-relay IETF

service-module t1 timeslots 1-24

frame-relay lmi-type ansi

!

interface Serial0/0/0.1 point-to-point

ip address 10.30.1.162 255.255.255.252

ip ospf network point-to-point

ip ospf priority 0

ip ospf mtu-ignore

ip ospf 100 area 3

frame-relay interface-dlci 17

router ospf 100

log-adjacency-changes

no capability lls

4 REPLIES
Hall of Fame Super Bronze

Re: OSPF Adjacency Error Please Help

Your overall config looks good. The only thing missing would be hard-coding a router-id under the ospf routing process. Weird things can happen with a missing or incorrect router-id.

If you don't hard-code the router-id, it should randomly pick from the highest loopback address but that's the only suggestion I can give... give it a try :).

HTH,

__

Edison.

New Member

Re: OSPF Adjacency Error Please Help

Thanks for your response. I hardcoded the router-id and same issue. Here is the full error log. Router ID 1.1.1.9 is the 3725 and 1.1.1.162 is the 1841

eb 4 14:06:00.206: OSPF: Rcv hello from 1.1.1.9 area 3 from Serial0/0/0.1 10.30.1.161

Feb 4 14:06:00.206: OSPF: Cannot see ourself in hello from 1.1.1.9 on Serial0/0/0.1, state INIT

Feb 4 14:06:00.206: OSPF: Send immediate hello to nbr 1.1.1.9, src address 10.30.1.161, on Serial0/0/0.1

Feb 4 14:06:00.206: OSPF: Send hello to 224.0.0.5 area 3 on Serial0/0/0.1 from 10.30.1.162

Feb 4 14:06:00.206: OSPF: End of hello processing

Feb 4 14:06:00.706: OSPF: For next LSA generation - wait : 5000ms next: 5000ms

Feb 4 14:06:00.706: OSPF: Build router LSA for area 3, router ID 1.1.1.162, seq 0x8000000D

Hall of Fame Super Bronze

Re: OSPF Adjacency Error Please Help

Multicast allowed on this link? Try using unicast instead with the neighbor command under the routing process.

New Member

Re: OSPF Adjacency Error Please Help

I was able to ping the OSPF multicast address of 224.0.0.5 and got this response on both ends. From 3725

rtr#ping 224.0.0.5

Type escape sequence to abort.

Sending 1, 100-byte ICMP Echos to 224.0.0.5, timeout is 2 seconds:

Reply to request 0 from 10.30.1.162, 8 ms

From 1841

rtr#ping 224.0.0.5

Type escape sequence to abort.

Sending 1, 100-byte ICMP Echos to 224.0.0.5, timeout is 2 seconds:

Reply to request 0 from 10.30.1.161, 96 ms

I have tried making both a non-broadcost link under each interface and configuring the neighbor statement under the OSPF process with no luck still. I don't believe I can leave the ip ospf network point-to-point and configure the neigbor command correct?

704
Views
0
Helpful
4
Replies
CreatePlease to create content