Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

ospf advertisemnet

Hi Expert

in OSPF does the advertisement in point-2-point Link from one side as /32 and from other side as /30 affect the ospf work

thanks

6 REPLIES

Re: ospf advertisemnet

Ibrahim,

The advertisement will work fine and wouldn't affect anything that I could see. The /32 would be preferred though if someone were trying to go to the address in the /30 block:

192.168.1.1/32 via s0/0

192.168.1.0/30  via s0/1

A user would go to the first path if they wanted to get to 192.168.1.1 instead of routing the way that you may have intended.

John

HTH, John *** Please rate all useful posts ***
New Member

ospf advertisemnet

Hi John

Pls Have a look to below topology its Clear

R1-----------                                           ----------R2

R1 F0/0 :1.1.1.1 255.255.255.252

R2 F0/0: 1.1.1.2 255.255.255.252

R1

OSPF 1

net 1.1.1.1 0.0.0.0 are 2

R2

OSPF 1

net 1.1.1.1 0.0.0.2 are 2

ospf advertisemnet

Ibrahim,

The mask under R2 would be incorrect and would need to be 0.0.0.3 (255-252 = 3), but overall I still get adjacencies with a configuration like this:

R1:

interface FastEthernet0/0

ip address 1.1.1.1 255.255.255.252

duplex auto

speed auto

router ospf 1

router-id 1.1.1.1

log-adjacency-changes

network 1.1.1.1 0.0.0.0 area 0

Neighbor ID     Pri   State           Dead Time   Address         Interface

1.1.1.2           1   FULL/DR         00:00:39    1.1.1.2         FastEthernet0/0

R2:

interface FastEthernet0/0

ip address 1.1.1.2 255.255.255.252

duplex auto

speed auto

router ospf 1

router-id 1.1.1.2

log-adjacency-changes

network 1.1.1.0 0.0.0.3 area 0

Neighbor ID     Pri   State           Dead Time   Address         Interface

1.1.1.1           1   FULL/DR         00:00:36    1.1.1.1         FastEthernet0/0

HTH,

John

Please rate...

HTH, John *** Please rate all useful posts ***
New Member

ospf advertisemnet

Hi John

Even with the Below configuration , I Have Adjacency ,so how the mask is incorrect or even doesn't match on side while the do have Adjacency Pls Clarify

thanks

ospf advertisemnet

Your wildcard mask doesn't pair....are you sure you have it at 0.0.0.2 and not 0.0.0.3? Your mask with 0.0.0.2 would effectively translate to 255.255.255.253 which isn't valid. I'm assuming you just had a typo above?

Otherwise, you're basically say that 1.1.1.1/32 is in the range of the 1.1.1.0/30 (1.1.1.1-1.1.1.2 useable), so that's why you would have an adjacency. The masks don't have to match, but the addresses that are doing the neighborship need to fall into the same subnet.

Thanks for the rating!

HTH, John *** Please rate all useful posts ***
New Member

ospf advertisemnet

Guys sorry , Mistypo the wild card is 0.0.0.3 not 0.0.0.2

305
Views
13
Helpful
6
Replies