Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

OSPF Area

please give some sample config for OSPF single and multible area.

1 REPLY
Purple

Re: OSPF Area

Hi Anthony,

It's really as simple as working out which interfaces you want in which area and then configuring network statements accordingly.

For example,

interface eth0

ip address 10.1.1.1 255.255.255.0

!

interface eth1

ip address 10.2.1.1 255.255.255.0

!

interface eth2

ip address 192.168.1.1 255.255.255.0

!

interface eth3

ip address 192.168.2.1 255.255.255.0

!

router ospf 100

network 10.1.1.0 0.0.0.255 area 0

network 10.2.1.0 0.0.0.255 area 1

network 192.168.1.0 0.0.0.255 area 2

network 192.168.2.0 0.0.0.255 area 3

Based on the above config:

eth0 will be in area 0

eth1 will be in area 1

eth2 will be in area 2

eth3 will be in area 3

Hope that helps - pls rate the post if it does.

Paresh

!

220
Views
5
Helpful
1
Replies