Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

OSPF areas question

Hi Guys !

Is it possible to configure the same network for the separate OSPF areas.

Example:

network 1.1.1.0 area 0.0.0.0

network 1.1.1.0 area 0.0.0.1

network 1.1.1.0 area 0.0.0.2

I have some strange flip when it was configured this way, I assume this is not supported and is wrong configuration of OSPF , am I right ?

thanx !

2 REPLIES
Purple

Re: OSPF areas question

Hi,

That is not possible. If you enter the above, you will find that you will just be left with the last statement; the first two will be overwritten by the 'network 1.1.1.0 area 0.0.0.2' command.

Paresh

PS. Pls do remember to rate posts

Re: OSPF areas question

Hi,

just to clarify the meaning of the network interface in OSPF: the network statement is used to identify which interface belongs to which area. It is not used to specify the networks which should be routed by OSPF, i.e. the OSPF network statement does not have to match the interface network mask. An interface can only belong to one area in OSPF.

So if you have a router with two interfaces S0 and S1 the config can look like this:

interface Serial0

ip address 1.1.1.1 255.255.255.252

interface Serial0

ip address 1.1.1.5 255.255.255.252

router ospf 10

network 1.1.1.1 0.0.0.0 area 1

!this means Serial0 belongs to area 1

network 1.1.1.5 0.0.0.0 area 2

!this means Serial1 belongs to area 2

Be aware that both networks will be announced to both areas. So connectivity is not an issue here. make sure the respective neighbors connected to S0 and S1 are in area 1 and area 2 respectively.

Hope this helps! Please rate all posts.

Regards, Martin

97
Views
0
Helpful
2
Replies