cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1952
Views
0
Helpful
6
Replies

OSPF Failover.

johnelliot6
Level 2
Level 2

Hi,

Have the following setup:

CE with 3 LAN Subs:

ip address 10.1.1.0 255.255.255.0
ip address 10.254.1.0 255.255.255.0
ip address 192.168.1.0 255.255.255.0

And 2 Eth WAN(A+B) connections both running ospf.

We require both WAN links to advertise all 3 LAN subs(So failover works), but need the following scenario:

WAN link A is primary for subnets 10.1.1.0/24 + 10.254.1.0/24

WAN link B is primary for subnet 192.168.1.0/24

But both links need to be able to accept traffic for all 3 subnets(i.e. advertise them to ospf nei), in the event of a wan link failure.

Thought I could do this with route-maps/metrics:


router ospf 31
router-id 10.2.7.6
log-adjacency-changes
redistribute connected subnets route-map wireless_ospf
passive-interface default
no passive-interface FastEthernet0/1
network 10.2.7.4 0.0.0.3 area 31
!
router ospf 32
router-id 10.2.7.2
log-adjacency-changes
redistribute connected subnets route-map eoc_ospf
passive-interface default
no passive-interface FastEthernet0/0/0
network 10.2.7.0 0.0.0.3 area 32


access-list 90 remark WIRELESS_OSPF_SUB_METRICS
access-list 90 permit 192.168.1.0 0.0.0.255
access-list 91 remark EOC_OSPF_SUB_METRICS
access-list 91 permit 10.1.1.0 0.0.0.255
access-list 91 permit 10.254.1.0 0.0.0.255
access-list 92 remark EOC_OSPF_FILTER_SUB
access-list 92 deny   10.2.7.4 0.0.0.3
access-list 93 remark WIRELESS_OSPF_FILTER_SUB
access-list 93 deny   10.2.7.0 0.0.0.3

route-map eoc_ospf permit 10
match ip address 91
set metric 250
!
route-map eoc_ospf permit 20
match ip address 90
!
route-map eoc_ospf permit 30
match ip address 92
!
route-map wireless_ospf permit 10
match ip address 90
set metric 250
!
route-map wireless_ospf permit 20
match ip address 91
!
route-map wireless_ospf permit 30
match ip address 93


But all subnets are preferred via LinkA (Route-map appears to be working, as metric of 250 is applied)

Routing entry for 10.1.1.0/24
  Known via "ospf 31", distance 110, metric 20, type extern 2, forward metric 1
  Redistributing via bgp 17766
  Advertised by bgp 17766 match external 2
  Last update from 10.2.7.6 on GigabitEthernet0/1.498, 02:20:54 ago
  Routing Descriptor Blocks:
  * 10.2.7.6, from 10.2.7.6, 02:20:54 ago, via GigabitEthernet0/1.498

Routing entry for 10.254.1.0/24
  Known via "ospf 31", distance 110, metric 20, type extern 2, forward metric 1
  Redistributing via bgp 17766
  Advertised by bgp 17766 match external 2
  Last update from 10.2.7.6 on GigabitEthernet0/1.498, 02:19:54 ago
  Routing Descriptor Blocks:
  * 10.2.7.6, from 10.2.7.6, 02:19:54 ago, via GigabitEthernet0/1.498
      Route metric is 20, traffic share count is 1

Routing entry for 192.168.1.0/24
  Known via "ospf 31", distance 110, metric 250, type extern 2, forward metric 1
  Redistributing via bgp 17766
  Advertised by bgp 17766 match external 2
  Last update from 10.2.7.6 on GigabitEthernet0/1.498, 02:19:11 ago
  Routing Descriptor Blocks:
  * 10.2.7.6, from 10.2.7.6, 02:19:11 ago, via GigabitEthernet0/1.498
      Route metric is 250, traffic share count is 1


Any suggestions on how to achieve the behaviour I am after?

Thanks in advance.

2 Accepted Solutions

Accepted Solutions

Sorry didnt payed more attantion

I think that with changing the distance of the backup routes will help you :

router ospf

distance 120 0.0.0.0 ACL-BACKUP-ROUTES

Dan

View solution in original post

soruce will match the advertising router , if you will set the wildcard to 0.0.0.3 it will match all the source updates from that class , if you will set 0.0.0.0 you will match only the exact IP. That's why i set to wildcard 0.0.0.0

View solution in original post

6 Replies 6

Hi ,

redistribute connected subnets route-map wireless_ospf metric-type 1

HTH

Thanks - But didn't appear to make any difference(Other than change the type to extern 1 from 2):

Routing entry for 192.168.1.0/24
  Known via "ospf 31", distance 110, metric 251, type extern 1
  Redistributing via bgp 17766
  Advertised by bgp 17766 match external 2
  Last update from 10.2.7.6 on GigabitEthernet0/1.498, 00:00:26 ago
  Routing Descriptor Blocks:
  * 10.2.7.6, from 10.2.7.6, 00:00:26 ago, via GigabitEthernet0/1.498
      Route metric is 251, traffic share count is 1

i.e. It was still preferred via ospf 31

Thanks

Sorry didnt payed more attantion

I think that with changing the distance of the backup routes will help you :

router ospf

distance 120 0.0.0.0 ACL-BACKUP-ROUTES

Dan

johnelliot6
Level 2
Level 2

Thanks Dan - Just to confirm:

#distance 120 ?
  A.B.C.D  IP Source address

source address is CE IP?

It then expects wildcard bits - If the previous is CE IP, I assume /30 (As this is the IP+Sub conf on WAN Int)

Thanks,

soruce will match the advertising router , if you will set the wildcard to 0.0.0.3 it will match all the source updates from that class , if you will set 0.0.0.0 you will match only the exact IP. That's why i set to wildcard 0.0.0.0

Legend!

Thanks - metric is still the same in both /24's, but ospf 32 is now preferred for 192.168.1.0/24? :

Routing entry for 192.168.1.0/24
  Known via "ospf 32", distance 110, metric 20, type extern 2, forward metric 1
  Redistributing via bgp 17766
  Advertised by bgp 17766 match external 2
  Last update from 10.2.7.2 on GigabitEthernet0/1.132, 00:00:14 ago
  Routing Descriptor Blocks:
  * 10.2.7.2, from 10.2.7.2, 00:00:14 ago, via GigabitEthernet0/1.132
      Route metric is 20, traffic share count is 1

Compared to:

Routing entry for 10.254.1.0/24
  Known via "ospf 31", distance 110, metric 20, type extern 2, forward metric 1
  Redistributing via bgp 17766
  Advertised by bgp 17766 match external 2
  Last update from 10.2.7.6 on GigabitEthernet0/1.498, 00:00:26 ago
  Routing Descriptor Blocks:
  * 10.2.7.6, from 10.2.7.6, 00:00:26 ago, via GigabitEthernet0/1.498
      Route metric is 20, traffic share count is 1

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card