Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

OSPF hello process occupy too much CPU usage !!

I have a Catalyst 6509 connect to another switch using two giga port bundled by a layer2 Etherchannel , then I create the same vlan within these two switch and enable OSPF in the layer 3 vlan interface . However , I often found the OSPF hello process occupy too much CPU usage then cause the OSPF neighbor up/down , I am wondering what will be the most possible cause to make it happen .

4 REPLIES

Re: OSPF hello process occupy too much CPU usage !!

High CPU will cause more than just OSPF adjacency. Have you looked at the show proc cpu and determined which process is hogging the cpu? Is the new vlan you created the only vlan the OSPF is running on? Is this a Native IOS or Hybrid? Have you checked the log of the switch/MSFC? anything interesting?

New Member

Re: OSPF hello process occupy too much CPU usage !!

"show process cpu" command display :

CPU utilization for five seconds: 0%/0%; one minute: 34%; five minutes: 40%

PID Runtime(ms) Invoked uSecs 5Sec 1Min 5Min TTY Process

111 23615884 478191301 49 18.63% 5.29% 5.01% 0 IP Input

120 49543536 267899596 184 21.19% 6.63% 6.57% 0 OSPF Hello

It indicate "IP Input" and "OSPF Hello" process almost take up the whole CPU resource .

Ctatalyst 6509 is running with two SUP-720 configured in "SSO" redundancy mode (Native IOS)

Re: OSPF hello process occupy too much CPU usage !!

Hmm, for five secs section the cpu is 0% but there are process that has 18% and 21%. For troubleshooting purposes, have you try shutting down one of the gig port in that channel, did the cpu subsided? Is the high cpu only occurs when you enable that interface vlan? does the cpu go down when that new interface vlan is admin down? can you verify the spanning tree for that vlan, make sure the right root is the root for that vlan.

New Member

Re: OSPF hello process occupy too much CPU usage !!

Below is my configuration for your reference , I am wondering if the problem is under the etherchannel , should I use the layer 3 etherchannel to act as OSPF interface ?

-----------------------------------------------------

spanning-tree mode mst

no spanning-tree optimize bpdu transmission

spanning-tree extend system-id

spanning-tree vlan 1-4094 priority 0

spanning-tree mst 0 priority 0

port-channel load-balance src-mac

!

redundancy

mode sso

main-cpu

auto-sync running-config

auto-sync standard

!

vlan internal allocation policy ascending

vlan access-log ratelimit 2000

!

interface Port-channel2

no ip address

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 118,526-533,760,4088,4092

switchport mode trunk

switchport nonegotiate

!

interface Port-channel3

no ip address

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 117,128,524,525,754,761,4089,4092

switchport mode trunk

switchport nonegotiate

!

interface GigabitEthernet1/2

no ip address

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 118,526-533,760,4088,4092

switchport mode trunk

switchport nonegotiate

channel-protocol lacp

channel-group 2 mode active

!

interface GigabitEthernet1/3

no ip address

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 117,128,524,525,754,761,4089,4092

switchport mode trunk

switchport nonegotiate

channel-protocol lacp

channel-group 3 mode active

!

interface GigabitEthernet2/2

no ip address

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 118,526-533,760,4088,4092

switchport mode trunk

switchport nonegotiate

channel-protocol lacp

channel-group 2 mode active

!

interface GigabitEthernet2/3

no ip address

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 117,128,524,525,754,761,4089,4092

switchport mode trunk

switchport nonegotiate

no cdp enable

channel-protocol lacp

channel-group 3 mode active

!

interface FastEthernet9/48

no ip address

switchport

switchport access vlan 4092

switchport mode access

!

interface Vlan1

no ip address

!

interface Vlan114

no ip address

priority-group 14

!

interface Vlan117

no ip address

!

interface Vlan119

no ip address

!

interface Vlan129

no ip address

!

interface Vlan130

no ip address

!

interface Vlan136

no ip address

!

interface Vlan138

no ip address

!

interface Vlan530

no ip address

!

interface Vlan754

no ip address

!

interface Vlan756

no ip address

!

interface Vlan757

no ip address

!

interface Vlan758

no ip address

!

interface Vlan759

no ip address

!

interface Vlan773

no ip address

!

interface Vlan1031

ip address 192.168.42.50 255.255.255.0

!

interface Vlan4076

ip address 172.26.254.153 255.255.255.252

!

interface Vlan4087

ip address 172.26.254.65 255.255.255.252

!

interface Vlan4088

ip address 172.26.254.57 255.255.255.252

!

interface Vlan4089

ip address 172.26.254.53 255.255.255.252

!

interface Vlan4090

ip address 172.26.254.50 255.255.255.252

!

interface Vlan4091

ip address 172.26.254.141 255.255.255.252

!

interface Vlan4092

ip address 172.26.120.190 255.255.255.192

priority-group 1

!

router ospf 1

router-id 172.26.120.190

log-adjacency-changes

network 172.22.67.0 0.0.0.255 area 2

network 172.26.120.190 0.0.0.0 area 2

network 172.26.120.0 0.0.0.255 area 2

network 172.26.121.0 0.0.0.255 area 2

network 172.26.254.48 0.0.0.3 area 2

network 172.26.254.52 0.0.0.3 area 2

network 172.26.254.56 0.0.0.3 area 2

network 172.26.254.64 0.0.0.3 area 2

network 172.26.254.140 0.0.0.3 area 2

network 172.26.254.152 0.0.0.3 area 2

!

ip route 172.22.0.0 255.255.0.0 172.22.67.254

priority-list 14 interface Vlan114 medium

!

828
Views
0
Helpful
4
Replies
CreatePlease to create content