Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

OSPF ISSUE

4w6d: OSPF: Rcv pkt from 10.205.32.2, Vlan1, area 0.0.0.0 : src not on the same

network

Plz find the error message

suggest me

5 REPLIES

Re: OSPF ISSUE

Can you post the config?

Just a long shot, you seems to have an adjacency problem. The interfaces that communicates to form a OSPF adjacency between the two routers needs to be in the same IP subnet/network.

This mean that the local router VLAN1 interface ip addressress is not in the same IP subnet/network where the remote router interface configured with 10.205.32.2

For example: If the remote router interface use to form adjacency with the local router is configured with IP subnet/network of 10.205.32.2/30 your local router VLAN1 interface should be configured with IP subnet/network of 10.205.32.1/30

New Member

Re: OSPF ISSUE

router int config ot L3 switch & router ospf config

interface FastEthernet0/0

ip address 10.205.31.1 255.255.255.0

no ip redirects

ip route-cache policy

ip route-cache flow

duplex auto

speed auto

end

router ospf 1

router-id 10.220.31.1

log-adjacency-changes

redistribute connected metric-type 1 subnets

redistribute static metric-type 1 subnets

network 10.0.0.0 0.255.255.255 area 0

L3 VLAN and ospf config

interface Vlan1

ip address 10.205.31.2 255.255.255.0

ip helper-address 10.205.35.250

no ip redirects

!

interface Vlan2

ip address 10.205.32.2 255.255.255.0

ip helper-address 10.205.35.250

no ip redirects

!

interface Vlan3

ip address 10.205.35.2 255.255.255.0

no ip redirects

!

!

router ospf 1

router-id 10.220.31.2

log-adjacency-changes

redistribute connected metric-type 1 subnets

redistribute static metric 150 metric-type 1 subnets

network 10.0.0.0 0.255.255.255 area 0

plz suggest me

Hall of Fame Super Silver

Re: OSPF ISSUE

Tarunava

There appears to be a device in vlan 1 with IP address 10.205.32.2 which is also the address of your vlan 2 interface. Is it possible that the cables got swapped and that the router is actually connected to vlan 2 instead of vlan 1?

Perhaps posting the output of show cdp neighbor would be helpful.

HTH

Rick

New Member

Re: OSPF ISSUE

every thing is ok

Hall of Fame Super Silver

Re: OSPF ISSUE

Tarunava

We are glad that every thing is ok. It would help the forum if you would explain for us what was the problem and how did you solve the problem. It makes the forum more useful if we see description of a problem to also be able to know the definition of the problem and the steps to resolve the problem.

HTH

Rick

344
Views
0
Helpful
5
Replies