Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

OSPF Load balancing issue (Multilink P-P)

Hai all,

My customer is facing a issue in load balancing OSPF in Multilink (Point to Point ) after configuring the multilink customer is only able to use 60 % of the bandwidth.

Now customer has removed the multilink but still he is not able to load balance ..

Customer requirement OSPF load balancing has to be optimized. Right now per-packet CEF is being used. But full bandwidth is not getting utilized.

belw is the customer config

nterface Loopback0

ip address 192.168.254.11 255.255.255.255

!

interface GigabitEthernet0/0

ip address 172.18.0.14 255.255.240.0

duplex auto

speed auto

!

interface GigabitEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface Serial0/0/0

no ip address

clock rate 2000000

interface Serial0/0/1

description IPLC 2nd Link - 0440031962

bandwidth 2048

ip address 172.18.207.6 255.255.255.252

ip load-sharing per-packet

no ip mroute-cache

ip ospf network point-to-point

load-interval 30

no fair-queue

hold-queue 500 out

!

interface Serial0/1/0

no ip address

no ip mroute-cache

shutdown

clock rate 2000000

!

interface Serial0/1/1

description IPLC 4th Link - 0440090531

bandwidth 2048

ip address 172.18.207.14 255.255.255.252

ip load-sharing per-packet

no ip mroute-cache

ip ospf network point-to-point

load-interval 30

no fair-queue

hold-queue 500 out

!

interface Serial0/2/0

description IPLC 3rd Link - 0440044832

bandwidth 2048

ip address 172.18.207.10 255.255.255.252

ip load-sharing per-packet

no ip mroute-cache

ip ospf network point-to-point

load-interval 30

no fair-queue

hold-queue 500 out

!

interface Serial0/2/1

description IPLC 1st Link - 0220009129

bandwidth 2048

ip address 172.18.207.2 255.255.255.252

ip load-sharing per-packet

no ip mroute-cache

ip ospf network point-to-point

load-interval 30

no fair-queue

hold-queue 500 out

!

router ospf 1

router-id 192.168.254.11

log-adjacency-changes

redistribute static subnets

network 172.18.0.0 0.0.15.255 area 0

network 172.18.207.0 0.0.0.3 area 0

network 172.18.207.4 0.0.0.3 area 0

network 172.18.207.12 0.0.0.3 area 0

network 192.168.254.11 0.0.0.0 area 0

!

ip classless

ip route 10.16.19.0 255.255.255.0 172.18.207.1

ip route 10.16.19.0 255.255.255.0 172.18.207.5

ip route 10.16.19.0 255.255.255.0 172.18.207.9

ip route 10.16.19.0 255.255.255.0 172.18.207.13

ip route 172.16.0.0 255.255.0.0 172.18.0.2 250

ip route 172.17.0.0 255.255.0.0 172.18.0.2 250

ip route 172.18.16.0 255.255.240.0 172.18.0.1

ip route 172.18.32.0 255.255.240.0 172.18.0.1

ip route 172.18.160.0 255.255.240.0 172.18.0.1

ip route 172.20.0.0 255.255.0.0 172.18.0.1

ip route 192.168.100.57 255.255.255.255 172.18.207.1

ip route 192.168.100.57 255.255.255.255 172.18.207.5

ip route 192.168.100.57 255.255.255.255 172.18.207.9

ip route 192.168.100.57 255.255.255.255 172.18.207.12

Lijesh.N.C

4 REPLIES

Re: OSPF Load balancing issue (Multilink P-P)

Could you post the configuration with the PPP multilink in place please? Also, the other side of these links?

If you are doing PPP multilink, the discussion about per-packet or per-destination does not enter into it. The PPP treats both links as a single connection, and load-balances the links very effectively. In that case, you only have one IP address at each end, which goes on the multilink interface.

Kevin Dorrell

Luxembourg

New Member

Re: OSPF Load balancing issue (Multilink P-P)

hai Kev,'

Sorry for the delayed reply...

I am attaching the multilink configuration which we tried and failed (only one multilink is coming up at a time, out of two). Please go through it and suggest any changes would be required.

Also we tried for per-destination CEF, but it was working fine, till we noticed that certain links are getting highly utilized at times(due to certain high bandwidth consuming application servers-hosts pairs are getting mapped to those interfaces ) and hence we went for per-packet CEF. Its working fine, still utilization is not optimized fully.(only 20-30%) of the bandwidth of each link is getting utilized).

We use a Cisco 2811 router with IOS version of 12.4(3f), and it supports fast switching functionality needed for per-destination CEF.

Multilink config

interface Multilink1

desc XXXXXXXX

ip address 172.18.207.1 255.255.255.252

no cdp enable

ppp multilink

ppp multilink fragment disable

ppp multilink group 1

interface Serial0/0/0

desc XXXXXXXX

bandwidth 2048

no ip address

encapsulation ppp

no cdp enable

ppp multilink

ppp multilink group 1

interface Serial0/2/0

desc XXXXXXXX

bandwidth 2048

no ip address

encapsulation ppp

no cdp enable

ppp multilink

ppp multilink group 1

interface Multilink2

desc *** MLPPP Bundle2

ip address 172.18.207.5 255.255.255.252

no cdp enable

ppp multilink

ppp multilink fragment disable

ppp multilink group 2

interface Serial0/0/1

desc XXXXXXXX

no ip address

encapsulation ppp

no cdp enable

ppp multilink

ppp multilink group 2

interface Serial0/2/1

desc XXXXXXXX

no ip address

encapsulation ppp

no cdp enable

ppp multilink

ppp multilink group 2

------------------------

existing config

!

interface Serial0/1/0

no ip address

no ip mroute-cache

shutdown

clock rate 2000000

!

interface Serial0/1/1

descriptionXXXXXXXX

bandwidth 2048

ip address 172.18.207.14 255.255.255.252

ip load-sharing per-packet

no ip mroute-cache

ip ospf network point-to-point

load-interval 30

no fair-queue

hold-queue 500 out

!

interface Serial0/2/0

description IPLC 3rd Link - 0440044832

bandwidth 2048

ip address XXXXXXXX

ip load-sharing per-packet

no ip mroute-cache

ip ospf network point-to-point

load-interval 30

no fair-queue

hold-queue 500 out

!

interface Serial0/2/1

descriptionXXXXXXXX

bandwidth 2048

ip address 172.18.207.2 255.255.255.252

ip load-sharing per-packet

no ip mroute-cache

ip ospf network point-to-point

load-interval 30

no fair-queue

hold-queue 500 out

!

router ospf 1

router-id 192.168.254.11

log-adjacency-changes

redistribute static subnets

network 172.18.0.0 0.0.15.255 area 0

network 172.18.207.0 0.0.0.3 area 0

network 172.18.207.4 0.0.0.3 area 0

network 172.18.207.8 0.0.0.3 area 0

network 172.18.207.12 0.0.0.3 area 0

network 192.168.254.11 0.0.0.0 area 0

!

ip classless

ip route 10.16.19.0 255.255.255.0 172.18.207.1

ip route 10.16.19.0 255.255.255.0 172.18.207.5

ip route 10.16.19.0 255.255.255.0 172.18.207.9

ip route 10.16.19.0 255.255.255.0 172.18.207.13

ip route 172.16.0.0 255.255.0.0 172.18.0.2 250

ip route 172.17.0.0 255.255.0.0 172.18.0.2 250

ip route 172.18.16.0 255.255.240.0 172.18.0.1

ip route 172.18.32.0 255.255.240.0 172.18.0.1

ip route 172.18.160.0 255.255.240.0 172.18.0.1

ip route 172.20.0.0 255.255.0.0 172.18.0.1

ip route 192.168.100.57 255.255.255.255 172.18.207.1

ip route 192.168.100.57 255.255.255.255 172.18.207.5

ip route 192.168.100.57 255.255.255.255 172.18.207.9

ip route 192.168.100.57 255.255.255.255 172.18.207.12

New Member

Re: OSPF Load balancing issue (Multilink P-P)

Hi ,

please share the output of commands:-

show ip ospf database.

show ip ospf neighbours

show ip ospf interfaces

show ip route.

New Member

Re: OSPF Load balancing issue (Multilink P-P)

hai sir,

Will do that ..nice to hear that u ve moved to BSG ...right place 4 u

Lijesh .N.C

csg blr

239
Views
0
Helpful
4
Replies
CreatePlease to create content