Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Ospf logs and snmp Server.

I have 3750E with c3750e-universalk9-mz.122-50.SE3 IOS. I have two redundant Links to different ISPs with equal Cost. G0/1 and G0/2, both are advertised in ospf within same area with equal cost. I have snmp enable traps and my snmp is connected in a remote location via these ospf links.

Normally snmp-serve receives these traps via G0/2 link and when G0/2 link fails the snmp-server will receive these traps via g0/1. But in this case snmp-server does not receive the Adj-changes logs OR G0/2 down logs. Logs are generated on local Switch but they are not seen on SNMP-SERVER, so in this case Person Monitoring the snmp-server cannot identify that the link g0/2 is now down or ospf nei is down via g0/2.

help me to resolve this issue.

!

interface Loopback10

ip address 4.4.4.4 255.255.255.255

!

!

interface GigabitEthernet0/1

description =================) normal Snmp tarps are sent from this link after Ge 0/2 goes down = Secondary

no switchport

ip address 10.10.10.1 255.255.255.248

ip ospf network point-to-point

ip ospf cost 10

!

!

interface GigabitEthernet0/2

description =================) normal Snmp tarps are sent from this link = primary.

no switchport

ip address 20.20.20.3 255.255.255.248

ip ospf network point-to-point

ip ospf cost 10

!

!

router ospf 3

router-id 4.4.4.4

log-adjacency-changes

network 4.4.4.4 0.0.0.0 area 0

network 10.10.10.3 0.0.0.7 area 0

network 20.20.20.3 0.0.0.7 area 0

!

snmp-server enable traps ospf state-change

snmp-server enable traps ospf errors

snmp-server enable traps ospf retransmit

snmp-server enable traps ospf lsa

snmp-server enable traps ospf cisco-specific state-change nssa-trans-change

snmp-server enable traps ospf cisco-specific state-change shamlink interface-old

snmp-server enable traps ospf cisco-specific state-change shamlink neighbor

snmp-server enable traps ospf cisco-specific errors

snmp-server enable traps ospf cisco-specific retransmit

snmp-server enable traps ospf cisco-specific lsa

Above config is already deployed on the switch.

Can Anyone help me here.

468
Views
0
Helpful
0
Replies
CreatePlease to create content