Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

OSPF LSA types and point-to-point fiber link

image.jpg

Hello Everyone,

Sorry if the question is too basic, but i could not find any answer so far.

I have this two routers are connected via 10Gig fiber. Here the configuration on both devices (but i ommited whatever is not related to ospf):

Location1 router:

interface TenGigabitEthernet1/1/14

description uplink to Location 2

no switchport

ip address 192.168.255.65 255.255.255.252

ip ospf network point-to-point

end

router ospf 100

redistribute connected subnets

passive-interface default

no passive-interface TenGigabitEthernet1/1/14

network 192.168.255.64 0.0.0.3 area 0

end

Location2 router:

interface TenGigabitEthernet6/5

description uplink to Location 1

no switchport

ip address 192.168.255.66 255.255.255.252

ip ospf network point-to-point

end

router ospf 100

redistribute connected subnets

redistribute static subnets

passive-interface default

no passive-interface TenGigabitEthernet6/5

network 10.0.8.0 0.0.0.255 area 0

network 10.2.0.0 0.0.255.255 area 0

network 10.12.0.0 0.0.0.255 area 0

network 10.18.0.0 0.0.0.255 area 0

network 10.19.0.0 0.0.255.255 area 0

network 192.168.255.64 0.0.0.3 area 0

end

I have everything working normally (i can reach all subnets), but then i realize that something is wrong because when i issue the "show ip ospf database" i can see only the type 1 and type 5 LSA's.

Assuming that this is not the best way to use the redistribute command, I removed, on the Location 1, the "redistribute connected subnets" and added the "network 10.160.0.0 0.0.255.255 area 0". When i did that, the entries related to the subnets from 10.160.0.0/16 disappeared from the type  LSA on the location 2.

Despite of that, i could still reach everything, and when i issue the command "show ip route10.160.9.1"on the location 2, i could see that the route via ospf exist and points normally to the Location 1 router.

Now my questions are:

- Why i don't see any reference for the network 10.160.0.0/16 ans its subnets on the Location 2 router?

- Why i still can reach everything at Location 1 , from Location 2 Router, even if i don't have anything on the ospf database?

I thought that the ospf database should have the entries of the whole network, but it does not seem to be the case. How is possible to build the route table without having any entry on the database?

I was not expecting the Type 2 LSA because the connection is point-to-point, but what should i see instead?

Thank you, and i'm sorry for any grammar mistake..english is not my main language.

Everyone's tags (3)
1 ACCEPTED SOLUTION

Accepted Solutions
Silver

OSPF LSA types and point-to-point fiber link

Hi Lucas,

First some basics on OSPF LSA types:

Type-1 Router LSA - Contains both topological information to build SPF tree and prefixes

Type-2 Network LSA - Used on broadcast and non broadcast networks for more effecient handling of updates and to announce which devices are connected to that network and also the network itself.

Type-3 Summary LSA - These LSAs are sent across area boundaries by the ABRs. Type-1 and type-2 LSAs from one area becomes Type-3 in another area. This is a summary of topology information, not summary of prefixes.

Type-4 ASBR Summary LSA - Used by the ABRs to tell routers in another area how to reach the ASBR in a type-5 LSA.

Type-5 External LSA - External prefixes (redistribution) are sent in Type-5 LSA. In some cases the Forwarding Address is set.

Type-7 NSSA External LSA - Used to inject external prefixes into NSSA area. An ABR will then translate this to Type-5 LSA.

When using a point to point network type there is no need to create a Type-2 LSA because you only have two routers on the link.

Your confusion comes from that you are expecting the LSDB to look like a routing table, which it is not. When you were redistributing connected you could see external prefixes in the LSDB for your prefixes. If one is not familiar with the LSDB this is what you would expect it to look like.

You are only running one area so you will have no Type-3 or Type-4 LSAs.

When you use the network command you tell OSPF routing process on which interfaces to enable OSFP. When you removed the redistribute connected and used the network statement, OSPF got enabled on the interfaces on the router. This means that these networks are now included in the Type-1 Router LSA instead of Type-5 External LSAs.

If you look in the LSDB it might look strange because you only see the Router LSAs. If you do show ip ospf database router x.x.x.x where x.x.x.x is the Router ID of the other router you will see what the LSA actually contains. You will see the P2P link described with a prefix and the neighboring IP of the adjacent router. You will also see a stub network and for your other prefixes you should see stub networks.

Through this Router LSA, the router knows how to build the SPF tree to reach all of those prefixes which can be seen as leaves on a tree where the Router ID would be the root of the tree. So it is natural and expected that you had full reachability also in the second case of configuration.

Daniel Dib
CCIE #37149

Please rate helpful posts.

Daniel Dib CCIE #37149 Please rate helpful posts.
2 REPLIES
Silver

OSPF LSA types and point-to-point fiber link

Hi Lucas,

First some basics on OSPF LSA types:

Type-1 Router LSA - Contains both topological information to build SPF tree and prefixes

Type-2 Network LSA - Used on broadcast and non broadcast networks for more effecient handling of updates and to announce which devices are connected to that network and also the network itself.

Type-3 Summary LSA - These LSAs are sent across area boundaries by the ABRs. Type-1 and type-2 LSAs from one area becomes Type-3 in another area. This is a summary of topology information, not summary of prefixes.

Type-4 ASBR Summary LSA - Used by the ABRs to tell routers in another area how to reach the ASBR in a type-5 LSA.

Type-5 External LSA - External prefixes (redistribution) are sent in Type-5 LSA. In some cases the Forwarding Address is set.

Type-7 NSSA External LSA - Used to inject external prefixes into NSSA area. An ABR will then translate this to Type-5 LSA.

When using a point to point network type there is no need to create a Type-2 LSA because you only have two routers on the link.

Your confusion comes from that you are expecting the LSDB to look like a routing table, which it is not. When you were redistributing connected you could see external prefixes in the LSDB for your prefixes. If one is not familiar with the LSDB this is what you would expect it to look like.

You are only running one area so you will have no Type-3 or Type-4 LSAs.

When you use the network command you tell OSPF routing process on which interfaces to enable OSFP. When you removed the redistribute connected and used the network statement, OSPF got enabled on the interfaces on the router. This means that these networks are now included in the Type-1 Router LSA instead of Type-5 External LSAs.

If you look in the LSDB it might look strange because you only see the Router LSAs. If you do show ip ospf database router x.x.x.x where x.x.x.x is the Router ID of the other router you will see what the LSA actually contains. You will see the P2P link described with a prefix and the neighboring IP of the adjacent router. You will also see a stub network and for your other prefixes you should see stub networks.

Through this Router LSA, the router knows how to build the SPF tree to reach all of those prefixes which can be seen as leaves on a tree where the Router ID would be the root of the tree. So it is natural and expected that you had full reachability also in the second case of configuration.

Daniel Dib
CCIE #37149

Please rate helpful posts.

Daniel Dib CCIE #37149 Please rate helpful posts.

OSPF LSA types and point-to-point fiber link

Hi Daniel,

Thank you for your answer, you are right! Now i see my mistake....

Best Regards,

Lucas

1202
Views
0
Helpful
2
Replies