Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

OSPF mtu mismatch question

Hello,

I have following cisco catalyst switches and running OSPF.

3750G (C3750-ADVIPSERVICESK 12.2(25)SED1)

3750X (C3750E-UNIVERSALK9-M 15.0(1)SE3)

3850 (cat3k_caa-universalk9 03.02.01.SE)

They are all connected through L2 WAN (192.168.40.x/24 star topology)

The link between 3750X and 3850 doesn't reach FULL state.

I think this is because MTU mismatch.

3750G VLAN60 SVI mtu 1500

3750X VLAN60 SVI mtu 1500

3850 VLAN60 SVI mtu 9198

But 3750G doesn't complain anything and staying FULL state with 3750X and 3850.

The output of show ip ospf neigbors on each switch is like the following.

3750G (ID: 10.10.11.1 IP address:192.168.40.101)

Neighbor ID     Pri   State           Dead Time   Address         Interface

2.2.2.2           1   FULL/DROTHER    00:00:36    192.168.40.102  Vlan60

3.3.3.3           1   FULL/BDR        00:00:33    192.168.40.103  Vlan60

3750X (ID: 2.2.2.2 IP address:192.168.40.102)

Neighbor ID     Pri   State           Dead Time   Address         Interface

3.3.3.3           1   EXSTART/BDR     00:00:36    192.168.40.103  Vlan60 (repeat EXSTART > DOWN )

10.10.11.1        1   FULL/DR         00:00:30    192.168.40.101  Vlan60

3850 (ID:3.3.3.3 IP address: 192.168.40.103)

Neighbor ID     Pri   State           Dead Time   Address         Interface

2.2.2.2           1   EXSTART/DROTHER 00:00:38    192.168.40.102  Vlan60 (repeat EXSTART > DOWN )

10.10.11.1        1   FULL/DR         00:00:32    192.168.40.101  Vlan60

I think if I changed MTU on 3850 to 1500 (ip mtu 1500), all seem to get OK.

But the question is why 3750G doesn't complain now.

Thanks in advance,

Taro

Everyone's tags (6)
3 ACCEPTED SOLUTIONS

Accepted Solutions
New Member

Re: OSPF mtu mismatch question

Ignoring MTU is not the right solution. This can cause problems related to DBD exchange. changing the MTU size to a correct number is better. However the query posted is  why 3750G doesn't complain about MTU mismatch !!

Can i get the network diagram to understand the connectivity better!!!

Refer while you debug ip ospf adj

http://www.cisco.com/en/US/tech/tk365/technologies_tech_note09186a0080093f0d.shtml

Regards,

Sathvik

New Member

Re: OSPF mtu mismatch question

Simulated but didn't work as I thought seems mtu must match, why 3750g worked with low mtu that I don't know. But like u said, either setting mtu lower in 3800 or configuring ip ospf mtu-ignore resolves issue.
Other expertise might feed some light to the behavior. iOS bug???

Sent from Cisco Technical Support iPhone App

Silver

Re: OSPF mtu mismatch question

With OSPF the MTU is a field set in the DBD during neighbor establishement. We send small packets only indicating how big our interface MTU is. We can see this in the debugs between the 3750X and the 3850

===========================

Dec 27 09:42:04.033 JST: OSPF: Rcv DBD from 3.3.3.3 on Vlan60 seq 0x1ED6 opt 0x52 flag 0x7 len 32  mtu 9198 state EXSTART

Dec 27 09:42:04.033 JST: OSPF: Nbr 3.3.3.3 has larger interface MTU

!

!

Dec 27 09:52:01.538 JST: OSPF-1 ADJ   Vl60: Rcv DBD from 2.2.2.2 seq 0x230A opt 0x52 flag 0x7 len 32  mtu 1500 state EXSTART

Dec 27 09:52:01.538 JST: OSPF-1 ADJ   Vl60: Nbr 2.2.2.2 has smaller interface MTU

===========================

the debugs on the 3750G show the DR election on the segment, but is debug from a reset of all 3750G neighbors? The problem is clear, but the question is "why does it work when it shouldn't?"

My guess is that the 3750G is either lying about it's MTU or using MTU ignore without showing us. I'd want to see the adj debugs from both the 3750G and the 3850 with a full neighbor reset (clear ip ospf proc...), I think that seeing what advertised MTU is received on the remote end would be key to figuring out why it works when it shouldn't.

-Pete

19 REPLIES
Hall of Fame Super Bronze

OSPF mtu mismatch question

If indeed it's a MTU issue, the 3750G could become neighbors with the other 2 devices if the 3750G has a higher system MTU than the received OSPF packet or you have OSPF MTU-IGNORE configured in the interface.

New Member

OSPF mtu mismatch question

Thanks, Edison.

Does the behavior make sense if "ip ospf mtu-ignore" is enabled on 3750G?

As far as i see the config, i don't see the command.

I checked if "ip ospf mtu-ignore" is enabled by default and not show in the config on specific IOS version,

but i was not able to find any post/article.

New Member

OSPF mtu mismatch question

Here is a really good discussion I remember reading a while back:

https://learningnetwork.cisco.com/thread/37638

New Member

OSPF mtu mismatch question

Thanks, Daniel.

The link you gave me doesn't answer my question why 3750G doesn't complain about mtu mismatch.

or the issue is something different than mtu mismatch in the first place.

New Member

OSPF mtu mismatch question

Does anyone know why??

New Member

Re: OSPF mtu mismatch question

Can you plz post sh run and sh int vlan x.

Sent from Cisco Technical Support iPhone App

New Member

OSPF mtu mismatch question

Thanks for your reply.

Here is the information.

3750X

show run

interface Vlan60
ip address 192.168.40.102 255.255.255.0
ip ospf network broadcast


interface GigabitEthernet1/0/39
switchport access vlan 60
switchport mode access
speed 100
duplex full
priority-queue out
mls qos trust dscp
spanning-tree portfast

router ospf 1
router-id 2.2.2.2
passive-interface default
no passive-interface Vlan60
network 10.2.0.0 0.0.255.255 area 0
network 192.168.40.102 0.0.0.0 area 0

sh interface

sh int vlan 60
Vlan60 is up, line protocol is up
  Hardware is EtherSVI, address is 6073.5c5e.a755 (bia 6073.5c5e.a755)
  Internet address is 192.168.40.102/24
  MTU 1500 bytes, BW 1000000 Kbit/sec, DLY 10 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive not supported
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:00, output 00:00:00, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 3000 bits/sec, 4 packets/sec
     1709621 packets input, 160456050 bytes, 0 no buffer
     Received 0 broadcasts (0 IP multicasts)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     5682192 packets output, 694571645 bytes, 0 underruns
     0 output errors, 1 interface resets
     0 unknown protocol drops
     0 output buffer failures, 0 output buffers swapped out
    
sh int gigabitEthernet 1/0/39
GigabitEthernet1/0/39 is up, line protocol is up (connected)
  Hardware is Gigabit Ethernet, address is 6073.5c5e.a727 (bia 6073.5c5e.a727)
  MTU 9000 bytes, BW 100000 Kbit/sec, DLY 100 usec,
     reliability 255/255, txload 77/255, rxload 5/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 100Mb/s, media type is 10/100/1000BaseTX
  input flow-control is off, output flow-control is unsupported
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:00, output 00:00:08, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 137106466
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 2215000 bits/sec, 2226 packets/sec
  5 minute output rate 30233000 bits/sec, 3004 packets/sec
     6170441449 packets input, 1505330005415 bytes, 0 no buffer
     Received 2647635 broadcasts (2647634 multicasts)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog, 2647634 multicast, 0 pause input
     0 input packets with dribble condition detected
     8025568328 packets output, 9506017028037 bytes, 0 underruns
     0 output errors, 0 collisions, 1 interface resets
     0 unknown protocol drops
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier, 0 pause output
     0 output buffer failures, 0 output buffers swapped out

sh system mtu

System MTU size is 1500 bytes
System Jumbo MTU size is 9000 bytes
System Alternate MTU size is 1500 bytes
Routing MTU size is 1500 bytes

3850

sh run


interface Vlan60
ip address 192.168.40.103 255.255.255.0
ip ospf network broadcast

interface GigabitEthernet1/0/24
switchport access vlan 60
switchport mode access
speed 100
duplex full
spanning-tree portfast

router ospf 1
router-id 3.3.3.3
passive-interface default
no passive-interface Vlan60
network 10.3.0.0 0.0.255.255 area 0
network 192.168.40.103 0.0.0.0 area 0

sh interface

  sh interfaces vlan 60
Vlan60 is up, line protocol is up
  Hardware is Ethernet SVI, address is 44ad.d96d.4e44 (bia 44ad.d96d.4e44)
  Internet address is 192.168.40.103/24
  MTU 9198 bytes, BW 1000000 Kbit/sec, DLY 10 usec,
     reliability 255/255, txload 1/255, rxload 7/255
  Encapsulation ARPA, loopback not set
  Keepalive not supported
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:00, output never, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 29344000 bits/sec, 2565 packets/sec
  5 minute output rate 1733000 bits/sec, 1860 packets/sec
     2106300027 packets input, 3681780117 bytes, 0 no buffer
     Received 0 broadcasts (0 IP multicasts)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     3994823471 packets output, 849352157 bytes, 0 underruns
     0 output errors, 2 interface resets
     0 unknown protocol drops
     0 output buffer failures, 0 output buffers swapped out
    
sh interfaces gigabitEthernet 1/0/24
GigabitEthernet1/0/24 is up, line protocol is up (connected)
  Hardware is Gigabit Ethernet, address is 44ad.d96d.4e18 (bia 44ad.d96d.4e18)
  MTU 9198 bytes, BW 100000 Kbit/sec, DLY 100 usec,
     reliability 255/255, txload 4/255, rxload 70/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 100Mb/s, media type is 10/100/1000BaseTX
  input flow-control is off, output flow-control is unsupported
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:00, output never, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/2000/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 27499000 bits/sec, 2413 packets/sec
  5 minute output rate 1651000 bits/sec, 1752 packets/sec
     2095007493 packets input, 2494707744 bytes, 0 no buffer
     Received 11698507 broadcasts (11698501 multicasts)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog, 11698501 multicast, 0 pause input
     0 input packets with dribble condition detected
     3997144835 packets output, 1186738596 bytes, 0 underruns
     0 output errors, 0 collisions, 1 interface resets
     0 unknown protocol drops
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier, 0 pause output
     0 output buffer failures, 0 output buffers swapped out

sh system mtu
Global Ethernet MTU is 9198 bytes.

3750G

sh run

interface Vlan60
ip address 192.168.40.101 255.255.255.0
ip ospf network broadcast

interface GigabitEthernet1/0/24
switchport access vlan 60
switchport mode access
speed 100
duplex full
priority-queue out
mls qos trust dscp
spanning-tree portfast

router ospf 1
log-adjacency-changes
passive-interface default
no passive-interface Vlan60
network 10.1.0.0 0.0.255.255 area 0
network 192.168.40.101 0.0.0.0 area 0

sh interface

sh int vlan 60
Vlan60 is up, line protocol is up
  Hardware is EtherSVI, address is 0024.5081.c5d5 (bia 0024.5081.c5d5)
  Internet address is 192.168.40.101/24
  MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:00, output 00:00:00, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 1000 bits/sec, 1 packets/sec
  5 minute output rate 1000 bits/sec, 1 packets/sec
     6634505 packets input, 569546795 bytes, 0 no buffer
     Received 0 broadcasts (0 IP multicast)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     3649759 packets output, 416839158 bytes, 0 underruns
     0 output errors, 0 interface resets
     0 output buffer failures, 0 output buffers swapped out
    
sh interfaces gigabitEthernet 1/0/24
GigabitEthernet1/0/24 is up, line protocol is up (connected)
  Hardware is Gigabit Ethernet, address is 0024.5081.c598 (bia 0024.5081.c598)
  MTU 9000 bytes, BW 100000 Kbit, DLY 100 usec,
     reliability 255/255, txload 2/255, rxload 5/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 100Mb/s, media type is 10/100/1000BaseTX
  input flow-control is off, output flow-control is unsupported
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:25, output 00:00:00, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 2303000 bits/sec, 741 packets/sec
  5 minute output rate 860000 bits/sec, 642 packets/sec
     592388221 packets input, 101014036 bytes, 0 no buffer
     Received 2702855 broadcasts (0 multicast)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog, 2702839 multicast, 0 pause input
     0 input packets with dribble condition detected
     1131577290 packets output, 4108045582 bytes, 0 underruns
     0 output errors, 0 collisions, 5 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier, 0 PAUSE output
     0 output buffer failures, 0 output buffers swapped out

sh system mtu

System MTU size is 1500 bytes
System Jumbo MTU size is 9000 bytes
Routing MTU size is 1500 bytes

New Member

Re: OSPF mtu mismatch question

Can u make the neighbors point -to-point n see if all becomes neighbor.

Sent from Cisco Technical Support iPhone App

New Member

Re: OSPF mtu mismatch question

I think DR decides which MTU to use, that's why 3750g selects the MTU with its neighbors but as 3750x is not DR, MTU issue pops up while forming neighbor with 3800 which has higher MTU. To check, try making 3750x DR and check the results.
I do not have eqjipments, so I cannot verify. that's why I suggested making ospf point-to-point in my previous post.

Sent from Cisco Technical Support iPhone App

New Member

Re: OSPF mtu mismatch question

Simulated but didn't work as I thought seems mtu must match, why 3750g worked with low mtu that I don't know. But like u said, either setting mtu lower in 3800 or configuring ip ospf mtu-ignore resolves issue.
Other expertise might feed some light to the behavior. iOS bug???

Sent from Cisco Technical Support iPhone App

New Member

OSPF mtu mismatch question

Thank you very much.

I appreciate your input.

I will lower the mtu on 3850 in near future and post the result.

New Member

OSPF mtu mismatch question

I have applied "ip mtu 1500" on all SVI at Cat3850.

Now output of "sh ip ospf neigbors" shows FULL state at all switches.

I was not able to address the original question why 3750G doesn't complain about MTU mismatch.

However it all works fine now, so i won't investigate it any more.

Thanks for all inputs.

Silver

Re: OSPF mtu mismatch question

It depends on how large packets the device with higher MTU is sending.

Did you try to debug ip ospf adj and debug ip ospf hello to see what happens? Also do you have log-neighbor-changes under your OSPF config?

Daniel Dib
CCIE #37149

Please rate helpful posts.

Daniel Dib CCIE #37149 Please rate helpful posts.
New Member

OSPF mtu mismatch question

Daniel,

Thanks for your reply.

Since I see adjacency down in RAM log, I am pretty sure that log-neighbor-changes are applied.

But not shown in "show run".

Here is the debug information.

3750X

debug ip ospf adj
Dec 27 09:41:58.522 JST: OSPF: Send DBD to 3.3.3.3 on Vlan60 seq 0x1F73 opt 0x52 flag 0x7 len 32
Dec 27 09:41:58.522 JST: OSPF: Retransmitting DBD to 3.3.3.3 on Vlan60 [7]
Dec 27 09:41:59.252 JST: OSPF: Rcv DBD from 3.3.3.3 on Vlan60 seq 0x1ED6 opt 0x52 flag 0x7 len 32  mtu 9198 state EXSTART
Dec 27 09:41:59.252 JST: OSPF: Nbr 3.3.3.3 has larger interface MTU
Dec 27 09:42:03.076 JST: OSPF: Send DBD to 3.3.3.3 on Vlan60 seq 0x1F73 opt 0x52 flag 0x7 len 32
Dec 27 09:42:03.076 JST: OSPF: Retransmitting DBD to 3.3.3.3 on Vlan60 [8]
Dec 27 09:42:04.033 JST: OSPF: Rcv DBD from 3.3.3.3 on Vlan60 seq 0x1ED6 opt 0x52 flag 0x7 len 32  mtu 9198 state EXSTART
Dec 27 09:42:04.033 JST: OSPF: Nbr 3.3.3.3 has larger interface MTU
Dec 27 09:42:07.740 JST: OSPF: Send DBD to 3.3.3.3 on Vlan60 seq 0x1F73 opt 0x52 flag 0x7 len 32
Dec 27 09:42:07.740 JST: OSPF: Retransmitting DBD to 3.3.3.3 on Vlan60 [9]
Dec 27 09:42:08.822 JST: OSPF: Rcv DBD from 3.3.3.3 on Vlan60 seq 0x1ED6 opt 0x52 flag 0x7 len 32  mtu 9198 state EXSTART

debug ip ospf hello
Dec 27 10:06:29.658 JST: OSPF: Send hello to 224.0.0.5 area 0 on Vlan60 from 192.168.40.102
Dec 27 10:06:32.400 JST: OSPF: Rcv hello from 10.10.11.1 area 0 from Vlan60 192.168.40.101
Dec 27 10:06:32.400 JST: OSPF: End of hello processing
Dec 27 10:06:33.784 JST: OSPF: Rcv hello from 3.3.3.3 area 0 from Vlan60 192.168.40.103
Dec 27 10:06:33.784 JST: OSPF: End of hello processing
Dec 27 10:06:39.581 JST: OSPF: Send hello to 224.0.0.5 area 0 on Vlan60 from 192.168.40.102
Dec 27 10:06:42.407 JST: OSPF: Rcv hello from 10.10.11.1 area 0 from Vlan60 192.168.40.101
Dec 27 10:06:42.407 JST: OSPF: End of hello processing
Dec 27 10:06:43.406 JST: OSPF: Rcv hello from 3.3.3.3 area 0 from Vlan60 192.168.40.103
Dec 27 10:06:43.406 JST: OSPF: End of hello processing
Dec 27 10:06:48.925 JST: OSPF: Send hello to 224.0.0.5 area 0 on Vlan60 from 192.168.40.102
Dec 27 10:06:52.406 JST: OSPF: Rcv hello from 10.10.11.1 area 0 from Vlan60 192.168.40.101
Dec 27 10:06:52.406 JST: OSPF: End of hello processing
Dec 27 10:06:52.624 JST: OSPF: Rcv hello from 3.3.3.3 area 0 from Vlan60 192.168.40.103
Dec 27 10:06:52.624 JST: OSPF: End of hello processing


3850

debug ip ospf adj
Dec 27 09:51:57.153 JST: OSPF-1 ADJ   Vl60: Send DBD to 2.2.2.2 seq 0x5C2 opt 0x52 flag 0x7 len 32
Dec 27 09:51:57.153 JST: OSPF-1 ADJ   Vl60: Retransmitting DBD to 2.2.2.2 [5]
Dec 27 09:52:01.538 JST: OSPF-1 ADJ   Vl60: Rcv DBD from 2.2.2.2 seq 0x230A opt 0x52 flag 0x7 len 32  mtu 1500 state EXSTART
Dec 27 09:52:01.538 JST: OSPF-1 ADJ   Vl60: Nbr 2.2.2.2 has smaller interface MTU
Dec 27 09:52:01.538 JST: OSPF-1 ADJ   Vl60: First DBD and we are not SLAVE
Dec 27 09:52:01.802 JST: OSPF-1 ADJ   Vl60: Send DBD to 2.2.2.2 seq 0x5C2 opt 0x52 flag 0x7 len 32
Dec 27 09:52:01.802 JST: OSPF-1 ADJ   Vl60: Retransmitting DBD to 2.2.2.2 [6]
Dec 27 09:52:06.218 JST: OSPF-1 ADJ   Vl60: Rcv DBD from 2.2.2.2 seq 0x230A opt 0x52 flag 0x7 len 32  mtu 1500 state EXSTART
Dec 27 09:52:06.218 JST: OSPF-1 ADJ   Vl60: Nbr 2.2.2.2 has smaller interface MTU
Dec 27 09:52:06.218 JST: OSPF-1 ADJ   Vl60: First DBD and we are not SLAVE
Dec 27 09:52:06.620 JST: OSPF-1 ADJ   Vl60: Send DBD to 2.2.2.2 seq 0x5C2 opt 0x52 flag 0x7 len 32
Dec 27 09:52:06.620 JST: OSPF-1 ADJ   Vl60: Retransmitting DBD to 2.2.2.2 [7]

debug ip ospf hello
Dec 27 09:52:48.559 JST: OSPF-1 HELLO Vl60: Send hello to 224.0.0.5 area 0 from 192.168.40.103
Dec 27 09:52:50.257 JST: OSPF-1 HELLO Vl60: Rcv hello from 2.2.2.2 area 0 192.168.40.102
Dec 27 09:52:57.789 JST: OSPF-1 HELLO Vl60: Send hello to 224.0.0.5 area 0 from 192.168.40.103
Dec 27 09:52:58.369 JST: OSPF-1 HELLO Vl60: Rcv hello from 10.10.11.1 area 0 192.168.40.101
Dec 27 09:52:59.579 JST: OSPF-1 HELLO Vl60: Rcv hello from 2.2.2.2 area 0 192.168.40.102
Dec 27 09:53:07.099 JST: OSPF-1 HELLO Vl60: Send hello to 224.0.0.5 area 0 from 192.168.40.103
Dec 27 09:53:08.377 JST: OSPF-1 HELLO Vl60: Rcv hello from 10.10.11.1 area 0 192.168.40.101
Dec 27 09:53:09.390 JST: OSPF-1 HELLO Vl60: Rcv hello from 2.2.2.2 area 0 192.168.40.102
Dec 27 09:53:16.169 JST: OSPF-1 HELLO Vl60: Send hello to 224.0.0.5 area 0 from 192.168.40.103
Dec 27 09:53:18.376 JST: OSPF-1 HELLO Vl60: Rcv hello from 10.10.11.1 area 0 192.168.40.101
Dec 27 09:53:18.930 JST: OSPF-1 HELLO Vl60: Rcv hello from 2.2.2.2 area 0 192.168.40.102


3750G


debug ip ospf adj
Dec 27 09:53:01.462 JST: OSPF: Neighbor change Event on interface Vlan60
Dec 27 09:53:01.462 JST: OSPF: DR/BDR election on Vlan60
Dec 27 09:53:01.462 JST: OSPF: Elect BDR 3.3.3.3
Dec 27 09:53:01.462 JST: OSPF: Elect DR 10.10.11.1
Dec 27 09:53:01.462 JST:        DR: 10.10.11.1 (Id)   BDR: 3.3.3.3 (Id)
Dec 27 09:54:07.405 JST: OSPF: Neighbor change Event on interface Vlan60
Dec 27 09:54:07.405 JST: OSPF: DR/BDR election on Vlan60
Dec 27 09:54:07.405 JST: OSPF: Elect BDR 3.3.3.3
Dec 27 09:54:07.405 JST: OSPF: Elect DR 10.10.11.1
Dec 27 09:54:07.405 JST:        DR: 10.10.11.1 (Id)   BDR: 3.3.3.3 (Id)
Dec 27 09:55:24.505 JST: OSPF: Build network LSA for Vlan60, router ID 10.10.11.1
Dec 27 09:55:24.505 JST: OSPF: Build network LSA for Vlan60, router ID 10.10.11.1
Dec 27 09:55:24.505 JST: OSPF: Build router LSA for area 0, router ID 10.10.11.1, seq 0x80002679
Dec 27 09:56:09.476 JST: OSPF: Neighbor change Event on interface Vlan60
Dec 27 09:56:09.476 JST: OSPF: DR/BDR election on Vlan60
Dec 27 09:56:09.476 JST: OSPF: Elect BDR 3.3.3.3
Dec 27 09:56:09.476 JST: OSPF: Elect DR 10.10.11.1
Dec 27 09:56:09.476 JST:        DR: 10.10.11.1 (Id)   BDR: 3.3.3.3 (Id)
Dec 27 09:57:06.100 JST: OSPF: Neighbor change Event on interface Vlan60
Dec 27 09:57:06.100 JST: OSPF: DR/BDR election on Vlan60
Dec 27 09:57:06.100 JST: OSPF: Elect BDR 3.3.3.3
Dec 27 09:57:06.100 JST: OSPF: Elect DR 10.10.11.1
Dec 27 09:57:06.100 JST:        DR: 10.10.11.1 (Id)   BDR: 3.3.3.3 (Id)


debug ip ospf hello
Dec 27 09:57:42.121 JST: OSPF: Send hello to 224.0.0.5 area 0 on Vlan60 from 192.168.40.101
Dec 27 09:57:42.121 JST: OSPF: Rcv hello from 3.3.3.3 area 0 from Vlan60 192.168.40.103
Dec 27 09:57:42.121 JST: OSPF: End of hello processing
Dec 27 09:57:44.671 JST: OSPF: Rcv hello from 2.2.2.2 area 0 from Vlan60 192.168.40.102
Dec 27 09:57:44.671 JST: OSPF: End of hello processing
Dec 27 09:57:51.239 JST: OSPF: Rcv hello from 3.3.3.3 area 0 from Vlan60 192.168.40.103
Dec 27 09:57:51.239 JST: OSPF: End of hello processing
Dec 27 09:57:52.120 JST: OSPF: Send hello to 224.0.0.5 area 0 on Vlan60 from 192.168.40.101
Dec 27 09:57:54.452 JST: OSPF: Rcv hello from 2.2.2.2 area 0 from Vlan60 192.168.40.102
Dec 27 09:57:54.452 JST: OSPF: End of hello processing
Dec 27 09:58:01.079 JST: OSPF: Rcv hello from 3.3.3.3 area 0 from Vlan60 192.168.40.103
Dec 27 09:58:01.079 JST: OSPF: End of hello processing
Dec 27 09:58:02.127 JST: OSPF: Send hello to 224.0.0.5 area 0 on Vlan60 from 192.168.40.101
Dec 27 09:58:04.325 JST: OSPF: Rcv hello from 2.2.2.2 area 0 from Vlan60 192.168.40.102
Dec 27 09:58:04.325 JST: OSPF: End of hello processing
Dec 27 09:58:10.105 JST: OSPF: Rcv hello from 3.3.3.3 area 0 from Vlan60 192.168.40.103
Dec 27 09:58:10.105 JST: OSPF: End of hello processing

New Member

OSPF mtu mismatch question

try to ignore MTU on interface, like this cmd ip ospf mtu-ignore

Regards,

Habibi

Regards, Habibi
New Member

Re: OSPF mtu mismatch question

Ignoring MTU is not the right solution. This can cause problems related to DBD exchange. changing the MTU size to a correct number is better. However the query posted is  why 3750G doesn't complain about MTU mismatch !!

Can i get the network diagram to understand the connectivity better!!!

Refer while you debug ip ospf adj

http://www.cisco.com/en/US/tech/tk365/technologies_tech_note09186a0080093f0d.shtml

Regards,

Sathvik

Silver

Re: OSPF mtu mismatch question

With OSPF the MTU is a field set in the DBD during neighbor establishement. We send small packets only indicating how big our interface MTU is. We can see this in the debugs between the 3750X and the 3850

===========================

Dec 27 09:42:04.033 JST: OSPF: Rcv DBD from 3.3.3.3 on Vlan60 seq 0x1ED6 opt 0x52 flag 0x7 len 32  mtu 9198 state EXSTART

Dec 27 09:42:04.033 JST: OSPF: Nbr 3.3.3.3 has larger interface MTU

!

!

Dec 27 09:52:01.538 JST: OSPF-1 ADJ   Vl60: Rcv DBD from 2.2.2.2 seq 0x230A opt 0x52 flag 0x7 len 32  mtu 1500 state EXSTART

Dec 27 09:52:01.538 JST: OSPF-1 ADJ   Vl60: Nbr 2.2.2.2 has smaller interface MTU

===========================

the debugs on the 3750G show the DR election on the segment, but is debug from a reset of all 3750G neighbors? The problem is clear, but the question is "why does it work when it shouldn't?"

My guess is that the 3750G is either lying about it's MTU or using MTU ignore without showing us. I'd want to see the adj debugs from both the 3750G and the 3850 with a full neighbor reset (clear ip ospf proc...), I think that seeing what advertised MTU is received on the remote end would be key to figuring out why it works when it shouldn't.

-Pete

New Member

OSPF mtu mismatch question

Thank you very much to all inputs!

I appreciate it.

I will lower the mtu on 3850 and post the result!

New Member

OSPF mtu mismatch question

I have applied "ip mtu 1500" on all SVI at Cat3850.

Now output of "sh ip ospf neigbors" shows FULL state at all switches.

I was not able to address the original question why 3750G doesn't complain about MTU mismatch.

However it all works fine now, so i won't investigate it any more.

Thanks for all the inputs.

2748
Views
0
Helpful
19
Replies