Cisco Support Community
Showing results for 
Search instead for 
Did you mean: 
Community Member

OSPF (MULTI-LINK) Sorry to post the same once again

Hai all,

My customer is facing a issue in load balancing OSPF in Multilink (Point to Point ) after configuring the multilink customer is only able to use 60 % of the bandwidth.

Now customer has removed the multilink but still he is not able to load balance ..

Customer requirement OSPF load balancing has to be optimized. Right now per-packet CEF is being used. But full bandwidth is not getting utilized.

I am attaching the multilink configuration which we tried and failed (only one multilink is coming up at a time, out of two). Please go through it and suggest any changes would be required.

Also we tried for per-destination CEF, but it was working fine, till we noticed that certain links are getting highly utilized at times(due to certain high bandwidth consuming application servers-hosts pairs are getting mapped to those interfaces ) and hence we went for per-packet CEF. Its working fine, still utilization is not optimized fully.(only 20-30%) of the bandwidth of each link is getting utilized).

We use a Cisco 2811 router with IOS version of 12.4(3f), and it supports fast switching functionality needed for per-destination CEF.


Re: OSPF (MULTI-LINK) Sorry to post the same once again

So what is the concern if the links are not utilised. From your post it seems, the link is not utilised with per pkt load-balancing, & so is the case with multilink. Which gives a reflection that your bandwidth is more than sufficient for current traffic.

Do you see any packet drops or slow connections. What is the reason for suspecting on load-balancing techniques. As far as Multilink not coming up issue, pls post the config for us to have a look.

Community Member

Re: OSPF (MULTI-LINK) Sorry to post the same once again

hai ,

Thanks for the up date ..will check the same with the customer and revert at the earleast ..

Community Member

Re: OSPF (MULTI-LINK) Sorry to post the same once again

Hai Narayan,

Pls find the requested one

when customer has configured two multilink bundles comprising of two links each (2Mbps each), found that only one multilink is coming up. The other multilink shows serial and line protocol down.

requesting for any modifications required in that.

Now the status is that, multilink is removed and data is getting routed through all four links separately, through a per-packet express forwarding( problem with this is that, for individual packet, the Router

needs processing time to scan the full routing table to find the least utilized link and route through it. This can cause delay).

Hence the best option is multilink configuration, where in the router has to look in the table to

find best of two multilinks to pump the traffic, rather than four individual links.).


Re: OSPF (MULTI-LINK) Sorry to post the same once again

Firstly remove the following commands from Multilink interface:

"ppp multilink group 1" & "ppp multilink group 2". These commands are required only on physical interfaces.

For the multilink which shows line down & protocol down, remove that multilink configuration completely from both end devices & create again. I faced this problem many times while configuring Multilinks, though the exact reasson is not known but removing & recreating has solved.

You may refer this link for any assistance:

You may revert for any help.

pls rate all helpful posts.

Community Member

Re: OSPF (MULTI-LINK) Sorry to post the same once again

hai Narayan,

Informed My customer to do nessery changes.... custoemr yet to revert ...wiil updte the status

Thanks once again


CreatePlease to create content