Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

OSPF multiple separate processes

Hi to all,

well my question sounds kind of weird. So let me go to the point.

Cisco doesn't recommend to use multiple opsf processes on the same router although this is possible.

We have in our network a working multiple area design with route summarization, static routes, stub areas etc etc.

Now, we need to build another separate network with a routing protocol (OSPF) on the same router.

Separate means no route exchange between these two ospf processes.

It also has to be possible to insert static routes which aply once for one process and another static route for only the other process.

Can this approach be reached with OSPF?

Happy New Year! :)

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Silver

Re: OSPF multiple separate processes

Hello Christian,

you cannot specify an ospf process in a static route but you can choice what static routes are redistributed into each OSPF process

router ospf 1

redistribute static subnets route-map static_to_proc1

router ospf 2

redistribute static subnets route-map static_to_proc2

you can create the static routes with a route tag

ip route 10.10.1.0 255.255.255.0 172.20.5.30 tag 33

ip route 10.10.2.0 255.255.255.0 172.20.5.35 tag 88

then the route-maps can just match the route-tags:

route-map static_to_proc1 permit 10

match tag 33

route-map static_to_proc2 permit 10

match tag 88

in this way the first is only redistributed into ospf 1 the second static route only into process 2

Hope to help

Giuseppe

7 REPLIES
New Member

Re: OSPF multiple separate processes

Hello and Happy New Year!

Two OSPF processes on the same box don't talk to each other unless you redistribute between them. But both processes will put routes into the single route table on the box. Adding static routes will also put routes into the single route table. All routing process on a box (OSPF 1, 2, Static, whatever) create one route table. The box then forwards traffic based on all the inputs of all the routing protocols. (Hence administrative distance to prioritize protocols) And keep in mind, you cannot run two instances of OSPF on the same interface either. I'm not sure if your design would require this, but it doesn't work.

I hope this helps.

Matt

Hall of Fame Super Bronze

Re: OSPF multiple separate processes

Matt hit it right on the head.

In addition to his post, Cisco does not recommend having multiple OSPF routing process due to the added CPU overhead. OSPF (one process) is CPU intensive as is - imagine having 2 OSPF process calculating SPFs?

If you want separate routing table, you should look into VRF-Lite or full blown MPLS.

HTH,

__

Edison.

Hall of Fame Super Silver

Re: OSPF multiple separate processes

Hello Christian,

you can configure two OSPF processes on the same box.

As Matthew and Edison have pointed out if you need a real separation, both on the signalling and forwarding plane, you need to implement VRF lite or MPLS VPNs.

If instead you want to keep separated the routing domains but you want to have some traffic going between them just define two OSPF router processes on the global routing table (no VRF involved).

Note: in this second case I recommend to design the OSPF areas with different area-id in the two routing instances: you are allowed to use a non zero area to implement a single area OSPF domain.

The reason for this is to provide a security mechanism to avoid unwanted OSPF adjacencies to be formed by accident.

OSPF v2 hellos keep the area ID and area flags but not the OSPF process-id for this reason if you put the same

network x.x.x.x area y

under both routing processes the router will be in trouble and will not advertise the network in either process it cannot decide to what process a link belongs.

So using different area numbers protect you from this possible mistake too.

Hope to help

Giuseppe

Hall of Fame Super Silver

Re: OSPF multiple separate processes

Christian

In your original post you stated these as the requirements:

Now, we need to build another separate network with a routing protocol (OSPF) on the same router.

Separate means no route exchange between these two ospf processes.

It also has to be possible to insert static routes which aply once for one process and another static route for only the other process.

If you need a separate network, running a dynamic routing protocol, with no exchange of routing information with the original network, then it seems to me that 2 OSPF processes is just what you need. Be aware of the restriction that an interface can belong only to a single OSPF process. But if the 2 networks are truly independent I would assume that you do not have any interface that needs to belong to both.

If you need some static route redistributed into one OSPF and some other static route redistributed into the other OSPF then you need to configure the redistribution of static into each OSPF with a distribute list or with a route map that will control redistribution and allow only the desired static to redistribute into each OSPF process.

If we knew more about your environment and the requirements, there might be alternatives we could consider such as VRF lite that might work for you. But based on your original post I believe that multiple OSPF processes can work for you.

HTH

Rick

New Member

Re: OSPF multiple separate processes

Hello,

thank you all for your answers.

Matt and Rick: no, those OSPF processes will run on different interfaces so there is no problem with that.

My main concern is the fact, that every OSPF process is using the same static routes (as Matt said) but this is exactly what i want to avoid.

I must be able to assign static routes to different OSPF processes. For example:

ip route 10.10.1.0 255.255.255.0 172.20.5.30 ospf id 100

ip route 10.10.2.0 255.255.255.0 172.20.5.35 ospf id 200

Have a nice day,

Christian

Hall of Fame Super Silver

Re: OSPF multiple separate processes

Hello Christian,

you cannot specify an ospf process in a static route but you can choice what static routes are redistributed into each OSPF process

router ospf 1

redistribute static subnets route-map static_to_proc1

router ospf 2

redistribute static subnets route-map static_to_proc2

you can create the static routes with a route tag

ip route 10.10.1.0 255.255.255.0 172.20.5.30 tag 33

ip route 10.10.2.0 255.255.255.0 172.20.5.35 tag 88

then the route-maps can just match the route-tags:

route-map static_to_proc1 permit 10

match tag 33

route-map static_to_proc2 permit 10

match tag 88

in this way the first is only redistributed into ospf 1 the second static route only into process 2

Hope to help

Giuseppe

New Member

Re: OSPF multiple separate processes

Giuseppe,

this is exactly what i wanted to do. Great! Thank you to all for your helpful replies.

Christian

549
Views
0
Helpful
7
Replies
CreatePlease to create content