Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

OSPF: Neighbor address does not map to an interface

GW(config)#router ospf 14

GW(config-router)#neighbor 172.30.0.9

OSPF: Neighbor address does not map to an interface

What does that message mean?

  • WAN Routing and Switching
1 ACCEPTED SOLUTION

Accepted Solutions
Silver

Re: OSPF: Neighbor address does not map to an interface

Yes tunnel for each pair. Much harded to achieve a mesh because of the large number of tunnels you will be creating. If the number is much, then seriously consider using your provider. MPLS VPNs are fully mesh by default. One of their advantages.

16 REPLIES
VIP Purple

Re: OSPF: Neighbor address does not map to an interface

Hello,

technically speaking, the error message means that the neighbor with IP address 172.30.0.9 is not on the same primary network as that of your local router, that is, there is no interface configured on your local router with an IP address on the same network...

Can you check if that is the case ?

Regards,

GP

New Member

Re: OSPF: Neighbor address does not map to an interface

yes- 172.30.0.9 in the other subnet:

!

interface Serial0/0

description IP VPN MPLS 384kbps

ip address 172.30.0.14 255.255.255.252

!

router ospf 14

log-adjacency-changes

network 10.20.20.0 0.0.0.255 area 1

network 172.30.0.0 0.0.0.255 area 1

!

But how to establish connect with ospf neighboor?

VIP Purple

Re: OSPF: Neighbor address does not map to an interface

Hello,

the only neighbor address that would work with your configuration is 172.30.0.13. Here are the addresses allowed on the subnet configured for your serial0/0 interface:

network 172.30.0.12/30

hosts 172.30.0.13-14

broadcast 172.30.0.15

Keep in mind that when you configure the network statement in OSPF, you are not actually advertising networks, just the interfaces on your router that fall into the specified network address space...

Does that make sense ?

So either change the IP address of the interface connecting to your Serial0/0 to 172.30.0.13/30, or increase the subnet by adding another bit, 172.30.0.12/29...

Let me know if you have more trouble with this...

Regards,

GP

New Member

Re: OSPF: Neighbor address does not map to an interface

In my situation i've 2 routers connected via ISP MPLS IP VPN

R1(s0/0-172.30.0.14/255.255.255.252,dg=172.30.0.13)

R2(s0/0-172.30.0.9/255.255.255.252,dg=172.30.0.10)

How to made ospf relationship between thrm?

VIP Purple

Re: OSPF: Neighbor address does not map to an interface

Hello,

are you fairly restricted regarding the IP addresses you are allowed to assign ? If possible, can you increase your subnet, that is, make it 172.30.0.8/29, with host from 172.30.0.9 thru 172.30.0.14 ?

Regards,

GP

New Member

Re: OSPF: Neighbor address does not map to an interface

it's production network with several routers connected via MPLS ( 172.30.0.14/29,172.30.0.29/29,172.30.0.5/29.....)

Silver

Re: OSPF: Neighbor address does not map to an interface

If I understand you correctly, your routers are in different places connected by your ISP, using MPLS VPN. And you wish to run OSPF between your routers.

For this you have two options. Either ask your ISP to configure OSPF for you as the PE to CE protocol, in which situation you will be running ospf to your provier. Or you could configure a tunnel between the Routers and run OSPF across the tunnel.

New Member

Re: OSPF: Neighbor address does not map to an interface

yes, you are right.

Does it mean in first case - all work will do ISP and i need not to configure OSPF on my devices?

Second case - which tunnel i must to configure?

Silver

Re: OSPF: Neighbor address does not map to an interface

In the first case, you still need to configure ospf. But you will be peering with your ISP. The ISP will advertise to you, your routes from your other sites.

In the second case, you can simply use a GRE tunnel. Just give it an IP address, and specify the tunnel source and destination using the WAN addresses. Confirm that you can ping from WAN to WAN first (use static routes for the WAN addresses if necessary)

1021
Views
0
Helpful
16
Replies