Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

OSPF Neighbor Down: Too many retransmissions

Hi. i have trouble with ospf adjency.

I have two layer 3 switches:

cisco WS-C3750G-24TS     c3750-advipservicesk9-mz.122-44.SE.bin

cisco WS-C4507R      cat4500-entservicesk9-mz.122-53.SG.bin

Configuration and port statistic on cat4507:

interface Vlan199

ip address 77.94.161.58 255.255.255.248

no ip redirects

no ip proxy-arp

ip ospf cost 60

ip ospf mtu-ignore

Vlan199 is up, line protocol is up

  Hardware is Ethernet SVI, address is 0013.1a1f.4fbf (bia 0013.1a1f.4fbf)

  Internet address is 77.94.161.58/29

  MTU 1552 bytes, BW 1000000 Kbit, DLY 10 usec,

     reliability 255/255, txload 1/255, rxload 0/255

  Encapsulation ARPA, loopback not set

  Keepalive not supported

  ARP type: ARPA, ARP Timeout 04:00:00

  Last input 00:00:06, output never, output hang never

  Last clearing of "show interface" counters never

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: fifo

  Output queue: 0/40 (size/max)

-----------------------------------

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

-----------------------------------

0 output errors, 0 interface resets

#sh system mtu

Global Ethernet MTU is 1552 bytes.

Configuration and port statistic on cat3750:

interface Vlan199

ip address 77.94.161.59 255.255.255.248

no ip redirects

no ip proxy-arp

ip ospf mtu-ignore

end

Vlan199 is up, line protocol is up

  Hardware is EtherSVI, address is 0015.2b5c.154c (bia 0015.2b5c.154c)

  Internet address is 77.94.161.59/29

  MTU 1700 bytes, BW 1000000 Kbit, DLY 10 usec,

     reliability 255/255, txload 1/255, rxload 0/255

  Encapsulation ARPA, loopback not set

  Keepalive not supported

  ARP type: ARPA, ARP Timeout 04:00:00

  Last input 00:00:06, output 00:00:06, output hang never

  Last clearing of "show interface" counters never

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: fifo

  Output queue: 0/40 (size/max)

#sh system mtu

System MTU size is 1700 bytes

System Jumbo MTU size is 1700 bytes

Routing MTU size is 1546 bytes

router ospf 1  (cat 4507)

router-id 85.91.126.1

log-adjacency-changes

network 77.94.161.56 0.0.0.7 area 0

router ospf 1 (cat 3750)

log-adjacency-changes

network 77.94.161.56 0.0.0.7 area 0

Here debug ip ospf events log:

Apr  4 12:37:31: OSPF: Exchange Done with 85.91.126.1 on Vlan199

Apr  4 12:37:32: OSPF: Rcv LS UPD from 85.91.126.1 on Vlan199 length     100 LSA count 1

Apr  4 12:37:33: OSPF: Rcv LS UPD from 85.91.126.1 on Vlan199 length     64 LSA count 1

Apr  4 12:37:33: OSPF: Rcv LS UPD from 85.91.126.1 on Vlan199 length     1504 LSA count 41

Apr  4 12:37:33: OSPF: Rcv LS UPD from 85.91.126.1 on Vlan199 length     604 LSA count 16

Apr  4 12:37:35: OSPF: Send hello to 224.0.0.5 area 0 on Vlan199     from 77.94.161.59

Apr  4 12:37:36: OSPF: Retransmitting request to 85.91.126.1 on     Vlan199

Apr  4 12:37:36: OSPF: Send LS REQ to 85.91.126.1 length 1500 LSA     count 125

Apr  4 12:37:37: OSPF: Rcv LS UPD from 85.91.126.1 on Vlan199 length     64 LSA count 1

Apr  4 12:37:39: OSPF: Rcv hello from 85.91.126.1 area 0 from     Vlan199 77.94.161.58

Apr  4 12:37:39: OSPF: End of hello processing

Apr  4 12:37:41: OSPF: Retransmitting request to 85.91.126.1 on     Vlan199

Apr  4 12:37:41: OSPF: Send LS REQ to 85.91.126.1 length 1500 LSA     count 125

Apr  4 12:37:44: OSPF: Rcv LS UPD from 85.91.126.1 on Vlan199 length     64 LSA count 1

Apr  4 12:37:45: OSPF: Send hello to 224.0.0.5 area 0 on Vlan199     from 77.94.161.59

Apr  4 12:37:46: OSPF: Retransmitting request to 85.91.126.1 on     Vlan199

Apr  4 12:37:46: OSPF: Send LS REQ to 85.91.126.1 length 1500 LSA     count 125

Apr  4 12:37:49: OSPF: Rcv hello from 85.91.126.1 area 0 from     Vlan199 77.94.161.58

Apr  4 12:37:49: OSPF: End of hello processing

Apr  4 12:37:50: OSPF: Rcv LS UPD from 85.91.126.1 on Vlan199 length     64 LSA count 1

Apr  4 12:37:51: OSPF: Retransmitting request to 85.91.126.1 on     Vlan199

Apr  4 12:37:51: OSPF: Send LS REQ to 85.91.126.1 length 1500 LSA     count 125

Apr  4 12:37:55: OSPF: Send hello to 224.0.0.5 area 0 on Vlan199     from 77.94.161.59

Apr  4 12:37:56: OSPF: Retransmitting request to 85.91.126.1 on     Vlan199

Apr  4 12:37:56: OSPF: Send LS REQ to 85.91.126.1 length 1500 LSA     count 125

Apr  4 12:37:58: OSPF: Rcv hello from 85.91.126.1 area 0 from     Vlan199 77.94.161.58

Apr  4 12:37:58: OSPF: End of hello processing

Apr  4 12:38:01: OSPF: Retransmitting request to 85.91.126.1 on     Vlan199

Apr  4 12:38:01: OSPF: Send LS REQ to 85.91.126.1 length 1500 LSA     count 125

Apr  4 12:38:02: OSPF: Rcv LS UPD from 85.91.126.1 on Vlan199 length     64 LSA count 1

Apr  4 12:38:05: OSPF: Send hello to 224.0.0.5 area 0 on Vlan199     from 77.94.161.59

Apr  4 12:38:06: OSPF: Retransmitting request to 85.91.126.1 on     Vlan199

Apr  4 12:38:06: OSPF: Send LS REQ to 85.91.126.1 length 1500 LSA     count 125

Apr  4 12:38:07: OSPF: Rcv hello from 85.91.126.1 area 0 from     Vlan199 77.94.161.58

Apr  4 12:38:07: OSPF: End of hello processing

Apr  4 12:38:10: OSPF: Rcv LS UPD from 85.91.126.1 on Vlan199 length     64 LSA count 1

Apr  4 12:38:11: OSPF: Retransmitting request to 85.91.126.1 on     Vlan199

Apr  4 12:38:11: OSPF: Send LS REQ to 85.91.126.1 length 1500 LSA     count 125

Apr  4 12:38:15: OSPF: Rcv LS UPD from 85.91.126.1 on Vlan199 length     64 LSA count 1

Apr  4 12:38:15: OSPF: Send hello to 224.0.0.5 area 0 on Vlan199     from 77.94.161.59

Apr  4 12:38:16: OSPF: Retransmitting request to 85.91.126.1 on     Vlan199

Apr  4 12:38:16: OSPF: Send LS REQ to 85.91.126.1 length 1500 LSA     count 125

Apr  4 12:38:17: OSPF: Rcv hello from 85.91.126.1 area 0 from     Vlan199 77.94.161.58

Apr  4 12:38:17: OSPF: End of hello processing

Apr  4 12:38:20: OSPF: service_maxage: Trying to delete MAXAGE LSA

Apr  4 12:38:21: OSPF: Retransmitting request to 85.91.126.1 on     Vlan199

Apr  4 12:38:21: OSPF: Send LS REQ to 85.91.126.1 length 1500 LSA     count 125

Apr  4 12:38:25: OSPF: Send hello to 224.0.0.5 area 0 on Vlan199     from 77.94.161.59

Apr  4 12:38:26: OSPF: Retransmitting request to 85.91.126.1 on     Vlan199

Apr  4 12:38:26: OSPF: Send LS REQ to 85.91.126.1 length 1500 LSA     count 125

Apr  4 12:38:26: OSPF: Rcv hello from 85.91.126.1 area 0 from     Vlan199 77.94.161.58

Apr  4 12:38:26: OSPF: End of hello processing

Apr  4 12:38:27: OSPF: Rcv LS UPD from 85.91.126.1 on Vlan199 length     64 LSA count 1

Apr  4 12:38:30: OSPF: service_maxage: Trying to delete MAXAGE LSA

Apr  4 12:38:31: OSPF: Retransmitting request to 85.91.126.1 on     Vlan199

Apr  4 12:38:31: OSPF: Send LS REQ to 85.91.126.1 length 1500 LSA     count 125

Apr  4 12:38:35: OSPF: Send hello to 224.0.0.5 area 0 on Vlan199     from 77.94.161.59

Apr  4 12:38:36: OSPF: Rcv hello from 85.91.126.1 area 0 from     Vlan199 77.94.161.58

Apr  4 12:38:36: OSPF: End of hello processing

Apr  4 12:38:36: OSPF: Retransmitting request to 85.91.126.1 on     Vlan199

Apr  4 12:38:36: OSPF: Send LS REQ to 85.91.126.1 length 1500 LSA     count 125

Apr  4 12:38:40: OSPF: Rcv LS UPD from 85.91.126.1 on Vlan199 length     64 LSA count 1

Apr  4 12:38:40: OSPF: service_maxage: Trying to delete MAXAGE LSA

Apr  4 12:38:41: OSPF: Retransmitting request to 85.91.126.1 on     Vlan199

Apr  4 12:38:41: OSPF: Send LS REQ to 85.91.126.1 length 1500 LSA     count 125

Apr  4 12:38:45: OSPF: Rcv hello from 85.91.126.1 area 0 from     Vlan199 77.94.161.58

Apr  4 12:38:45: OSPF: End of hello processing

Apr  4 12:38:45: OSPF: Send hello to 224.0.0.5 area 0 on Vlan199     from 77.94.161.59

Apr  4 12:38:46: OSPF: Retransmitting request to 85.91.126.1 on     Vlan199

Apr  4 12:38:46: OSPF: Send LS REQ to 85.91.126.1 length 1500 LSA     count 125

Apr  4 12:38:46: OSPF: Rcv LS UPD from 85.91.126.1 on Vlan199 length     64 LSA count 1

Apr  4 12:38:46: OSPF: Send UPD to 77.94.161.58 on Vlan199 length 40     LSA count 1

Apr  4 12:38:50: OSPF: service_maxage: Trying to delete MAXAGE LSA

Apr  4 12:38:51: OSPF: Retransmitting request to 85.91.126.1 on     Vlan199

Apr  4 12:38:51: OSPF: Send LS REQ to 85.91.126.1 length 1500 LSA     count 125

Apr  4 12:38:51: OSPF: Rcv LS UPD from 85.91.126.1 on Vlan199 length     64 LSA count 1

Apr  4 12:38:51: OSPF: Send UPD to 77.94.161.58 on Vlan199 length 40     LSA count 1

Apr  4 12:38:52: OSPF: Rcv LS UPD from 85.91.126.1 on Vlan199 length     64 LSA count 1

Apr  4 12:38:54: OSPF: Rcv hello from 85.91.126.1 area 0 from     Vlan199 77.94.161.58

Apr  4 12:38:54: OSPF: End of hello processing

Apr  4 12:38:55: OSPF: Send hello to 224.0.0.5 area 0 on Vlan199     from 77.94.161.59

Apr  4 12:38:56: OSPF: Retransmitting request to 85.91.126.1 on     Vlan199

Apr  4 12:38:56: OSPF: Send LS REQ to 85.91.126.1 length 1500 LSA     count 125

Apr  4 12:38:56: OSPF: Rcv LS UPD from 85.91.126.1 on Vlan199 length     64 LSA count 1

Apr  4 12:39:01: OSPF: Retransmitting request to 85.91.126.1 on     Vlan199

Apr  4 12:39:01: OSPF: Send LS REQ to 85.91.126.1 length 1500 LSA     count 125

Apr  4 12:39:04: OSPF: Rcv hello from 85.91.126.1 area 0 from     Vlan199 77.94.161.58

Apr  4 12:39:04: OSPF: End of hello processing

Apr  4 12:39:04: OSPF: Rcv LS UPD from 85.91.126.1 on Vlan199 length     64 LSA count 1

Apr  4 12:39:04: OSPF: Rcv LS UPD from 85.91.126.1 on Vlan199 length     64 LSA count 1

Apr  4 12:39:05: OSPF: Send hello to 224.0.0.5 area 0 on Vlan199     from 77.94.161.59

Apr  4 12:39:06: OSPF: Retransmitting request to 85.91.126.1 on     Vlan199

Apr  4 12:39:06: OSPF: Send LS REQ to 85.91.126.1 length 1500 LSA     count 125

Apr  4 12:39:09: OSPF: Rcv LS UPD from 85.91.126.1 on Vlan199 length     56 LSA count 1

Apr  4 12:39:09: OSPF: Rcv LS UPD from 85.91.126.1 on Vlan199 length     1516 LSA count 44

Apr  4 12:39:09: OSPF: Rcv LS UPD from 85.91.126.1 on Vlan199 length     244 LSA count 6

Apr  4 12:39:11: OSPF: Rcv LS UPD from 85.91.126.1 on Vlan199 length     64 LSA count 1

Apr  4 12:39:11: OSPF: Rcv LS UPD from 85.91.126.1 on Vlan199 length     424 LSA count 11

Apr  4 12:39:11: OSPF: Retransmitting request to 85.91.126.1 on     Vlan199

Apr  4 12:39:11: OSPF: Send LS REQ to 85.91.126.1 length 1500 LSA     count 125

Apr  4 12:39:13: OSPF: Rcv hello from 85.91.126.1 area 0 from     Vlan199 77.94.161.58

Apr  4 12:39:13: OSPF: End of hello processing

Apr  4 12:39:15: OSPF: Send hello to 224.0.0.5 area 0 on Vlan199     from 77.94.161.59

Apr  4 12:39:15: OSPF: Rcv LS UPD from 85.91.126.1 on Vlan199 length     64 LSA count 1

Apr  4 12:39:15: OSPF: Rcv LS UPD from 85.91.126.1 on Vlan199 length     208 LSA count 5

Apr  4 12:39:16: OSPF: Retransmitting request to 85.91.126.1 on     Vlan199

Apr  4 12:39:16: OSPF: Send LS REQ to 85.91.126.1 length 1500 LSA     count 125

Apr  4 12:39:21: OSPF: Retransmitting request to 85.91.126.1 on     Vlan199

Apr  4 12:39:21: OSPF: Send LS REQ to 85.91.126.1 length 1500 LSA     count 125

Apr  4 12:39:23: OSPF: Rcv hello from 85.91.126.1 area 0 from     Vlan199 77.94.161.58

Apr  4 12:39:23: OSPF: End of hello processing

Apr  4 12:39:25: OSPF: Send hello to 224.0.0.5 area 0 on Vlan199     from 77.94.161.59

Apr  4 12:39:26: OSPF: Retransmitting request to 85.91.126.1 on     Vlan199

Apr  4 12:39:26: OSPF: Send LS REQ to 85.91.126.1 length 1500 LSA     count 125

Apr  4 12:39:30: OSPF: Rcv LS UPD from 85.91.126.1 on Vlan199 length     64 LSA count 1

Apr  4 12:39:31: OSPF: Retransmitting request to 85.91.126.1 on     Vlan199

Apr  4 12:39:31: OSPF: Send LS REQ to 85.91.126.1 length 1500 LSA     count 125

Apr  4 12:39:32: OSPF: Rcv hello from 85.91.126.1 area 0 from     Vlan199 77.94.161.58

Apr  4 12:39:32: OSPF: End of hello processing

Apr  4 12:39:34: OSPF: Rcv LS UPD from 85.91.126.1 on Vlan199 length     64 LSA count 1

Apr  4 12:39:34: OSPF: Rcv LS UPD from 85.91.126.1 on Vlan199 length     64 LSA count 1

Apr  4 12:39:35: OSPF: Send hello to 224.0.0.5 area 0 on Vlan199     from 77.94.161.59

Apr  4 12:39:36: OSPF: Retransmitting request to 85.91.126.1 on     Vlan199

Apr  4 12:39:36: OSPF: Send LS REQ to 85.91.126.1 length 1500 LSA     count 125

Apr  4 12:39:41: OSPF: Killing nbr 85.91.126.1 on Vlan199 due to     excessive (25) retransmissions

Apr  4 12:39:41: %OSPF-5-ADJCHG: Process 1, Nbr 85.91.126.1 on     Vlan199 from LOADING to DOWN, Neighbor Down: Too many     retransmissions

How i can fix this retransmissions? Why it happens?

Everyone's tags (2)
2 REPLIES
Cisco Employee

OSPF Neighbor Down: Too many retransmissions

HI Maxim,

I see you have an MTU mismatch between the two devices. You have formally solved it using the ip ospf mtu-ignore command on both routers but if the packets are indeed sent so large from one device that the are considered oversized on the other, they will be dropped, possibly resulting in the adjacency flapping as you see here.

Is it by any means possible to align the MTU sizes?

Best regards,

Peter

New Member

OSPF Neighbor Down: Too many retransmissions

Hi Maxim,

I also faced a issue like this here the neighborship was down everytime.

The neighborship was between 2nos 65k core switches.

The issue that I found was one of the 65k was using 99% of the CPU. That was the reason the opsf was not

getting reply to packets sent to other neighbor. I actually tried increasing the dead timer on both side but still

it didn't worked unless the CPU process was down.

Once the cpu process was down the neighborship worked fine.

Regards

Narayan Dev Sarma

7058
Views
0
Helpful
2
Replies