Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

OSPF not working

HI,

I have pasted the configuration of my routers. Although the show ip osfp database shows the osfp data, it is not passing the traffic. I have given the static, the dynamic ospf routing is not wokring, What may be the problem ? The ISP 2 is working in OSFP routing but the ISP 1 is not working with OSPF.

Regards,

Mero

Head Office

==========

interface GigabitEthernet0/0

description ***** Connected To Switch  *****

ip address 10.10.0.1 255.255.255.0

ip ospf message-digest-key 1 md5 7 XXXXXXXX

ip ospf cost 10

ip ospf priority 2

duplex auto

speed auto

!

interface GigabitEthernet0/1

description ***** Connected To ISP 1*****

ip address 10.10.25.1 255.255.255.0

ip ospf message-digest-key 1 md5 7 XXXXXXXX

ip ospf cost 60

duplex auto

speed auto

!

interface GigabitEthernet0/2

description ***** CONNECTED TO ISP 2 *****

ip address 10.10.24.1 255.255.255.0

ip ospf message-digest-key 1 md5 7 XXXXXXXX

ip ospf priority 10

duplex auto

speed auto

router ospf 1

log-adjacency-changes

area 0 authentication message-digest

network 10.10.0.1 0.0.0.0 area 0

network 10.10.24.1 0.0.0.0 area 0

network 10.10.250.251 0.0.0.0 area 0

network 10.10.25.1 0.0.0.0 area 0

default-information originate

Branch Office

==================

interface FastEthernet0/0

description ***** Connected To LAN  *****

ip address 10.10.10.100 255.255.255.0

ip ospf message-digest-key 1 md5 7 XXXXXXXX

ip ospf cost 0

ip ospf priority 2

duplex auto

speed auto

!

interface FastEthernet0/1

description ***** Connected To ISP 1*****

ip address 10.10.25.100 255.255.255.0

ip ospf message-digest-key 1 md5 7 XXXXXXXX

ip ospf cost 60

duplex auto

speed auto

!

interface FastEthernet0/2

description ***** CONNECTED TO ISP 2 *****

ip address 10.10.24.100 255.255.255.0

ip ospf message-digest-key 1 md5 7 XXXXXXXX

ip ospf priority 50

duplex auto

speed auto

router ospf 1

log-adjacency-changes

area 0 authentication message-digest

network 10.10.10.100 0.0.0.0 area 0

network 10.10.24.100 0.0.0.0 area 0

network 10.10.250.100 0.0.0.0 area 0

network 10.10.25.100 0.0.0.0 area 0

3 ACCEPTED SOLUTIONS

Accepted Solutions

OSPF not working

Are you saying that only one ISP is being used to send/receive traffic and the other one is not??

a network diagram might help. Also, please note that yo uhave cost configured on the interfaces etc.

Higher the cost lower the preference of the link.  So, please check the metrics so maybe do a

sh ip route 10.10.10.100 on Head Office and see the cost advertised etc.

HTH

Kishore

OSPF not working

To my understanding, you say that you are not learning prefixes from your branch via ISP1? If thats the case, then you have to delete those cost parameters on the interface connecting to ISP1 (both sides). By that you will achieve equal cost load balancing. Incase if you just wondering why you don't see the prefixes of branch via ISP1 then to see that you need to use show ip ospf database from your head office. You would see that OSPF is aware of the prefixes via ISP1 as well. Due to the cost parameters configured on the interface, OSPF doesn't inject that bad cost route into the routing table.

Hope this clarifies.

Thanks

Vivek

Re: OSPF not working

Hi,

It should be advertised normally the way primary ip addresses are. The difference when you use routing protocols is that the source ip address for sending the routing updates ,establishing neighors and all is done using primary address. So, AFAIK neighbors are never etablished on a secondary ip address.

The whole idea of secondary ip address is to enable you to use extend your hosts range . i.e if you have a /24 subnet you can have 254 hosts in it but if you need to add another 100 then you can add another subnet under the same interface as a secondary ip address. the hosts in that will be advertised the same way the primary ip address is  as far routing updates are considered

Does this help. please ask if you need more info

HTH

Kishore

4 REPLIES

OSPF not working

Are you saying that only one ISP is being used to send/receive traffic and the other one is not??

a network diagram might help. Also, please note that yo uhave cost configured on the interfaces etc.

Higher the cost lower the preference of the link.  So, please check the metrics so maybe do a

sh ip route 10.10.10.100 on Head Office and see the cost advertised etc.

HTH

Kishore

OSPF not working

To my understanding, you say that you are not learning prefixes from your branch via ISP1? If thats the case, then you have to delete those cost parameters on the interface connecting to ISP1 (both sides). By that you will achieve equal cost load balancing. Incase if you just wondering why you don't see the prefixes of branch via ISP1 then to see that you need to use show ip ospf database from your head office. You would see that OSPF is aware of the prefixes via ISP1 as well. Due to the cost parameters configured on the interface, OSPF doesn't inject that bad cost route into the routing table.

Hope this clarifies.

Thanks

Vivek

New Member

Re: OSPF not working

Hey Guys,

Sorry, there was a mistake in conf file, i have edited it and it's working now.

Is there any solution if I have got 2,3 secondary ip in a single interface ? Please suggests if their is any kind of solution for dynamic routing for secondary ip.

Regards,

Mero

Re: OSPF not working

Hi,

It should be advertised normally the way primary ip addresses are. The difference when you use routing protocols is that the source ip address for sending the routing updates ,establishing neighors and all is done using primary address. So, AFAIK neighbors are never etablished on a secondary ip address.

The whole idea of secondary ip address is to enable you to use extend your hosts range . i.e if you have a /24 subnet you can have 254 hosts in it but if you need to add another 100 then you can add another subnet under the same interface as a secondary ip address. the hosts in that will be advertised the same way the primary ip address is  as far routing updates are considered

Does this help. please ask if you need more info

HTH

Kishore

659
Views
0
Helpful
4
Replies