Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

OSPF over non Broadcast

Guys I have a very weird issue I am helping out a buddy and I cant get OSPF to form up. Now let me throw out there I'm not a newbie to R&S but I'm not a CCIE. I can get the point to point serial interfaces to ping each other but I can't get ospf to see each other as neighbors. I have 3 routers one in Chicago one in LA and one in New Jersey. Before we sent the routers out I connected back to back serial cables to the routers and ospf formed up and saw each other as neighbors. The routing tables populated etc. Now we get the routers out to the locations and OSPF wont form up. The serial interfaces can ping each other and there are no erros on the line but they wont talk as neighbors. Its weird because we can change the encapsulation from hdlc to ppp and the circuit comes up with both encapsualations. I suspect the ISP sold this to my buddy as point to point but its probably some non broadcast media like frame in the backbone between Chicago to LA. Here is the config for Chicago and LA. Lets just begin here and assume if this works New Jersey will to.

Chicago:

controller T1 0/0/1

framing esf

clock source internal

linecode b8zs

channel-group 23 timeslots 1-24 speed

64

interface Serial0/0/1:23

description LA California T1

ip address 172.16.0.5 255.255.255.252

encapsulation ppp

router ospf 1

router-id 1.1.1.1

log-adjacency-changes

network 1.1.1.1 0.0.0.0 area 0

network 10.100.1.0 0.0.0.255 area 1

network 172.16.0.0 0.0.0.3 area 0

network 172.16.0.4 0.0.0.3 area 0

default-information originate always

ip route 0.0.0.0 0.0.0.0 10.100.1.1

LA:

interface Serial0/1/0

ip address 172.16.0.6 255.255.255.252

encapsulation ppp

!

router ospf 1

router-id 5.5.5.5

log-adjacency-changes

network 5.5.5.5 0.0.0.0 area 0

network 10.200.5.0 0.0.0.255 area 5

network 172.16.4.0 0.0.0.3 area 0

I guess my question is if this is a non broadcast network. I am very confused about the configuration: This isnt frame-relay at the last miles, there are no DLCIs, and there are no subinterfaces at the Chicago router. Each interface leads directly to its opposite end so I shouldnt run into split-horizon issues.

So how do I configure this? My guess is I will put the statements: ip ospf point-to-point non-broadcast on all serial interfaces and I will configure neighbor statements at the Chicago router to the oposite end of the serial interfaces. Like this:

Chicago:

controller T1 0/0/1

framing esf

clock source internal

linecode b8zs

channel-group 23 timeslots 1-24 speed

64

interface Serial0/0/1:23

description LA California T1

ip address 172.16.0.5 255.255.255.252

encapsulation ppp

ip ospf point-to-point non-broadcast

router ospf 1

router-id 1.1.1.1

log-adjacency-changes

network 1.1.1.1 0.0.0.0 area 0

network 10.100.1.0 0.0.0.255 area 1

network 172.16.0.0 0.0.0.3 area 0

network 172.16.0.4 0.0.0.3 area 0

default-information originate always

neighbor 172.16.0.6

neighbor 172.16.0.2

ip route 0.0.0.0 0.0.0.0 10.100.1.1

LA:

interface Serial0/1/0

ip address 172.16.0.6 255.255.255.252

encapsulation ppp

ip ospf point-to-point non-broadcast

!

router ospf 1

router-id 5.5.5.5

log-adjacency-changes

network 5.5.5.5 0.0.0.0 area 0

network 10.200.5.0 0.0.0.255 area 5

network 172.16.4.0 0.0.0.3 area 0

Can anybody add some useful input. I certianly dont want to do DR/BDR elections etc. BTW the provider is crappy XO Communications. If anyone can reference any XO stories to help coroborate my theroy.

1 ACCEPTED SOLUTION

Accepted Solutions

Re: OSPF over non Broadcast

Hi there,

First of all on LA there is either a mistake or a typo mistake "network 172.16.4.0 0.0.0.3 area 0", it should be "network 172.16.0.4 0.0.0.3 area 0".

You only need DR/BDR in broadcast networks, in non-broadcast network there is no need for DR/BDR, and the split horizon is only disabled by default when using frame-relay not PPP. But since each interface leads directly to its opposite end so you shouldn't run into split-horizon issues.

HTH, please rate if it does,

Mohammed Mahmoud.

5 REPLIES

Re: OSPF over non Broadcast

Hi there,

First of all on LA there is either a mistake or a typo mistake "network 172.16.4.0 0.0.0.3 area 0", it should be "network 172.16.0.4 0.0.0.3 area 0".

You only need DR/BDR in broadcast networks, in non-broadcast network there is no need for DR/BDR, and the split horizon is only disabled by default when using frame-relay not PPP. But since each interface leads directly to its opposite end so you shouldn't run into split-horizon issues.

HTH, please rate if it does,

Mohammed Mahmoud.

New Member

Re: OSPF over non Broadcast

DOH!!!!!!!!! you are right I fat fingered the network statment. I dont know if this will alleviate the problem, I might still be facing a NBMA senario but I will let you know tommorrow when I am on site. Thanks, somtimes it takes an extra set of eyes to look things over objectively.

New Member

Re: OSPF over non Broadcast

Hi,

looking at your initial config, I believ your network is already in point-to-point network type beacuase of the use of PPP encapsulation.

your other altrnative could be configuring point-to -multipoint on these links as they do not require any additional neighbor commands and also do not require DR/BDR. (unlike non-broadcast which does require DR/BDR election).

Re: OSPF over non Broadcast

Hey there,

There is a few issues here.

Firstly, on the LA router, you're not putting the serial0/1/0 interface into the network specified by ospf, which means it'll not be speaking ospf out of that interface.

The link that you've got seems to be a simple leased line, rather than a specific frame relay link.

I would change the encapsulation to hdlc (but set a "reload in 10" first!) on both sides of the link, rather than PPP (unless there's a reason you're running PPP?) Then take out the "ip ospf point-to-point non-broadcast" command, as it's not needed. Change that ospf network command and you should be in business.

If none of that works and you're having real trouble with the link (it should be ok), then you can always build a tunnel and route over that, but you shouldn't need to.

Also - if it were non-broadcast, you'd need to put in neighbour statements on both side of the link, as that changes the packet type from the ospf multicast address to a unicast one the specified neighbour.

Let me know how it goes!

Regards,

LH

oh - How come you're running on s0/0/1:23 on the chicago router rather than s0/0/1?

AND have you ever seen Dynagen? It's a router simulator, a poor mans lab if you will. Check it out: http://www.dynagen.org/ Using this you can fire up the test routers and put it over a leased line or frame, then have a play with the configs.

New Member

Re: OSPF over non Broadcast

Hi, the reason I am running ppp is incase my budy decideds to increase capacity and drop in another T1 so we can multilink them up without having to bring down the circuit. Another guy pointed out my "fat finger" config on the LA router of the serial interface. The reason the chicago router is 0/0/1:23 instead of 0/1/0 is becase it is an WIC-2MFT so you have to configure the channels to be Data vs. CAS vs. PRI thats just how it looks when its configured for Data. I'll tell you guys how it goes after I get on site tommorrow. Thanks everyone. PS I'll check out that dynagen..sounds cool.

646
Views
5
Helpful
5
Replies
CreatePlease to create content