Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

OSPF problem

Hii,

I am configuring OSPF between two cisco L3 switches 4510 & 4507 (as of now between these switches static routes are confugured). Configured properly but it is not working..checked by removing the static routes.

router ospf 1

network 10.10.10.0 255.255.255.252 0.0.0.3 area 0

network 10.10.10.4 255.255.255.248 0.0.0.7 area 0

Where i am doing mistake pls. guide me.

Regards

30 REPLIES
Cisco Employee

Re: OSPF problem

Sam,

These network statements are invalid. They should use the wild mask bits only (0.0.0.3 and 0.0.0.7) not the subnet mask (255.255.255.252, 255.255.255.248). By using the following wildcard bits (0.0.0.3 and 0.0.0.7) you will include interfaces in the following ranges in area 0:

10.10.10.0-10.10.10.3

10.10.10.0-10.10.10.7

As you can see the second statement covers the first one.

Is your interface between the two devices in this range?

Regards

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
New Member

Re: OSPF problem

Hii,

Sorry i have typed wrong configs by mistake. It is actually as:-

router ospf 1

network 10.10.10.4 0.0.0.7 area 0

network 10.10.10.0 0.0.0.3 area 0

network scenerio is like this -===>

Cisco 4507 Switch ---> Cisco 4510 Switch ---> Cisco Router (on which these routes are running for one connectivity, /30 for WAN & /29 for their LAN).

Pls help.

New Member

Re: OSPF problem

Hi Net,

Could you elaborate the problem .

Do you mean OSPF routes are not coming to the routing tables in the switches or they are not forming neighbor relationship.

Chao

Vishwa

New Member

Re: OSPF problem

Hii Vishwa,

Yes u r right,

neither OSPF routes coming to routing table. Not showing neighbor status.

No output after executing command "sh ip ospf neighbor".

regards

Hall of Fame Super Silver

Re: OSPF problem

Hello Sam,

follow Leo's suggestions about debug;

you may be facing an MTU mismatch issue between the two devices.

Hope to help

Giuseppe

New Member

Re: OSPF problem

check whether the subnet mask on both side of links are the same(must for ospf) and try to ping from both ends.If this is successful...check sh log...if something is reflecting...some ospf logs....

Hall of Fame Super Gold

Re: OSPF problem

Try debug:

debug ip ospf adj

debug ip ospf events

debug ip ospf hello

New Member

Re: OSPF problem

Hello all,

OSPF neighbor is now establised between two switches. But still the two routes running for lease lines (10.XX.XX.XX pool, /30 & /28 ) is still not reachable with OSPF after removing static route.

Regards

Hall of Fame Super Silver

Re: OSPF problem

Hello Sam,

are network ... area commands present for the IP subnets associated to the leased lines?

post a sh ip route 10.x.x.x

May I ask you what change you did to make the two switches to build an OSPF adjacency ?

This can help to make this a complete story.

Hope to help

Giuseppe

New Member

Re: OSPF problem

Hello,

PLease to avoid any confusion here i an enclosing the scenrio where i am configuring OSPF (Between Cisco Switch"A" & Cisco Switch"B").

Dear Giuseppe :>> I have made modification in network(10.10.1.6 & 10.10.1.5) under OSPF after which neighbor established.

Switch_A(config)#

router ospf 1

network 10.10.1.6 0.0.0.0 area 0

network 10.10.10.0 0.0.0.3 area 0

network 10.10.10.4 0.0.0.7 area 0

Switch_B(config)#

router ospf 1

network 10.10.1.5 0.0.0.0 area 0

network 10.10.10.0 0.0.0.3 area 0

network 10.10.10.4 0.0.0.7 area 0

+++++++++++++++++++++++++

As updated in previous posts, As present there is static route configured on Switch A towards SwitchB and then towards Cisco Router. And as i want to run OSPF between Switch A & Switch B. I am facing the problem with Lease line (WAN & LAN) route reachable when removing static routes after configuring respective networks in OSPF(As shown in above logs).

Please help to fullfill as required.

New Member

Re: OSPF problem

Hello,

PLease to avoid any confusion here i an enclosing the scenrio where i am configuring OSPF (Between Cisco Switch"A" & Cisco Switch"B").

Dear Giuseppe :>> I have made modification in network(10.10.1.6 & 10.10.1.5) under OSPF after which neighbor established.

Switch_A(config)#

router ospf 1

network 10.10.1.6 0.0.0.0 area 0

network 10.10.10.0 0.0.0.3 area 0

network 10.10.10.4 0.0.0.7 area 0

Switch_B(config)#

router ospf 1

network 10.10.1.5 0.0.0.0 area 0

network 10.10.10.0 0.0.0.3 area 0

network 10.10.10.4 0.0.0.7 area 0

+++++++++++++++++++++++++

As updated in previous posts, As present there is static route configured on Switch A towards SwitchB and then towards Cisco Router. And as i want to run OSPF between Switch A & Switch B. I am facing the problem with Lease line (WAN & LAN) route reachable when removing static routes after configuring respective networks in OSPF(As shown in above logs).

Please help to fullfill as required.

Hall of Fame Super Silver

Re: OSPF problem

Hello Sam,

you have two options:

a) extend OSPF on 7613 device and have network area commands on it for the wan links ip subnets and for the link C7613 - Switch B.

b) on switch B you leave the static routes but you add

router ospf 1

red static subnets

network ... area commands are effective only for connected interfaces in OSPF.

This is the reason why the solutions are or to extend the ospf domain or to have switch B to inject in OSPF the routes from its own routing table (without removing the static routes)

Hope to help

Giuseppe

New Member

Re: OSPF problem

Hello Giuseppe,

Option A)--> I want to run OSPF between Switch A & Switch B only. Hence not extending OSPF to Router.

Option B)--> PLease confirm the purpose of this command on Switch B==>

router ospf 1

red static subnets

Simply asking b'coz we have other Static route also on Switch B. Will this command affect them too(i.e those static route which are not advertised under OSPF)..?

Regards

Hall of Fame Super Silver

Re: OSPF problem

Hello Sam,

option B needs to be refined using a route-map to avoid to redistribute all static routes.

access-list 33 permit 10.10.10.8 0.0.0.3

access-list 33 permit 10.101.10.12 0.0.0.3

route-map selected_routes permit 10

match ip address 33

router ospf 1

red static route-map selected_routes subnets

Adapt access-list 33 to real ip subnets of the wan links that you want to reach from SwitchA.

Hope to help

Giuseppe

New Member

Re: OSPF problem

Hello,

access-list 33 permit 10.10.10.8 0.0.0.3

access-list 33 permit 10.101.10.12 0.0.0.3

route-map selected_routes permit 10

match ip address 33

Why this above this are required in Switch B. especially ACL 33.

Hall of Fame Super Silver

Re: OSPF problem

Hello Sam,

that is a route filter that decides what static routes have to be published in the OSPF domain without the filter you would advertise in OSPF also other static routes that are present in IP routing table of SwitchB.

Hope to help

Giuseppe

New Member

Re: OSPF problem

Hii Giuseppe,

I was meaning about this ACL -->

access-list 33 permit 10.10.10.8 0.0.0.3

access-list 33 permit 10.101.10.12 0.0.0.3

Actually here in OSPF we are advertising route/network for 10.10.10.0 & 10.10.10.4 but in ACL provided by you it seems form 10.10.10.8 & 10.101.10.12

Hall of Fame Super Silver

Re: OSPF problem

Hello Sam,

I couldn't see the whole thread story so I had just provided an example the ACL has to be written to match your effective subnets

10.10.10.0/30

10.10.10.4/30

sorry for the confusion I've caused

Hope to help

Giuseppe

New Member

Re: OSPF problem

Hello Giuseppe/Friendzs,

Two more basic querries...

1) As of now default route is running between Switch A & Switch B i.e On switch B default route is advertised towards Switch A. After Configuring OSPF we'll remove the default route from Switch B. Hope it will work properly(ROute learn via new OSPF config) as like now with default route.

2) As mentioned on network diagram Switch A is running with BGP(with WAN/Provider network),after running OSPF on it(for Switch B and extended network). Hope there will not be any affect on BGP route learning process or something else. All will be proper as now.

Regards

Hall of Fame Super Silver

Re: OSPF problem

Hello Sam,

a) be aware that SwitchA can be using the default route to reach other networks not redistributed into OSPF so you need to consider also if making SwitchB to advertise an OSPF default route with

router ospf 1

default-information originate

b) the changes you are doing shouldn't influence the eBGP session unless SwitchA is sending a default route on provider based on the presence of a default route int its IP routing table.

BGP network commands for WAN Ip subnets work well regardless of the origin of the routes in the IP routing table so moving from static routes to OSPF routes don't cause problems.

Hope to help

Giuseppe

New Member

Re: OSPF problem

Hello Giuseppe,

Thanks but little confusion on Point A.

For Point A) you mean after removing default route from Switch B (Which is toward Switch A) i have to configure "default-information originate" under router ospf 1 on Switch B only (i.e not on Switch A) ..rest all OK.

Point B) is OK. As i understand that there would not be any problem on WAN BGP session with OSPF configuration.

Hall of Fame Super Silver

Re: OSPF problem

Hello Sam,

a) I didn't understand I thought it was the opposite in this case it is SwitchA that should use the default-originate command under router ospf process

Hope to help

Giuseppe

New Member

Re: OSPF problem

Hello Giuseppe,

Again i am confused... :-)

See...default route is configured on Switch "B" pointing towards Switch "A" IP.

Hence "default-originate" command should be on Switch "B". Please confirm once more command should be on Switch "A" or on Switch "B". ..Sorry.. for incovineience.

regards

Hall of Fame Super Silver

Re: OSPF problem

Hello Sam,

when you use static default routes you configure them on Ry pointing to Rx.

If you want to achieve a similar result when using a dynamic routing protocol like OSPF, the command has to be configured on the device that has to advertise the route to the other one so going back to my example it has to be configured on Rx.

In your case it is the same: it is SwitchB that has to receive a default route, so the default-information has to be configured on SwitchA.

Hope to help

Giuseppe

New Member

Re: OSPF problem

Hi Giuseppe

Thank Buddy for clearing this.

Pls suggest me for this last question.

I skipped to mention about one more static route (This route is for production devices connected/extended from Switch "B" as like router shown is diagram on previous post i.e for access port connectivity from switch B) which is configured on Switch A pointing towards Switch B IP .i.e "Ip route 10.10.1.32 255.255.255.224 10.10.1.5"

For this route also we need to advertise the route under OSPF on both the switches

ie.

Router OSPF 1

network 10.10.1.32 0.0.0.31 area 0

Please correct if i am wrong...

Regards

Hall of Fame Super Silver

Re: OSPF problem

Hello Sam,

you need to include the required subnets as network command on SwitchB only or in the ACL used in the redistribute static in SwitchB if it is a static route also.

Again when moving to dynamic routing protocol the router that had the static route is the one that has to receive the OSPF external route, and so the OSPF config has to be done on the other device.

as I explained you cannot use a network command for static routes (this can be done in BGP but not in OSPF)

you need simply to add a third line to the ACL with a permit for this required network.

Hope to help

Giuseppe

New Member

Re: OSPF problem

Hi Giuseppe,

This time "ip route 10.10.1.32 255.255.255.224 10.10.1.5" is configure on Switch "A".

and one(first IP) IP of this pool 10.10.1.33 is configured on Switch B (on one Vlan).

Still you think that no network command is required on Switch A or on Switch B under OSPF config. only ACL need to be configuered on Switch B for this pool... ?

regards

Hall of Fame Super Silver

Re: OSPF problem

Hello Sam,

>> d one(first IP) IP of this pool 10.10.1.33 is configured on Switch B

then

add a network.. area statement under router ospf on SwitchB

Hope to help

Giuseppe

New Member

Re: OSPF problem

Hii Giuseppe,

Fine Sir..

Will remove the static route for 10.10.1.32 netwrok from Switch "A" and will configure network command for the same under Router OSPF on Switch "B" only ....without any ACL for this subnet on any switch.

regards

188
Views
0
Helpful
30
Replies
CreatePlease to create content