Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

OSPF Question

I have a 6509 and a 3662 that have different paths to a remote network, 10.32.56.0/21. They are neighbors to each other; however, they don't seem to be passing any routing information about this network. Can someone help me figure out what I'm overlooking? Thanks.

6509

----------

6509#sho ip ospf neigh

Neighbor ID Pri State Dead Time Address Interface

192.168.254.1 50 FULL/BDR 00:00:37 10.32.17.1 Vlan1

192.168.58.33 1 FULL/BDR 00:00:35 192.168.58.161 Vlan99

10.32.254.65 1 FULL/DR 00:00:37 10.32.254.65 Vlan254

6509#

6509#sho ip route | i 10.32.56.0

O IA 10.32.56.0/21 [110/6] via 192.168.58.161, 07:00:25, Vlan99

6509#

6509#sho run

...

router ospf 1

log-adjacency-changes

redistribute static subnets

network 10.0.0.0 0.255.255.255 area 10

network 172.16.0.0 0.0.255.255 area 10

network 192.168.0.0 0.0.255.255 area 10

...

6509#

3662

----------

JH_MDF_3662#sho ip ospf neigh

Neighbor ID Pri State Dead Time Address Interface

192.168.58.174 100 FULL/DR 00:00:32 10.32.17.3 FastEthernet0/

0

192.168.58.190 0 FULL/ - 00:00:38 10.32.254.6 Serial1/0:0

10.32.254.18 0 FULL/ - 00:00:38 10.32.254.18 Serial2/0:0

192.168.58.222 0 FULL/ - 00:00:34 10.32.254.22 Serial2/2:0

192.168.58.238 0 FULL/ - 00:00:31 10.32.254.26 Multilink1

10.32.254.14 0 FULL/ - 00:00:31 10.32.254.14 Serial2/1:0

JH_MDF_3662#

JH_MDF_3662#sho ip route | i 10.32.56.0

O 10.32.56.0/21 [110/66] via 10.32.254.18, 07:12:39, Serial2/0:0

JH_MDF_3662#

JH_MDF_3662#sho run

...

router ospf 1

log-adjacency-changes

redistribute static subnets

network 10.32.254.4 0.0.0.3 area 11

network 10.32.254.12 0.0.0.3 area 15

network 10.32.254.16 0.0.0.3 area 12

network 10.32.254.20 0.0.0.3 area 13

network 10.32.254.24 0.0.0.3 area 14

network 10.0.0.0 0.255.255.255 area 10

network 172.16.0.0 0.0.255.255 area 10

network 192.168.0.0 0.0.255.255 area 10

...

JH_MDF_3662#

3 REPLIES
Purple

Re: OSPF Question

Hi Tim,

I'm not sure I understand the exact issue you are facing. You stated that the two devices were not passing any routing info about the 10.32.56.0/21 network and yet, both have that route in their routing tables. So what exactly is the problem ?

Paresh

New Member

Re: OSPF Question

Sorry, I should have been more elaborate. The 3662 is pointing to 10.32.56.0 through 10.32.254.18 on one of its serial interfaces with a metric of 66. The 6509 is pointing to 10.32.56.0 through 192.168.58.161 on one of its vlans with a metric of 6. Why doesn't the 3662 point to the 6509 for the 10.32.56.0 network? Thanks.

Purple

Re: OSPF Question

Hi Tim,

There is a very good reason why you are seeing this behaviour. When ranking the merits of various routes, OSPF assigns preference to them in the following order:

- intra-area

- inter-area

- external type 1

- external type 2

Therefore, OSPF will always prefer intra-area routes over inter-area routes. Now, looking at the 3662, the route-type for the 10.32.56.0/21 is O (which signifies that it is an intra-area). The route on the 6509 is an IA route, which signifies that it is an inter-area route. Therefore, the metric does not even come into the calculation at all. The 3662 will always prefer the intra-area route.

Hope that helps - pls rate the post if it does.

Paresh

92
Views
0
Helpful
3
Replies