Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

OSPF question

i have 2 routers in the OSPF stub area 1. they are now working fine in the network after I installed them last week. I just don't understand why there's no ospf neibor relationship betwn these 2 routers. R1's routing table has static route to go outside although I set the AD as 250.

R1:

router ospf 50

log-adjacency-changes

area 1 stub

network 172.26.67.8 0.0.0.3 area 1

!

ip default-gateway 172.26.67.9

ip classless

ip route 0.0.0.0 0.0.0.0 172.26.67.9 250

R2:

router ospf 50

router-id 172.26.64.178

log-adjacency-changes

area 1 stub

passive-interface default

no passive-interface Serial0

network 172.26.64.178 0.0.0.0 area 1

network 172.26.67.8 0.0.0.3 area 1

these 2 routers are directly connected via subnet 172.26.67.8/30

anybody knows the root cause?

6 REPLIES
Blue

Re: OSPF question

Two routers will become neighbors if the following parameters are agreed upon:

Area ID - The two routers sharing a common network segment must have their interfaces configured to be in the same area.

Authentication - OSPF allows for configuration of a password for a specified area. Routers that want to become neighbors must exchange the same password over the common segment.

Hello and Dead intervals - The hello interval is the amount of time between hello packets that a router sends out on an OSPF-enabled interface. The dead interval is the amount of time, in seconds, that a router will wait for a hello packet from a neighbor before declaring the neighbor down. These interval times are included in the hello packet and must be agreed upon by neighbors.

Stub area flag - Two neighboring routers must also agree on the stub area flag in the hello packets in order to become neighbors. (Stub areas will also be discussed later.)

Check these out for starters..

HTH

Victor

New Member

Re: OSPF question

Thanks Victor

I just found out that R2 has the "passive-interface default" command which is prohibiting R2's E0 interface from sending OSPF update. I removed this command and fixed the problem. Cheers.

Hall of Fame Super Silver

Re: OSPF question

Wayne

You have provided some information. But perhaps not enough for us to really figure out what the problem is. Posting more complete configs (especially including the interface configs) would be helpful. It would also be nice if you would post the output of show ip ospf and show ip ospf interface on both of the routers.

Based on what you have posted I will take a quess at the problem. On R2 you have configured this:

passive-interface default

no passive-interface Serial0

which means that all interfaces except one are passive and will not form neighbor relationships. My guess is that serial 0 which is not passive is not the interface that connects these 2 routers.

If that is not correct then please give us more information to work with.

[edit] after posting my response I see your posting which confirms that the problem was the passive interface configuration. Congratulations on finding the source of your problem.

HTH

Rick

New Member

Re: OSPF question

hi, Rick, you rock. You got it right. I found this after posting this question. Thanks for your help anyway. I saw your replies to some questions in this forum, it's always worth reading!

Hall of Fame Super Silver

Re: OSPF question

Wayne

Thank you for the kind words - and for the rating.

The forum is an excellent place to learn about Cisco networking. I encourage you to continue your participation in the forum.

HTH

Rick

New Member

Re: OSPF question

yes, I will. I'm a bit Junior in the real job although I've done CCNP. It's a good place to learn stuff.

232
Views
10
Helpful
6
Replies
CreatePlease login to create content