Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

OSPF route between Nexus7010 and ASR 1004

I cannot receive any OSPF route from Nexus 7010 to ASR1004 even they are both OSPF neighbour. I have attached the config for both, Please can you have a look and advise.Both Nexus and ASR part of Area2.

NEXUS 7010

------------------

------------------

router ospf CORE

  vrf 1

    router-id 172.31.254.14

    rfc1583compatibility

  rfc1583compatibility

interface loopback1

  ip router ospf CORE area 0.0.0.1

interface Ethernet1/1.134

  ip router ospf CORE area 0.0.0.1

interface Ethernet1/2.135

  ip router ospf CORE area 0.0.0.1

interface Ethernet1/3.136

  ip router ospf CORE area 0.0.0.1

interface Ethernet1/4.137

  ip router ospf CORE area 0.0.0.1

interface Ethernet1/5.138

  ip router ospf CORE area 0.0.0.1

interface Ethernet1/7.140

  ip router ospf CORE area 0.0.0.2

interface Ethernet1/7.140

  ip router ospf CORE area 0.0.0.2

interface loopback1

  description OSPF ISP_2

  ip address 172.31.254.14/32

  ip router ospf CORE area 0.0.0.1

NK7_MUR2-ISP_2# sh ip ospf neighbors vrf 1

OSPF Process ID CORE VRF 1

Total number of neighbors: 6

Neighbor ID     Pri State            Up Time  Address         Interface

172.31.254.5      1 FULL/BDR         00:33:58 10.36.0.118     Eth1/1.134

172.31.254.3      1 FULL/DR          00:33:56 10.36.0.122     Eth1/2.135

172.31.254.6      1 FULL/DR          00:34:01 10.36.0.126     Eth1/3.136

172.31.254.4      1 FULL/DR          00:33:54 10.36.0.130     Eth1/4.137

172.31.254.13     1 FULL/DR          00:34:00 10.36.0.133     Eth1/5.138

172.31.254.16     1 FULL/BDR         00:34:01 10.36.0.142     Eth1/7.140

ASR 1004

----------------

----------------

router ospf 2

router-id 172.31.254.16

network 10.36.0.140 0.0.0.3 area 2

network 172.31.254.16 0.0.0.0 area 2

interface Loopback1

ip address 10.31.254.16 255.255.255.255

interface TenGigabitEthernet0/0/0.140

description Conexion VDC ISP2 1/7.140

encapsulation dot1Q 140

ip address 10.36.0.142 255.255.255.252

ASR_2#sh ip ospf neighbor 

Neighbor ID     Pri   State           Dead Time   Address         Interface

172.31.254.14     1   FULL/DR         00:00:38    10.36.0.141     TenGigabitEthernet0/0/0.140

ASR_2#sh ip route ospf

Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2

       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

       ia - IS-IS inter area, * - candidate default, U - per-user static route

       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP

       a - application route

       + - replicated route, % - next hop override

Gateway of last resort is not set

4 REPLIES

Re: OSPF route between Nexus7010 and ASR 1004

Hi,

bienvenido a CSC ;-)

Ethernet1/7.140 seems to be the only link in Area 2 on the Nexus.

Does it have any active interfaces in the Backbone Area too?

Otherwise it will not act as an ABR between Area 1 and 2; so perhaps a Virtual Link will be needed to connect the Area 2 link to the backbone if it has to be Area 2 for this connection.

What does 'show ip ospf database' show on the ASR?

HTH

Rolf

Re: OSPF route between Nexus7010 and ASR 1004

I guess it would not have to create the virtual link because there  physical connection between the Nexus and backboone

The nexus has multiple interfaces in area 1:

interface loopback1

  ip router ospf CORE area 0.0.0.1

interface Ethernet1/1.134

  ip router ospf CORE area 0.0.0.1

interface Ethernet1/2.135

  ip router ospf CORE area 0.0.0.1

interface Ethernet1/3.136

  ip router ospf CORE area 0.0.0.1

interface Ethernet1/4.137

  ip router ospf CORE area 0.0.0.1

interface Ethernet1/5.138

  ip router ospf CORE area 0.0.0.1

ASR_2#sh ip ospf database

            OSPF Router with ID (172.31.254.16) (Process ID 2)

                Router Link States (Area 2)

Link ID         ADV Router      Age         Seq#       Checksum Link count
172.31.254.14   172.31.254.14   1777        0x80000072 0x00D9DB 1
172.31.254.16   172.31.254.16   2015        0x80000027 0x004698 1

                Net Link States (Area 2)

Link ID         ADV Router      Age         Seq#       Checksum
10.36.0.141     172.31.254.14   1777        0x8000002B 0x00F0F9

Re: OSPF route between Nexus7010 and ASR 1004

The problem is that you have two non-backbone Areas (1 and 2) but no interface in Area 0, so the Nexus is not an Area Border Router. You can check that with 'show ip ospf border-router' on the ASR.

As you can see, the Link State Database shows only the single link in Area 2 (2 Router-LSAs and the corresponing Network-LSA), nothing more (originated from other Areas).

If the new link has to be in Area 2, you will have to connect it somehow to Area 0; this is an OSPF requirement.

Useful Link: OSPF Design Guide

HTH

Rolf

OSPF Design Guide

OSPF route between Nexus7010 and ASR 1004

Hi Dimitri,

The issue has been solved.

We have configured the virtual link between routers and everything works fine.

Thank you very much.

Regards

245
Views
5
Helpful
4
Replies
CreatePlease login to create content