Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

OSPF routing problem

Hi,

I am configuring OSPF on my 2 routers connected with a switch, below is the topology:

Router 1 (area 2) ---- Switch ---- Router2 (area 3)

Foe some reasons I don't want to use area 0 and I want to communicate the networks behind the routers configured for area 2 and area 3.

from Router 2, I can access all the networks behind Router 1 but not vice versa. What could be the problem?

Below is the OSPF config on routers:

Router 1

------------

router ospf 2
network 10.2.2.0 0.0.0.7 area 2
network 10.3.3.0 0.0.0.7 area 2
network 172.16.1.0 0.0.0.255 area 2
network 172.16.2.0 0.0.0.255 area 2
network 172.16.3.0 0.0.0.255 area 2
network 172.16.4.0 0.0.0.255 area 2

Router 2

------------

router ospf 3
network 10.2.2.0 0.0.0.7 area 2
network 10.3.3.0 0.0.0.7 area 2
network 172.16.5.0 0.0.0.255 area 3
network 172.16.6.0 0.0.0.255 area 3
network 172.16.7.0 0.0.0.255 area 3

Thanks,

Pawan

1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Re: OSPF routing problem

Hi Pawan,

As Jon has mentioned, the problem here is without area 0, routes in area 3 cannot be passed into area 2; as a result router 1 can not access any networks behind router 2.

The proper solution is to add area 0 as transit area. Another workaround, you can add "default-information originate always" at Router 2; that way Router 1 can use default route to reach networks behind Router 2.

HTH,

Lei Tian

3 REPLIES
Hall of Fame Super Blue

Re: OSPF routing problem

Pawan

This won't work as you have set it up. Router2 can access the networks behind router1 because they share interfaces in the same area ie. area 2. And if you only have one area then it can be any area number ie. it does not have to be area 0. But as soon as you have 2 areas in OSPF one of them has to be area 0 for the routes to be propogated.

OSPF is a hierarchical routing protocol where traffic between areas that are not area 0 must go via area 0. So traffic from area 2 cannot get to area 3 and vice-versa without their being an area 0 in between.

Jon

Cisco are currently donating money to the Haiti earthquake appeal for every rating so please consider rating all helpful posts.

Cisco Employee

Re: OSPF routing problem

Hi Pawan,

As Jon has mentioned, the problem here is without area 0, routes in area 3 cannot be passed into area 2; as a result router 1 can not access any networks behind router 2.

The proper solution is to add area 0 as transit area. Another workaround, you can add "default-information originate always" at Router 2; that way Router 1 can use default route to reach networks behind Router 2.

HTH,

Lei Tian

New Member

Re: OSPF routing problem

Thanks Lei and Jon

217
Views
0
Helpful
3
Replies