Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

OSPF setup help

I have my setup as shown below.

Area0<----Router-A---->Area0<----Router-B---->Area1

ROUTERB:
interface GigabitEthernet0/0
ip address 10.10.126.9 255.255.255.192
ip ospf message-digest-key 1 md5 XXXXYYYY

interface GigabitEthernet0/1
ip address 10.10.88.142 255.255.255.192
ip ospf message-digest-key 100 md5 7 XXXXYYYY
ip ospf priority 254

router ospf 65182
log-adjacency-changes
area 0 authentication message-digest
area 1 authentication message-digest
network 10.10.88.142 0.0.0.0 area 1
network 10.10.126.0 0.0.0.63 area 0

Do I also need to put the following command on router-B?

network 10.10.126.0 0.0.0.63 area 1

2 ACCEPTED SOLUTIONS

Accepted Solutions

Re: OSPF setup help

Hi Avilt,

if you write this command the below statement

network 10.10.126.0 0.0.0.63 area 0

will be over written as

network 10.10.126.0 0.0.0.63 area 1

and your ospf config will look like

router ospf 65182
log-adjacency-changes
area 0 authentication message-digest
area 1 authentication message-digest
network 10.10.88.142 0.0.0.0 area 1
network 10.10.126.0 0.0.0.63 area 1

and the impact is you will not find ospf adjacency between RouterA and Router B.

Regards

Mahesh

Re: OSPF setup help

Hello ,

No , the 10.10.126. segment is part of Area 0,

This route you will see it in Area 1 , if you have more then Router B in this area , as intre-area route (O IA).

Dan

9 REPLIES
Cisco Employee

Re: OSPF setup help

Is 10.10.126.0 0.0.0.63 in area 1 or area 0? You need to configure which interface is going to participate in OSPF in Router A. You need to put the OSPF authentication in Router A also.

HTH,

jerry

Re: OSPF setup help

Hi Avilt,

if you write this command the below statement

network 10.10.126.0 0.0.0.63 area 0

will be over written as

network 10.10.126.0 0.0.0.63 area 1

and your ospf config will look like

router ospf 65182
log-adjacency-changes
area 0 authentication message-digest
area 1 authentication message-digest
network 10.10.88.142 0.0.0.0 area 1
network 10.10.126.0 0.0.0.63 area 1

and the impact is you will not find ospf adjacency between RouterA and Router B.

Regards

Mahesh

Community Member

Re: OSPF setup help

Hi,

Can you share the configuration for both the routers ?

Community Member

Re: OSPF setup help

ROUTERA:

interface GigabitEthernet0/0

ip address 10.10.126.54 255.255.255.192

ip ospf message-digest-key 1 md5 XXXXYYYY

interface GigabitEthernet0/1

ip address 10.10.88.199 255.255.255.240

ip ospf message-digest-key 1 md5 7 XXXXYYYY

router ospf 65182

log-adjacency-changes

area 0 authentication message-digest

network 10.10.88.199 0.0.0.0 area 0

network 10.10.126.0 0.0.0.63 area 0

--------------------------------------------------

ROUTERB:

interface GigabitEthernet0/0

ip address 10.10.126.9 255.255.255.192

ip ospf message-digest-key 1 md5 XXXXYYYY

interface GigabitEthernet0/1

ip address 10.10.88.142 255.255.255.192

ip ospf message-digest-key 100 md5 7 XXXXYYYY

router ospf 65182

log-adjacency-changes

area 0 authentication message-digest

area 1 authentication message-digest

network 10.10.126.0 0.0.0.63 area 0

network 10.10.88.142 0.0.0.0 area 1

On router-B, in order to advertise the route to 10.10.126.0 in area-1, do I also need to put the following command on router-B?

network 10.10.126.0 0.0.0.63 area 1

Re: OSPF setup help

Hello ,

No , the 10.10.126. segment is part of Area 0,

This route you will see it in Area 1 , if you have more then Router B in this area , as intre-area route (O IA).

Dan

Community Member

Re: OSPF setup help

I am bit confused about the usage of network command in OSPF.
For example in the following config, if I do not add the command "network 10.10.126.9 0.0.0.0 area 0" is the router going to advertise the route to network 10.10.126.0 in area0 on the interface GigabitEthernet0/1?


TESTROUTER:
interface GigabitEthernet0/0
ip address 10.10.126.9 255.255.255.192

interface GigabitEthernet0/1
ip address 10.10.88.142 255.255.255.192
ip ospf message-digest-key 1 md5 7 XXXXYYYY

router ospf 65182
log-adjacency-changes
area 0 authentication message-digest
network 10.10.88.142 0.0.0.0 area 0

Re: OSPF setup help

Hi Avilt,

In case of ospf if you want to enable ospf on interface then you will have to put the IP  of that interface

via. network command in ospf.

Network command serve two purpose.

1- Help in estlablishing neighbor relationship with connected interface device

2- and advt. that network in ospf

For your query. You already have ospf route for network 10.10.126.0 on router B then you need not to put it in network command to advt. on your interface

GigabitEthernet0/1. You will see that network advt. on other routers as Net summary link.

Please issue "sh ip ospf database" to verify the same on router connected to GigabitEthernet0/1

Please feel free to write if you have any more query

Regards

Mahesh

Community Member

Re: OSPF setup help

Thank You Mahesh.

Just to clarify further regarding point 2

2- and advt. that network in ospf

Is this command goint to advertise every active route even though the network command is not defined for every network ?

Re: OSPF setup help

Hi Avilt,

This will advt. the route covered under this subnet. I mean if you put 10.10.10.0/16 then it will advt. all active route

belongs to that subnet

Hope this is clear to you

Regards

mahesh

410
Views
0
Helpful
9
Replies
CreatePlease to create content