Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

OSPF tunneling

Hi,

I have two 2821 routers running OSPFv3 with Address Family IPv4. These two routers are connected via static routes through a WAN therefore OSPF router on one side of the WAN is not running or advertising to the other OSPF router on the other side of the WAN.

Would you please give some advice on how to configure tunneling for OSPF instead of using static routes?

Here're parts of router running-config files.

hostname Router4

!

policy-map FQ

class class-default

fair-queue

!

interface GigabitEthernet0/0

Description external WAN

ip address 192.x.x.104 255.255.255.0

duplex auto

speed auto

ipv6 enable

ospfv3 instance 64 network manet

ospfv3 1 area 0 address-family ipv4 instance 64

service-policy output FQ

!

interface GigabitEthernet0/1

Description internal LAN

ip address 192.x.2.40 255.255.255.0

duplex auto

speed auto

ipv6 enable

ospfv3 instance 64 network manet

ospfv3 1 area 0 address-family ipv4 instance 64

!

router ospfv3 1

router-id 4.4.4.4

log-adjacency-changes

!

address-family ipv4

timers spf 1 2

router-id 4.4.4.4

exit-address-family

!

ip forward-protocol nd

ip route 142.x.x.0 255.255.255.0 192.x.x.172

ip route 192.x.4.0 255.255.255.0 192.x.x.172

--------------------

hostname Router5

!

policy-map FQ

class class-default

fair-queue

!

interface GigabitEthernet0/0

Description external WAN

ip address 142.x.x.105 255.255.255.0

duplex auto

speed auto

ipv6 enable

ospfv3 instance 64 network manet

ospfv3 1 area 0 address-family ipv4 instance 64

service-policy output FQ

!

interface GigabitEthernet0/1

Description internal LAN

ip address 192.x.4.40 255.255.255.0

duplex auto

speed auto

ipv6 enable

ospfv3 instance 64 network manet

ospfv3 1 area 0 address-family ipv4 instance 64

!

router ospfv3 1

router-id 5.5.5.5

log-adjacency-changes

!

address-family ipv4

timers spf 1 2

router-id 5.5.5.5

exit-address-family

!

ip forward-protocol nd

ip route 192.x.x.0 255.255.255.0 142.x.x.172

ip route 192.x.2.0 255.255.255.0 142.x.x.172

Thanks.

5 REPLIES
Cisco Employee

Re: OSPF tunneling

HI,

You can configure a GRE tunnel between both routers and run OSPF in it instead of the WAN interface.

Never try with OSPFv3 and IPv4 AF so.

HTH

Laurent.

Re: OSPF tunneling

Community Member

Re: OSPF tunneling

Hi,

I could not get to the document from the URL you provided:

http://www.cisco.com/en/US/partner/tech/tk583/tk372/technologies_configuration_example09186a00800a43f6.shtml

Would you please check. Thanks.

Hall of Fame Super Silver

Re: OSPF tunneling

Hello Hugh,

also for me it is the first time I see this address-family IPv4 with OSPFv3.

I don't know if it is only a typing error but I see two different ipv4 addresses on WAN interfaces

R4: 192.x.x.104/24

R5: 142.x.x.105/24

are these supposed to be connected directly between them?

if so they should share a common ipv4 subnet.

But I see here

http://www.cisco.com/web/strategy/docs/gov/OSPFv3_aag.pdf

that this condition with different IPv4 subnets should be supported if the two devices are directly connected because communication use IPv6 link local for LSA exchange.

Or if devices in the middle are able to send IPV4 family related LSA downstream.

However, it's not clear how the forwarding of IPv4 packets over the IPv6 only path can work: it requires some form of tunneling of IPv4 into IPv6 packets. (the opposite of what is done in most cases today where it is IPv6 tunneled into IPv4)

Hope to help

Giuseppe

Community Member

Re: OSPF tunneling

Hello all,

Thanks for all the advices. After set up tunneling for ospf and removed all the static routes, ospf routers were able to advertise to the other and I can ping every node on ospf networks. However, I have not tested with IPv6 addresses. Not sure if ospf tunneling will forwards IPv6. Here're changes to the config files:

hostname Router4

!

policy-map FQ

class class-default

fair-queue

!

interface Tunnel0

ip address 10.1.1.1 255.255.255.0

tunnel source GigabitEthernet0/0

tunnel destination 142.x.x.105

!

interface GigabitEthernet0/0

Description external WAN

ip address 192.x.x.104 255.255.255.0

duplex auto

speed auto

ipv6 enable

ospfv3 instance 64 network manet

ospfv3 1 area 0 address-family ipv4 instance 64

service-policy output FQ

!

interface GigabitEthernet0/1

Description internal LAN

ip address 192.x.2.40 255.255.255.0

duplex auto

speed auto

ipv6 enable

ospfv3 1 area 0 address-family ipv4 instance 64

!

router ospfv3 1

router-id 4.4.4.4

log-adjacency-changes

!

address-family ipv4

timers spf 1 2

router-id 4.4.4.4

exit-address-family

!

ip forward-protocol nd

--------------------

hostname Router5

!

policy-map FQ

class class-default

fair-queue

!

interface Tunnel0

ip address 10.1.1.2 255.255.255.0

tunnel source GigabitEthernet0/0

tunnel destination 142.x.x.105

!

interface GigabitEthernet0/0

Description external WAN

ip address 142.x.x.105 255.255.255.0

duplex auto

speed auto

ipv6 enable

ospfv3 instance 64 network manet

ospfv3 1 area 0 address-family ipv4 instance 64

service-policy output FQ

!

interface GigabitEthernet0/1

Description internal LAN

ip address 192.x.4.40 255.255.255.0

duplex auto

speed auto

ipv6 enable

ospfv3 1 area 0 address-family ipv4 instance 64

!

router ospfv3 1

router-id 5.5.5.5

log-adjacency-changes

!

address-family ipv4

timers spf 1 2

router-id 5.5.5.5

exit-address-family

!

ip forward-protocol nd

Thanks.

386
Views
0
Helpful
5
Replies
CreatePlease to create content