Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

p2p basic config

Hi

I have a very basic setup but I guess I am missing something. I am configuring a p2p between 2 locations. I can ping other end router interfaces but not any other devices on the remote networks. I dont need any Internet connectivity but just need between 2 locations.

R1#sh run

no network-clock-participate slot 1

no network-clock-participate wic 0

no aaa new-model

ip subnet-zero

ip cef

!

interface FastEthernet0/0

ip address 172.16.1.1 255.255.255.0

duplex auto

speed auto

!

interface Serial0/0

ip address 10.1.0.1 255.255.255.252

encapsulation ppp

service-module 56k clock rate 64

!

ip classless

ip route 192.168.1.0 255.255.255.0 10.1.0.2

----------------------------------------------------------------

R2#sh run

no network-clock-participate slot 1

no network-clock-participate wic 0

no aaa new-model

ip subnet-zero

ip cef

interface FastEthernet0/0

ip address 192.168.1.1 255.255.255.0

duplex auto

speed auto

!

interface Serial0/0

ip address 10.1.0.2 255.255.255.252

encapsulation ppp

service-module 56k clock rate 64

!

ip classless

ip route 0.0.0.0 0.0.0.0 192.168.1.10

ip route 172.16.1.0 255.255.255.0 10.1.0.1

Thanks

1 ACCEPTED SOLUTION

Accepted Solutions

Re: p2p basic config

If it's a windows server the remote PCs probably need a WINS server for name resolution. Alternatively, you can use a LMHOST file on the local PC. Have a look at this link.

http://support.microsoft.com/kb/150800

HTH

Sundar

11 REPLIES

Re: p2p basic config

1. Are the LAN devices using the correct default gateway address. R1 LAN devices would have to use 172.16.1.1 and R2 LAN devices would have to use 192.168.1.1 as their default gateway.

2. If the default gateway is correct, is ICMP being denied on those hosts. I believe Windows firewall would block ICMP echo replies from being sent. If you can ping the LAN devices from the local router then it would eliminate the possibility of firewall being the issue.

HTH

Sundar

New Member

Re: p2p basic config

Hi Sundar

Thanks for the reply. Actually there are 2 ISPs as in the attached network setup. So the default gateway is another router on the same LAN which is 172.16.1.2.

I can ping R3(172.16.1.2) and the server(172.16.1.10) from R1(172.16.1.1) but I cannot ping the same if I give the source interface s0/0(10.1.0.1)

I can ping R1 from R2 and I cannot ping R3.

R2#sh ip route 172.16.1.10

Routing entry for 172.16.1.0/24

Known via "static", distance 1, metric 0 (connected)

Routing Descriptor Blocks:

* directly connected, via Serial0/0, permanent

Route metric is 0, traffic share count is 1

New Member

Re: p2p basic config

could you pls post the show ip route of R3 ?

tks

ric

Re: p2p basic config

Venkat,

It looks like R3 (Linksys) might be routing all traffic destined to 10.1.0.0/30 and 192.168.1.0/24 to the Internet. You can one of two things

1. add route(s) for these two subnets on R3 to forward traffic to 172.16.1.1(R1)

(or)

2. change the gateway of all PCs to 172.16.1.1 and add a default route on R1 to forward traffic to 172.16.1.2.

HTH

Sundar

New Member

Re: p2p basic config

Hi Sundar

Thanks for the reply. I realized this yesterday when I draw the network sent to you. So I added routes below on Linksys

Dest - 10.1.0.0/30

GW - 172.16.1.1

Hop count - 1

Dest - 192.168.1.0/24

GW - 172.16.1.1

Hop count - 3

Now I can ping my server 172.16.1.10 from R2 which is good. However I tried to ping few other devices on the network (eg., 172.16.1.20,21 GW: 172.16.1.2) and I cannot reach them. It doesnt make any sense to me. But I guess these are printers and probably wouldnt bother much about that.

As my R2 location does not have a server, as this p2p in place, can DNS and AD traffic be forwarded over the link?

Also I just configured default route on R1 pointing to R3

Thanks

Venkat

Re: p2p basic config

To transport non-routable (bridged) protocol traffic over the same p2p connection you would have to configure integrated routing & bridging (IRB). This would allow bridged and routed traffic use the p2p connection. DNS uses IP and you should be ok there. What protocol does AD use?

New Member

Re: p2p basic config

For some reason I can ping the server with IP but not with the name from the remote location. I can ping with name from LAN.

I believe AD (Active directory) is IP based. So that should work too right?

Do I need any more configuration on Cisco or Linksys routers to get this working?

Please advise

Thanks

Re: p2p basic config

If it's a windows server the remote PCs probably need a WINS server for name resolution. Alternatively, you can use a LMHOST file on the local PC. Have a look at this link.

http://support.microsoft.com/kb/150800

HTH

Sundar

New Member

Re: p2p basic config

Hi Sundar

It worked after I add the WINS. Also pinging to other systems is also resolved. I was onsite today and found that is blocked by Windows firewall.

Appreciate all your help. Is that possible to send your email id to techtips03@yahoo.com. It is not for sending requests to your email but I got something to ask.

Thanks

Venkat

Re: p2p basic config

Glad your problem is solved. Thanks for the rating!

I have sent an email to you.

New Member

Re: p2p basic config

Hi Ric

The routes are in my other post

Thanks

244
Views
5
Helpful
11
Replies