Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

parallel GRE Tunnels to connect different and overlapped VRF

Hi to all,

I'm working on a simple implementation of VRF and gre tunnel to archive this topology :

                     Ce1

                      |

ce11----f1/0-MLS1-f0/0----f0/0-R1-f0/1----f0/1-R2-f0/0----f0/0-MLS2-f1/0----ce21
                     |                                                                   |
                    f1/1                                                             f1/1
                     |                                                                   |
                  ce12                                                           ce22
Ce11 can speak only with Ce21
Ce12 can speak only with Ce22
Ce1 must speak with  Ce11, Ce12, MLS1, MLS2,Ce22, Ce21
Ce11,Ce12, Ce22, Ce21 are host in different Vlans on MLS (C3750) and the address plan is overlapped and i can't change it:
ce11 : 10.0.1.1/24 vlan 10 
ce12 : 10.0.1.1/24 vlan 20
ce21 : 10.0.2.1/24 vlan 10
ce22 : 10.0.2.1/24 vlan 20
for Ce1 i can choose any address  for ex. 10.0.253.0/24 VLAN 253
In MLS1 and MLS2 i configure the VLAN interface as gateway and i place them respectively in different Vrfs on MLS1/2
int vlan 10 vrf 10 rd:1:1
int vlan 20 vrf 20 rd 2:2
int vlan 253 is in global
between R1 and R2 there is OSPF and MLS1/2 f0/0 IP's are redistribute and global and connectivity it's ok and tested.
First Q :
To archive separation and connectivity
Ce11---Vrf 10--Tunnell 10---Vrf10--Ce21    and 
Ce12---Vrf 20--Tunnell 20---Vrf20--Ce22
I configure two tunnel gre  Tunnel 10 and 20 with their IPs in VRF 10 and VRF 20 respectively 
and source and destination global MLS1 f0/0----MLS2 f0/0.
on MLS1
interface Tunnel10
ip vrf forwarding 10
ip address 192.168.0.1 255.255.255.252
tunnel source f0/0 (212.0.1.1 255.255.255.252
tunnel destination 212.0.2.1 (f0/0 MLS2)
!
interface Tunnel20
ip vrf forwarding 20
ip address 192.168.0.5/ 255.255.255.252
tunnel source f0/0 (212.0.1.1  255.255.255.252)
tunnel destination 212.0.2.1 (f0/0 MLS2)

IP route 212.0.2.1 255.255.255.255 f0/0
IP route vrf 10 10.0.2.0 255.255.255.0 tunnel 10
IP route vrf 20 10.0.2.0 255.255.255.0 tunnel 20
on MLS2
interface Tunnel10
ip vrf forwarding 10
ip address 192.168.0.2 255.255.255.252
tunnel source f0/0 (212.0.2.1 255.255.255.252)
tunnel destination 212.0.1.1 (f0/0 MLS1)
!
interface Tunnel20
ip vrf forwarding 20
ip address 192.168.0.6/30
tunnel source f0/0 (212.0.2.1/ 255.255.255.252)
tunnel destination 212.0.1.1 (f0/0 MLS1)

IP route 212.0.1.1 255.255.255.255 f0/0
IP route vrf 10 10.0.1.0 255.255.255.0 tunnel 10
IP route vrf 20 10.0.1.0 255.255.255.0 tunnel 20
The tunnels are up up but i don't ping the remote IP of the tunnels.
If i try to do the same in global without VRf (and with not overlapped network for Cexx) with 2 different tunnel and all it's ok.
Second Q :
for Ce1 i have no idea to implement its goal  ???
i can use only VRF an GRE, maybe i can activate a routing protocol on MLSx
Please help !!!!  

1 REPLY
New Member

Re: parallel GRE Tunnels to connect different and overlapped VRF

first question solved : tu key

and for the second?

301
Views
0
Helpful
1
Replies
CreatePlease login to create content