Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

PBR Using Tracked BGP Route

Hello Guys,

My scenario is:

2 Sites interconnected by 2 MPLS Links and BGP between the routers.

I need some help to force some traffic to be routed using one Link based on Protocol or TCP Port.

But if the link goes down, I need the traffic to be send using another link.

I want to do a PBR using track that validates a specific BGP Route or BGP Neighbor.

Can someone tell me some tips for this case?

Best Regards.

Heleno Fagundes

Everyone's tags (1)
5 REPLIES
New Member

 Hi,For your two concerns.**2

 

Hi,

For your two concerns.

**2 Sites interconnected by 2 MPLS Links and BGP between the routers

 Do you have some sort of network diagram ????

**I want to do a PBR using track that validates a specific BGP Route or BGP Neighbor.

We can always apply a track and an IP sla monitoring an IP address which the router is receiving from its BGP peer which you wish to monitor.

 

I am sure if you provide me sample diagram/config i'll be able to give some more descriptive answer.

 

Regards,

HK

 

New Member

Hello,Attached the Topology

Hello,

Attached the Topology as you asked.

I would like to track the BGP Route, I do not want to trust in a ICMP Ping with SLA to track reachability of the neighbor.

If the neighbor loss the route and stop to announcing in BGP, my track using ICMP will continue OK, but the route is not in the table.

Because of that I need to use a PBR Working with BGP.

Is that possible?

Best Regards.

Heleno Fagundes

 

 

 

HelloHow are these peers

Hello

How are these peers connecting? - directly or logical? - I mean are they peering from a source logical ip address ( loopback) and LB over one ip address or are do you have two direct ebgp peers using the physical interfaces?

I assume you aslo have maximum paths configured?

FYI - PBR with tracking on the line protocol without ip sla would be an option or you may be able to use the bgp weight attribute.if applicable to your needs.

 

the latter would be something like this:

access-list 2 permit x.x.x.0 0.0.0.255
access-list 22 permit y.y.y.0 0.0.0.255


neighbor 10.0.0.1 route-map weight2 in
neighbor 10.0.1.1 route-map weight in

router bgp 65501
route-map weight2 permit 10
 match ip address 2
 set weight 30000
route-map weight2 permit 90
 set weight 25000

route-map weight22 permit 10
 match ip address 22
 set weight 30000
route-map weight22 permit 90
 set weight 25000

 

The alternate applied to the other router also.

 

res

Paul

 

 

Please don't forget to rate any posts that have been helpful. Thanks.
New Member

Hi Paul,My BGP Peers are

Hi Paul,

My BGP Peers are using the IP of Physical Interface and they are logically connected, not a Direct link...

I need to make a decision of routing based on the protocol of application(TCP/1494 for instance) and not based on IP Address.

I have many servers using this type of connection and I need to choose que route based on TCP Port. The use of specific destinations based on IP it's hard and not an alternative for me.

Because of that I think that I have to use PBR. But the problem is the Track based on ICMP, I want to track an BGP route to validate the PBR "set ip next-hop" step.

Best Regards

Heleno Fagundes

New Member

Hello,

Hello,

 

The problem was solved using PBR with a Tracked object matching an IP Route /32 announced by the alternative BGP path.

 

Example:

track 1 ip route 1.1.1.1/32 reachability
route-map alpha permit 10
 match ip address 101 
 set ip next-hop verify-availability 192.168.0.10 10 track 1
route-map alpha permit 20

 

More info:

http://www.cisco.com/c/en/us/td/docs/ios/12_2sb/feature/guide/sbaiptrk.html#wp1047054

http://www.cisco.com/c/en/us/td/docs/switches/lan/catalyst3560/software/release/12-2_52_se/configuration/guide/3560scg/sweot.html#wp1086250

 

Regards.

Heleno Fagundes

353
Views
0
Helpful
5
Replies