Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Performance issue

Hi I have a problem whit performance at one office. The office is connected ass follows:

Office 1 is connected to Office 2 who connected to office 3 where the problem is. All the servers are at office 1 so office 3 connects to the router in office 2 who redirect the traffic to office 1. I don’t know if it is my configuration which is wrong or it is the line where the error are.

So before I Cal my ISP I hope that someone could look at my configuration and se if it is correct. Thanks in advance (and sorry for my English)

The configuration is ass follows.

Office 1:

version 12.3

no aaa new-model

ip subnet-zero

no ip domain lookup

ip cef

!

interface FastEthernet0

ip address 192.168.5.254 255.255.255.0

speed auto

full-duplex

!

interface Serial0

description to oofice 2

ip address 192.168.251.5 255.255.255.252

encapsulation ppp

no fair-queue

!

ip classless

ip route 0.0.0.0 0.0.0.0 192.168.5.250

ip route 10.40.167.0 255.255.255.0 192.168.251.6

ip route 192.168.3.0 255.255.255.0 192.168.251.6

ip http server

Office 2:

version 12.3

mmi polling-interval 60

no mmi auto-configure

no mmi pvc

mmi snmp-timeout 180

no aaa new-model

ip subnet-zero

ip cef

no ip domain lookup

no ftp-server write-enable

interface FastEthernet0

ip address 192.168.3.254 255.255.255.0

speed auto

full-duplex

!

interface Serial0

description To Office 1

ip address 192.168.251.6 255.255.255.252

encapsulation ppp

no fair-queue

!

interface Serial1

description To office 3

ip address 192.168.251.101 255.255.255.252

encapsulation ppp

no fair-queue

!

ip classless

ip route 0.0.0.0 0.0.0.0 192.168.251.5

ip route 10.40.167.0 255.255.255.0 192.168.251.102

no ip http server

!

Office 3:

version 12.3

no aaa new-model

ip subnet-zero

no ip domain lookup

ip cef

!

interface FastEthernet0

ip address 10.40.167.254 255.255.255.0

speed auto

full-duplex

!

interface Serial0

description To office 2

ip address 192.168.251.102 255.255.255.252

encapsulation ppp

no fair-queue

!

ip classless

ip route 0.0.0.0 0.0.0.0 192.168.251.101

no ip http server

12 REPLIES

Re: Performance issue

Hi

is ur connectivity between office 2 and office 1 ok ? working without any drops ??

also about the connectivity between office 3 and office 2 ?

did u check up the same with show interface command for any errors like crc or input in the serial interfaces ??

how did u measure the performance over here with any speed limitation or any comparsion being made over here?

i feel there are different points of errors which uneed to isolate and try to find the exact probs or whether the prob exactly exists.

few diagnostic which u can do out here is to check with Ping commands and find out the latency between office 2 and office 1 and office 2 to office 3 and office 3 to office 1.

btw whts the bandwidth being subcribed between ur locations ??

from ur config the routing and the other aspects are fine since its a simple sort of P2P connectivity between 3 of ur offices..

regds

Re: Performance issue

Hi

The config is perfect.Just check the physical carrier.If possible post the "sh int s0" and "sh int s1" output of all the applicable routers

Regards

JD

New Member

Re: Performance issue

Hi

Thanks for the quick response. The error is that from office 3 the connection is very slow comparing to office 2 and office 1. I call my ISP and ask them to check if everything is ok.

Thanks again I post the “sh int” replies.

Office1:

Serial0 is up, line protocol is up

Hardware is PowerQUICC Serial

Description: Till 3 natet

Internet address is 192.168.251.5/30

MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,

reliability 255/255, txload 17/255, rxload 2/255

Encapsulation PPP, LCP Open

Open: CDPCP, IPCP, loopback not set

Keepalive set (10 sec)

Last input 00:00:00, output 00:00:00, output hang never

Last clearing of "show interface" counters 32w2d

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 158238

Queueing strategy: fifo

Output queue: 0/40 (size/max)

5 minute input rate 15000 bits/sec, 36 packets/sec

5 minute output rate 106000 bits/sec, 25 packets/sec

315534006 packets input, 1706123701 bytes, 0 no buffer

Received 0 broadcasts, 0 runts, 0 giants, 0 throttles

530 input errors, 217 CRC, 198 frame, 0 overrun, 0 ignored, 115 abort

258664417 packets output, 2831448854 bytes, 0 underruns

0 output errors, 0 collisions, 111 interface resets

0 output buffer failures, 0 output buffers swapped out

2 carrier transitions

DCD=up DSR=up DTR=up RTS=up CTS=up

New Member

Re: Performance issue

Office 2:

Serial0 is up, line protocol is up

Hardware is PowerQUICC Serial

Description: Till HBG

Internet address is 192.168.251.6/30

MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,

reliability 255/255, txload 3/255, rxload 16/255

Encapsulation PPP, LCP Open

Open: CDPCP, IPCP, loopback not set

Last input 00:00:00, output 00:00:00, output hang never

Last clearing of "show interface" counters 32w1d

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 4530

Queueing strategy: fifo

Output queue: 0/40 (size/max)

5 minute input rate 99000 bits/sec, 31 packets/sec

5 minute output rate 19000 bits/sec, 40 packets/sec

257118839 packets input, 2358853136 bytes, 0 no buffer

Received 0 broadcasts, 0 runts, 0 giants, 0 throttles

554 input errors, 366 CRC, 175 frame, 0 overrun, 0 ignored, 13 abort

313618130 packets output, 1587771271 bytes, 0 underruns

0 output errors, 0 collisions, 104 interface resets

0 output buffer failures, 0 output buffers swapped out

0 carrier transitions

DCD=up DSR=up DTR=up RTS=up CTS=up

Serial1 is up, line protocol is up

Hardware is PowerQUICC Serial

Description: Till 10natet

Internet address is 192.168.251.101/30

MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation PPP, LCP Open

Open: CDPCP, IPCP, loopback not set

Last input 00:00:35, output 00:00:00, output hang never

Last clearing of "show interface" counters 32w1d

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue: 0/40 (size/max)

5 minute input rate 7000 bits/sec, 11 packets/sec

5 minute output rate 11000 bits/sec, 12 packets/sec

47394474 packets input, 3096100507 bytes, 0 no buffer

Received 0 broadcasts, 0 runts, 0 giants, 0 throttles

67 input errors, 10 CRC, 23 frame, 0 overrun, 0 ignored, 34 abort

42595909 packets output, 16878717 bytes, 0 underruns

0 output errors, 0 collisions, 50912 interface resets

0 output buffer failures, 0 output buffers swapped out

0 carrier transitions

DCD=up DSR=up DTR=up RTS=up CTS=up

Office 3:

Serial0 is up, line protocol is up

Hardware is PowerQUICC Serial

Description: Till 3natet

Internet address is 192.168.251.102/30

MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation PPP, LCP Open

Open: CDPCP, IPCP, loopback not set

Keepalive set (10 sec)

Last input 00:00:00, output 00:00:00, output hang never

Last clearing of "show interface" counters 24w4d

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 21

Queueing strategy: fifo

Output queue: 0/40 (size/max)

5 minute input rate 6000 bits/sec, 8 packets/sec

5 minute output rate 4000 bits/sec, 9 packets/sec

37998772 packets input, 3275561007 bytes, 0 no buffer

Received 0 broadcasts, 0 runts, 0 giants, 0 throttles

12 input errors, 4 CRC, 4 frame, 0 overrun, 0 ignored, 4 abort

42744666 packets output, 2759784450 bytes, 0 underruns

0 output errors, 0 collisions, 4 interface resets

0 output buffer failures, 0 output buffers swapped out

2 carrier transitions

DCD=up DSR=up DTR=up RTS=up CTS=up

New Member

Re: Performance issue

Hej,

Try to remove no fair-queue from configuration (if there are no very strong reasons to have it). At the same time try to increase queue length. Especially in office 1.

Actually, it would be good to place servers to "hub site" if it possible.

//Mikhail Galiulin

New Member

Re: Performance issue

Hello,

Why do you use NO FAIR-QUEUE on all Serial interfaces?

It seems that it could be the cause of the problem. If you disable fair-queue the queing strategy becomes "FIFO". In this case the applications which sends fast a lot of large packets will force rest of traffic wait.

If you enable fair-queue router will start to balance individual traffic flows so that no one will consume too much links bandwidth over the time.

//Mikhail Galiulin

New Member

Re: Performance issue

Thanks for the replies.

I have turned on FAIR-QUEUE on all Serial interfaces

So I have to se if it helps. The bandwidths we use on all 3 locations are 2Mb lines.

New Member

Re: Performance issue

This is not a good sign (from serial in office 1):

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 158238

You need also at least increase queue length (or increase links capacity if it possible).

Check how this parameter changes with time. If you have the same drop rate all the time it is time to upgrade the link. Otherwise if the most of drops happen under some short periods of time when you have "peaks" in traffic it could be sufficient just to increase queue length and implement some kind of traffic shaping.

//Mikhail Galiulin

New Member

Re: Performance issue

Maybe this is a dumb question but how do I increase queue length?

New Member

Re: Performance issue

A final question. When I run the command show queue on se0

It says Available Bandwidth 1158 kilobits/sec but I have a 2024 kb line.

Does this men anything?

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: weighted fair

Output queue: 0/1000/64/0 (size/max total/threshold/drops)

Conversations 0/2/256 (active/max active/max total)

Reserved Conversations 0/0 (allocated/max allocated)

Available Bandwidth 1158 kilobits/sec

New Member

Re: Performance issue

I guess that this is because 1158 is 75% of 1544. 1544 is T1 link capacity. 75% of bandwidth recommended by Cisco as default maximum bandwidth leaving the rest 25% för layer 2 overhead and some other types of traffic. (see http://www.cisco.com/en/US/products/sw/iosswrel/ps1831/products_configuration_guide_chapter09186a00800c60d6.html) Why IOS treats your interface as T1 - I don't know. I have absollutelly same numbers on my routers (also connected to 2M links). May be sombody can explain this better than me - I just see this as a strange IOS feature.

So it seems that there is not so much importance in this particular number in your case.

//Mikhail Galiulin

199
Views
0
Helpful
12
Replies
CreatePlease to create content