Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
obi
New Member

pim multicast - basic config

I'm part of a group of sites that are trying to multicast to each other. I'm showing on the neighbor table and in mroute on one of the routers between locations, but am unable to get my streams to be picked up by others. I *can* see the stream from one of the other sites. While I wait for:

  • working site's television engineer to track down the person that set up their router

and

  • yes/no confirmation that my latest config is working (just heard. it's a no)

I thought I'd post it here. Very last change was to enable bidirectional multicast (which worked for someone in another thread).

Any insights would be tremendously appreciated.

First, a factory reset, followed by

gave myself a login, then pasted the following:

hostname MCST-ONLY-01

ip multicast-routing

ip pim rp-address 199.x.x.x

ip route 0.0.0.0 0.0.0.0 199.x.x.x

ip mroute 0.0.0.0 0.0.0.0 199.x.x.x

ip pim bidir-enable

interface f8

ip address 199.x.x.x 255.255.255.248

ip pim sparse-mode

interface vlan1

ip address 10.10.10.1 255.255.255.0

ip pim sparse-mode

resulting in the following config:

MCST-ONLY-01#show running-conf

Building configuration...

Current configuration : 3966 bytes

!

! Last configuration change at 20:55:15 UTC Tue Oct 1 2013 by obi

! NVRAM config last updated at 20:55:17 UTC Tue Oct 1 2013 by obi

! NVRAM config last updated at 20:55:17 UTC Tue Oct 1 2013 by obi

version 15.1

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname MCST-ONLY-01

!

boot-start-marker

boot-end-marker

!

!

logging buffered 51200 warnings

!

no aaa new-model

!

!

ip dhcp excluded-address 10.10.10.1

!

ip dhcp pool ccp-pool

import all

network 10.10.10.0 255.255.255.248

default-router 10.10.10.1

lease 0 2

!

!

ip cef

no ip domain lookup

ip domain name yourdomain.com

ip multicast-routing

no ipv6 cef

!

!

multilink bundle-name authenticated

!

!

license udi pid CISCO891-K9 sn FTX163886MG

!

!

interface FastEthernet0

no ip address

!

interface FastEthernet1

no ip address

!

interface FastEthernet2

no ip address

!

interface FastEthernet3

no ip address

!

interface FastEthernet4

no ip address

!

interface FastEthernet5

no ip address

!

interface FastEthernet6

no ip address

!

interface FastEthernet7

no ip address

!

interface FastEthernet8

ip address 199.x.x.x 255.255.255.248

ip pim sparse-mode

duplex auto

speed auto

!

interface GigabitEthernet0

no ip address

shutdown

duplex auto

speed auto

!

interface Vlan1

description $ETH-SW-LAUNCH$$INTF-INFO-FE 1$

ip address 10.10.10.1 255.255.255.0

ip pim sparse-mode

ip tcp adjust-mss 1452

!

interface Async1

no ip address

encapsulation slip

!

ip forward-protocol nd

!

!

ip http server

ip http access-class 23

ip http authentication local

ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

ip pim bidir-enable

ip pim rp-address 199.8.216.31

ip mroute 0.0.0.0 0.0.0.0 199.x.x.x

ip route 0.0.0.0 0.0.0.0 199.x.x.x

!

access-list 23 permit 10.10.10.0 0.0.0.7

no cdp run

!

!

control-plane

!

!

mgcp profile default

!

!

line con 0

login local

line 1

modem InOut

stopbits 1

speed 115200

flowcontrol hardware

line aux 0

line vty 0 4

access-class 23 in

privilege level 15

login local

transport input telnet ssh

line vty 5 15

access-class 23 in

privilege level 15

login local

transport input telnet ssh

!

end

MCST-ONLY-01#

thanks again.

Everyone's tags (2)
4 REPLIES

pim multicast - basic config

Multicasting networks have more design issues than configuration problems.

The configuration is fine. But we need to have a clear understanding of what we are trying to achieve and how the traffic will flow fron the source to this router.

My Questions : -

ip mroute 0.0.0.0 0.0.0.0 199.x.x.x

  1. This 199 IP, is it part of your AS ?
  2. Does this peer have pim enabled ?
  3. Do we have pim neighborship to that neighbor (show ip pim neighbor)?
  4. Is it different from (ip route 0.0.0.0 0.0.0.0 199.x.x.x) ?
  5. Where is RP 199.8.216.31 located in the network?
  6. Does this router have receivers for the Group G?(show ip igmp groups)
  7. Do you see (*,G) joins forwarded to pim neighbor upstream?
  8. Does the RP has (S,G) for the group?
  9. Is the RPF correct in the transit path from this router to RP?
  10. Why are you trying to run pim in bidir mode?
  11. Can you post a network diagram ?
  12. Also please post a mtrace 199.8.216.31 and a trace from RP to interface FastEthernet8 IP.
obi
New Member

pim multicast - basic config

Didn't even consider how confusing trying to mask my addresses would make things.

Short version:

THIS router, the one I'm working on, is 199.8.201.100

next hop is my ISP's router, 199.8.201.97 (which is the default route/mroute)

RP is somewhere at the ISP.

I have access to a web based console where I can enter sh commands.

To my knowledge all peers are PIM-enabled.

if i sh neighbor on my router, i see only .97

working on getting answers to the rest of your q's.

thanks for trying to help with this!

obi
New Member

Re: pim multicast - basic config

1. This 199 IP, is it part of your AS ?

I assume yes.

2. Does this peer have pim enabled ?

also assumptive yes

3. Do we have pim neighborship to that neighbor (show ip pim neighbor)?

my router shows this as the only neighbor:

Neighbor     Interface      Uptime/Expires    Ver   DR

Address                                             Prio/Mode         

199.8.201.97 FastEthernet8  22:53:56/00:01:34 v2    1 / S P G

4. Is it different from (ip route 0.0.0.0 0.0.0.0 199.x.x.x) ?

no, both are 199.8.201.97. the only thing I'm 100% sure about

5. Where is RP 199.8.216.31 located in the network?

beyond the next hop. checking with ISP

6. Does this router have receivers for the Group G?(show ip igmp groups)

MCST-ONLY-01#sh ip igmp groups

IGMP Connected Group Membership

Group Address    Interface                Uptime    Expires   Last Reporter   Group Accounted

239.0.1.38       Vlan1                    22:41:39  00:02:27  10.10.10.45

239.255.255.250  Vlan1                    22:41:39  00:02:28  10.10.10.4

233.0.87.102     Vlan1                    15:29:26  00:02:28  10.10.10.4

233.6.231.4      Vlan1                    22:41:40  00:02:26  10.10.10.35

233.6.231.3      Vlan1                    22:41:39  00:02:28  10.10.10.20

224.0.1.40       FastEthernet8            22:41:50  00:02:51  199.8.201.100

7.  Do you see (*,G) joins forwarded to pim neighbor upstream?

8. Does the RP has (S,G) for the group?

9. Is the RPF correct in the transit path from this router to RP?

These have been forwarded to the ISP

10. Why are you trying to run pim in bidir mode?

no good reason. saw it mentioned in another thread and assumed that since I was getting data in but not sending it out that it would be worth trying. Will switch it off if it's not doing me any good.

11. Can you post a network diagram ?

streaming source 233.6.231.4 (10.10.10.40)

  |

FE1 on router, vlan1 10.10.10.1

  |

FE8 on router 199.8.201.100

  |

ISP 199.8.201.97

12. Also please post a mtrace 199.8.216.31 and a trace from RP to interface FastEthernet8 IP.

MCST-ONLY-01#mtrace 199.8.216.31

Type escape sequence to abort.

Mtrace from 199.8.216.31 to 199.8.201.100 via RPF

From source (?) to destination (?)

Querying full reverse path...

0  199.8.201.100

-1  199.8.201.100 PIM  [default]

-2  199.8.201.97 None No route

I hope at least some of this is helpful. Thanks again.

Re: pim multicast - basic config

MCST-ONLY-01#mtrace 199.8.216.31

Querying full reverse path...

0  199.8.201.100

-1  199.8.201.100 PIM  [default]

-2  199.8.201.97 None No route

It seems the issue is not on your router but on the ISP router(199.8.201.97) connected to yours.

Possible issues -

  • Incorrect RPF for the RP
  • Pim not enabled on path upstream to RP

Please do a traceroute and ping from your router to 199.8.216.31 and let me know of the output.

How to be sure that issue is with the ISP -

  • traceroute and mtrace should have same results complete path, the hop where you see a deflection could potentially be the INTERESTING-HOP with problem
  • traceroute and mtrace should have same results for complete path the hop where you see a deflection could potentially be the INTERESTING-HOP with problem
  • Note that if the above traces are incomplete as in your example above especially mtrace then it means multicast RPF is broken
  • show ip mroute 233.6.231.4 should have the (*,G) as the receivers joins a group and as soon as the router receives the multicast stream it should have (S,G)

Example -

(1.1.1.1)Source----R1----R2----R3----R4----Receiver

Output of R4 where receiver joins 229.0.0.1 but no source is sending the stream

R4#show ip mroute 229.0.0.1

(*, 229.0.0.1), 00:00:07/00:02:52, RP 2.2.2.2, flags: SJCL

  Incoming interface: FastEthernet0/0, RPF nbr 34.0.0.3

  Outgoing interface list:

    FastEthernet0/1, Forward/Sparse, 00:00:07/00:02:52

Output of R4 where receiver joins 229.0.10.10 and source 1.1.1.1 connected to R1 is sending the multicast stream.

R4#show ip mroute 229.0.10.10

(*, 229.0.10.10), 00:00:11/stopped, RP 2.2.2.2, flags: SJCL

  Incoming interface: FastEthernet0/0, RPF nbr 34.0.0.3

  Outgoing interface list:

    FastEthernet0/1, Forward/Sparse, 00:00:11/00:02:48

(1.1.1.1, 229.0.10.10), 00:00:09/00:02:58, flags: LJT

  Incoming interface: FastEthernet0/0, RPF nbr 34.0.0.3

  Outgoing interface list:

    FastEthernet0/1, Forward/Sparse, 00:00:09/00:02:50

Output of mtrace to source from R4

R4#mtrace 1.1.1.1

Type escape sequence to abort.

Mtrace from 1.1.1.1 to 34.0.0.4 via RPF

From source (?) to destination (?)

Querying full reverse path...

0  34.0.0.4

-1  34.0.0.4 PIM  [1.1.1.0/24]

-2  34.0.0.3 PIM  [1.1.1.0/24]

-3  23.0.0.2 PIM  [1.1.1.0/24]

-4  12.0.0.1 PIM  [1.1.1.0/24]

-5  1.1.1.1

Output of trace to source from R4

R4#traceroute 1.1.1.1

Type escape sequence to abort.

Tracing the route to 1.1.1.1

  1 34.0.0.3 32 msec 52 msec 32 msec

  2 23.0.0.2 56 msec 64 msec 60 msec

  3 12.0.0.1 96 msec 106 msec 124 msec

If the multicast path is broken in between; you will see the mtrace also broken and hence we can identify the potential hop with the issue.

326
Views
0
Helpful
4
Replies
CreatePlease to create content