Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

PIM Sparse-Mode Config

Hi Friends..

Please find the attachment below...I need to know the configuration commands for the RP (Rendezvous Point) for PIM sparse-mode...My LHR and FHR are not coming in Neighbor state instead they remain in HELLO state...

Would be highly thankful for ur help...

THNX

RAJ

5 REPLIES
VIP Purple

Re: PIM Sparse-Mode Config

Hello,

you should configure ´ip multicast-routing´ on all 3 routers, then ´ip pim sparse-mode´ on all interfaces, as well as the command ´ip pim rp-address´ on all 3 routers. The RP must obviously be reachable form both routers.

Can you post the configurations of your routers ?

Regards,

GP

Community Member

Re: PIM Sparse-Mode Config

Hi Georg,

The LHR and FHR are emulated routers in IXIA Traffic generator which are configured with all the necessary parameters (unfortunately can't post their configs since it's configured in GUI). The RP is obviosuly reachable from LHR and FHR since this is back to back ethernet connectivity.However I am posting the config for RP as follows :

----------------CONFIGURATION STARTS-----------------

Building configuration...

Current configuration:

!

version 11.0

service udp-small-servers

service tcp-small-servers

!

hostname cisco2500

!

enable secret 5 $1$IOdN$Mn5ENom3p7nmW9Cu.gi4g.

enable password cisco

!

no ip domain-lookup

ip multicast-routing

ip dvmrp route-limit 7000

!

interface Ethernet0

ip address 10.1.1.1 255.255.255.0

ip pim sparse-mode

ip igmp join-group 225.1.0.1

ip igmp join-group 225.1.0.2

ip igmp join-group 225.1.0.3

ip igmp join-group 225.1.0.4

!

interface Ethernet1

ip address 20.1.1.1 255.255.255.0

ip pim sparse-mode

ip igmp join-group 225.1.0.1

ip igmp join-group 225.1.0.2

ip igmp join-group 225.1.0.3

ip igmp join-group 225.1.0.4

!

interface Serial0

no ip address

shutdown

!

interface Serial1

no ip address

!

ip pim rp-address 10.1.1.1 1

ip pim message-interval 10

access-list 1 permit 225.0.0.0 0.255.255.255

!

line con 0

line aux 0

transport input all

line vty 0 4

password cisco

login

!

end

----------------CONFIGURATION ENDS-------------------

THNX

RAJ

VIP Purple

Re: PIM Sparse-Mode Config

Hello Raj,

the configuration looks very much ok. The only thing I can think about is that your 2500 is running PIM version 1, while the IXIA multicats emulator supports version 2. Can you try and configure ´ip pim version 2´ on your 2500 interfaces ?

If that doesn´t help, or if the interfaces are already set to version 2, can you post the output of ´show ip mroute´ from one of the routers LHR or FHR ?

Regards,

GP

Community Member

Re: PIM Sparse-Mode Config

Hi Georg..

As I said the LHR and FHR are emulated routers so I won't be able to post their configs since they have a GUI...But I can u give the following info :

The host on LHR is 10.1.1.3 for which 10.1.1.2 is the tester (IXIA) port for which default gateway is 10.1.1.1 and the multicast source is 225.1.0.1 to 225.1.0.4

The host on FHR is 20.1.1.3 for which 20.1.1.2 is the tester (IXIA) port for which the default gateway is 20.1.1.1

On my FHR the RP is 10.1.1.1

On LHR it's again 10.1.1.1

If I try and do sh ip PIM neighbors, it doesn't show me anything...

I am also pasting the sh ip mroute & sh ip mroute count for RP :

--------------------sh ip mroute---------------------

(*, 225.1.0.1), 00:28:34/never, RP 10.1.1.1, flags: SCL

Incoming interface: Null, RPF nbr 0.0.0.0

Outgoing interface list:

Ethernet1, Forward/Sparse, 00:28:34/0:02:32

Ethernet0, Forward/Sparse, 00:28:34/0:02:28

(*, 225.1.0.2), 00:28:34/never, RP 10.1.1.1, flags: SCL

Incoming interface: Null, RPF nbr 0.0.0.0

Outgoing interface list:

Ethernet1, Forward/Sparse, 00:28:34/0:02:30

Ethernet0, Forward/Sparse, 00:28:35/0:02:29

(*, 225.1.0.3), 00:28:35/never, RP 10.1.1.1, flags: SCL

Incoming interface: Null, RPF nbr 0.0.0.0

Outgoing interface list:

Ethernet1, Forward/Sparse, 00:28:34/0:02:24

Ethernet0, Forward/Sparse, 00:28:35/0:02:28

(*, 225.1.0.4), 00:28:36/never, RP 10.1.1.1, flags: SCL

Incoming interface: Null, RPF nbr 0.0.0.0

Outgoing interface list:

Ethernet1, Forward/Sparse, 00:28:35/0:02:20

Ethernet0, Forward/Sparse, 00:28:36/0:02:29

----------------------------------------------------

------------------sh ip mroute count-----------------

IP Multicast Statistics - Group count: 4, Average sources per group: 0.00

Counts: Pkt Count/Pkts per second/Avg Pkt Size/Kilobits per second

Group: 225.1.0.1, Source count: 0, Group pkt count: 0

RP-tree: 0/0/0/0

Group: 225.1.0.2, Source count: 0, Group pkt count: 0

RP-tree: 0/0/0/0

Group: 225.1.0.3, Source count: 0, Group pkt count: 0

RP-tree: 0/0/0/0

Group: 225.1.0.4, Source count: 0, Group pkt count: 0

RP-tree: 0/0/0/0

-----------------------------------------------------

THNX

RAJ

VIP Purple

Re: PIM Sparse-Mode Config

Hello Raj,

check if the sender application has set the TTL value to 1. Your groups are not joining the SPT, for some reason.

Also, check this document, it has some more troubleshooting techniques:

IP Multicast Troubleshooting Guide

http://www.cisco.com/warp/public/105/mcastguide0.html

Regards,

GP

410
Views
0
Helpful
5
Replies
CreatePlease to create content