Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

PIM with two DRs?

Hi All,

Is it possible to have two DRs in a LAN? I have a L2 switch connected to a router which is elected as a DR, the streamers are connected to the same Switch. i need to connect another router to the same L2 switch and distribute the stream to another network.

When i added the other router, it looks like it is not receiving the multicast because the first router is elected as a DR.

Regards,

Anas

4 REPLIES

Re: PIM with two DRs?

Anas,

There was a load balancing pim rfc out there that addressed this type of issue. The rfc expired in 2013, but I can't find a replacement. According to http://www.cisco.com/en/US/prod/collateral/iosswrel/ps6537/ps6552/ps6592/whitepaper_c11-474791.html, under Alternating DR Priority, Cisco recommends that you put a DR on a separate vlan in order to support the same streams. They do state in the document that 50% of the users would still notice an outage, so I'm going to assume based on this document that there's not a way of having to DRs on the same lan.

Here's the RFC I was speaking about:

http://tools.ietf.org/html/draft-ietf-pim-drlb-02

HTH,
John

*** Please rate all useful posts ***

HTH, John *** Please rate all useful posts ***

Re: PIM with two DRs?

Anas,

John is correct. If you have more than one DR on a segment, one will be elected the DR (I believe this is based upon highest IP address) could be wrong though.. Nevertheless, that's what's causing your specific issue. I would look linto load balancing like John suggested.

Hall of Fame Super Blue

PIM with two DRs?

Anas

Perhaps i am misunderstanding but the PIM DR is simply the router that is responsible for IGMP queries within the LAN segment. If you add another router and it is not elected DR that should not stop the router receiving the multicast stream. The new router simply registers with the DR that it wants to to receive that stream and then it can route the multicast stream to the remote network.

Of course you need something on the remote network to request the stream so the new router knows it needs to register for the stream.

Jon

New Member

PIM with two DRs?

Hi All,

Thank you for your feedback..

Actually i want to build two separate multicast trees from the same L2 switch. the first one is already up and working fine. but i am facing issue with the new router (R1) that is connected to the same L2 switch.

The design is as below:

      Streamers

       (L2 SW)

---------------------------

     |                    |

    R1              Rx Old Router

     |                  LAN/Receivers

  WAN

     |

    R2

  (Receivers)

Below is the configs of the R1 and R2:

I tried also to filter the PIM neighbor between R1 and Rx. now R1 is DR, but still the stream doesnot work from R1 down to the LAN of R2

R2:

ip vrf IPTV

ip multicast-routing vrf IPTV

vlan 301

name IPTV-WAN

!

vlan 302

name IPTV-Site2

!

interface GigabitEthernet0/24

description WAN

switchport trunk allowed vlan 1,100,200,250,301,2011,2012

switchport mode trunk

interface Vlan301

ip vrf forwarding IPTV-WAN

ip address 10.51.3.29 255.255.255.240

ip pim sparse-mode

standby 101 ip 10.51.3.30

standby 101 priority 110

standby 101 preempt

!

interface Vlan302

ip vrf forwarding IPTV

ip address 10.51.4.2 255.255.255.0

ip pim sparse-mode

standby 102 ip 10.51.4.1

standby 102 priority 110

standby 102 preempt

ip igmp join-group 239.3.3.3

ip igmp join-group 239.1.1.141

ip pim vrf IPTV rp-address 10.51.5.5

ip pim vrf IPTV spt-threshold infinity

ip route vrf IPTV 10.51.5.5 255.255.255.255 10.51.3.17

R2#sh ip mroute vrf IPTV

IP Multicast Routing Table

Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,

       L - Local, P - Pruned, R - RP-bit set, F - Register flag,

       T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,

       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,

       U - URD, I - Received Source Specific Host Report,

       Z - Multicast Tunnel, z - MDT-data group sender,

       Y - Joined MDT-data group, y - Sending to MDT-data group,

       G - Received BGP C-Mroute, g - Sent BGP C-Mroute,

       Q - Received BGP S-A Route, q - Sent BGP S-A Route,

       V - RD & Vector, v - Vector

Outgoing interface flags: H - Hardware switched, A - Assert winner

Timers: Uptime/Expires

Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 239.1.1.141), 01:10:21/00:02:32, RP 10.51.5.5, flags: SCL

  Incoming interface: Vlan301, RPF nbr 10.51.3.17

  Outgoing interface list:

    Vlan302, Forward/Sparse, 01:10:21/00:02:32

(*, 239.1.1.102), 01:09:22/00:02:31, RP 10.51.5.5, flags: SC

  Incoming interface: Vlan301, RPF nbr 10.51.3.17

  Outgoing interface list:

    Vlan302, Forward/Sparse, 01:09:22/00:02:31

(*, 239.255.255.250), 01:09:20/00:02:39, RP 10.51.5.5, flags: SC

  Incoming interface: Vlan301, RPF nbr 10.51.3.17

  Outgoing interface list:

    Vlan302, Forward/Sparse, 01:09:20/00:02:39

(*, 239.3.3.3), 01:10:21/00:02:37, RP 10.51.5.5, flags: SCL

  Incoming interface: Vlan301, RPF nbr 10.51.3.17

  Outgoing interface list:

    Vlan302, Forward/Sparse, 01:10:21/00:02:37

(*, 224.0.1.40), 01:10:21/00:02:39, RP 10.51.5.5, flags: SCL

  Incoming interface: Vlan301, RPF nbr 10.51.3.17

  Outgoing interface list:

    Vlan302, Forward/Sparse, 01:10:21/00:02:39

R2#sh ip pim vrf IPTV rp mapping

PIM Group-to-RP Mappings

Group(s): 224.0.0.0/4, Static

    RP: 10.51.5.5 (?)

R1:

ip vrf IPTV

ip multicast-routing vrf IPTV

vlan 301

name WAN-IPTV

!

vlan 302

name LAN-IPTV

!

interface Loopback20

ip vrf forwarding IPTV

ip address 10.51.5.5 255.255.255.255

ip pim sparse-mode

!

interface GigabitEthernet0/15

description WAN

port-type nni

switchport trunk allowed vlan 1,100,200,250,301,2011,2012

switchport mode trunk

!

interface GigabitEthernet0/24

description IPTV-LAN

port-type nni

switchport access vlan 302

interface Vlan301

ip vrf forwarding IPTV

ip address 10.51.3.17 255.255.255.240

ip pim sparse-mode

!

interface Vlan302

ip vrf forwarding IPTV

ip address 10.17.1.7 255.255.255.0

ip pim neighbor-filter 5

ip pim sparse-mode

!

ip route vrf IPTV 10.51.4.0 255.255.255.0 10.51.3.30

!

!

ip pim vrf IPTV rp-address 10.51.5.5

ip pim vrf IPTV spt-threshold infinity

!

ip sla enable reaction-alerts

access-list 5 deny   any

R1#sh ip pim vrf IPTV rp mapping

PIM Group-to-RP Mappings

Group(s): 224.0.0.0/4, Static

    RP: 10.51.5.5 (?)

R1#sh ip mroute vrf IPTV

IP Multicast Routing Table

Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,

       L - Local, P - Pruned, R - RP-bit set, F - Register flag,

       T - SPT-bit set, J - Join SPT, M - MSDP created entry,

       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,

       U - URD, I - Received Source Specific Host Report,

       Z - Multicast Tunnel, z - MDT-data group sender,

       Y - Joined MDT-data group, y - Sending to MDT-data group

       V - RD & Vector, v - Vector

Outgoing interface flags: H - Hardware switched, A - Assert winner

Timers: Uptime/Expires

Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 239.1.1.141), 01:15:01/00:02:57, RP 10.51.5.5, flags: SJC

  Incoming interface: Null, RPF nbr 0.0.0.0

  Outgoing interface list:

    Vlan301, Forward/Sparse, 01:14:20/00:03:05

    Vlan302, Forward/Sparse, 01:15:01/00:02:57

(*, 239.1.1.140), 01:15:01/00:02:03, RP 10.51.5.5, flags: SJC

  Incoming interface: Null, RPF nbr 0.0.0.0

  Outgoing interface list:

    Vlan302, Forward/Sparse, 01:15:01/00:02:03

(*, 239.1.1.143), 01:15:00/00:02:57, RP 10.51.5.5, flags: SJC

  Incoming interface: Null, RPF nbr 0.0.0.0

  Outgoing interface list:

    Vlan302, Forward/Sparse, 01:15:00/00:02:57

(*, 239.1.1.142), 01:15:01/00:02:01, RP 10.51.5.5, flags: SJC

  Incoming interface: Null, RPF nbr 0.0.0.0

  Outgoing interface list:

    Vlan302, Forward/Sparse, 01:15:01/00:02:01

(*, 239.1.1.102), 01:15:00/00:02:57, RP 10.51.5.5, flags: SJC

  Incoming interface: Null, RPF nbr 0.0.0.0

  Outgoing interface list:

    Vlan301, Forward/Sparse, 01:14:22/00:02:51

    Vlan302, Forward/Sparse, 01:15:00/00:02:57

(*, 239.1.1.101), 01:15:04/00:02:58, RP 10.51.5.5, flags: SJC

  Incoming interface: Null, RPF nbr 0.0.0.0

  Outgoing interface list:

    Vlan302, Forward/Sparse, 01:15:04/00:02:58

(*, 239.1.1.100), 01:15:07/00:02:54, RP 10.51.5.5, flags: SJC

  Incoming interface: Null, RPF nbr 0.0.0.0

  Outgoing interface list:

    Vlan302, Forward/Sparse, 01:15:07/00:02:54

(*, 239.1.1.99), 01:15:01/00:02:57, RP 10.51.5.5, flags: SJC

  Incoming interface: Null, RPF nbr 0.0.0.0

  Outgoing interface list:

    Vlan302, Forward/Sparse, 01:15:01/00:02:57

(*, 239.1.1.98), 01:15:07/00:02:55, RP 10.51.5.5, flags: SJC

  Incoming interface: Null, RPF nbr 0.0.0.0

  Outgoing interface list:

    Vlan302, Forward/Sparse, 01:15:08/00:02:55

(*, 239.1.1.111), 01:15:08/00:02:57, RP 10.51.5.5, flags: SJC

  Incoming interface: Null, RPF nbr 0.0.0.0

  Outgoing interface list:

    Vlan302, Forward/Sparse, 01:15:08/00:02:57

(*, 239.1.1.110), 01:15:00/00:02:57, RP 10.51.5.5, flags: SJC

  Incoming interface: Null, RPF nbr 0.0.0.0

  Outgoing interface list:

    Vlan302, Forward/Sparse, 01:15:00/00:02:57

(*, 239.1.1.109), 01:15:06/00:02:56, RP 10.51.5.5, flags: SJC

  Incoming interface: Null, RPF nbr 0.0.0.0

  Outgoing interface list:

    Vlan302, Forward/Sparse, 01:15:06/00:02:56

(*, 239.1.1.106), 01:15:05/00:02:51, RP 10.51.5.5, flags: SJC

  Incoming interface: Null, RPF nbr 0.0.0.0

  Outgoing interface list:

    Vlan302, Forward/Sparse, 01:15:05/00:02:51

--More--

140
Views
0
Helpful
4
Replies