Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

ping does not work on L2TPv3 tunnel

Hi, I have a simple lab setup for testing the L2TPv3. Diagram is attached.

The router simulated PCs (192.168.10.1 and 192.168.10.2) just can not ping each other. Here below are the comfiguration of the 2 routers. I tried to put in "ip pmtu" under pseudowire-class; I tried to adjust-mss under interface of the two router simulated PCs to 1400 or even 1360, none of them changed a thing. 

Please advise.

+++++++++++++++R1++++++++++++++++++
!
hostname R1
!
interface Loopback0
 ip address 10.0.1.1 255.255.255.255
!
interface FastEthernet 1/1
 ip address 4.2.2.1 255.255.255.0
 no shut
!
router ospf 1
 router-id 10.0.1.1
 network 0.0.0.0 255.255.255.255 area 0
!
l2tp-class L2TPV3class
 authentication
 password L2TPV3
 retransmit initial retries 30
 cookie size 8
!
pseudowire-class HQ2R2
 encapsulation l2tpv3
 protocol none
 ip local interface Loopback0
!
default inter fa1/0
interface FastEthernet1/0
 description HQ_LAN_R2Branch
 no ip address
 no shut
 no cdp enable
 xconnect 10.0.2.2 102 encapsulation l2tpv3 manual pw-class HQ2R2
 l2tp id 101 200
 l2tp cookie local 4 221200
 l2tp cookie remote 4 122200
 l2tp hello L2TPV3class
!
+++++++++++++++R2++++++++++++++++++
hostname R2
!
interface Loopback0
 ip address 10.0.2.2 255.255.255.255
!
interface FastEthernet 1/0
 ip address 4.2.2.2 255.255.255.0
 no shut
!
router ospf 1
 router-id 10.0.2.2
 network 0.0.0.0 255.255.255.255 area 0
!
l2tp-class L2TPV3class
authentication
password L2TPV3
retransmit initial retries 30
cookie size 8
!
pseudowire-class R2Branch2HQ
encapsulation l2tpv3
protocol none
ip local interface Loopback0
ip pmtu
!
default inter fa0/0
interface FastEthernet0/0
description R2Branch_LAN_HQ
no ip address
no shut
no cdp enable
xconnect 10.0.1.1 201 encapsulation l2tpv3 manual pw-class R2Branch2HQ
l2tp id 200 101
l2tp cookie local 4 221200
l2tp cookie remote 4 122200
l2tp hello L2TPV3class

Everyone's tags (2)
99
Views
0
Helpful
0
Replies
CreatePlease login to create content