Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Please help!!! Cisco QoS with MS Lync 2010 client

Hi All,

I am working with a client to implement QoS for their Lync environment. Lync 2010 has this feature to mark dscp values based on packets tagged with logical ports. As an example, packets on port 49000 til 49999 will be marked to dscp 46(ef).

On Cisco 2811 router, I am basically honouring the markings by the application and placing bandwidth priority on them and sending it out to the WAN.

The behaviour that I notice is that when port based packets are marked with a certain dscp value on the application, the router policy map doesn't pick up any packet increment for that dscp. But when all packets without port assigning to it are marked with certain dscp value, I can see increment on the router policy map for that dscp match.

Why is this so???

The client wants the Lync to mark the packets with dscp value and the router is suppose to honour the marking, schedule the priority and send it out.

Pls see below for my config:

class-map match-any QOS-SCHED-CRITICAL

match ip dscp ef

class-map match-any QOS-SCHED-FLASH

match ip dscp af31

match ip dscp af32

class-map match-any QOS-SCHED-FLASHOVERRIDE

match ip dscp af41

match ip dscp af42

match ip dscp af43

!

!

policy-map QOS-QUEUE-OUT

class QOS-SCHED-CRITICAL

    priority percent 25

class QOS-SCHED-FLASHOVERRIDE

    bandwidth remaining percent 40

class QOS-SCHED-FLASH

    bandwidth remaining percent 30

class class-default

    bandwidth remaining percent 30

     random-detect dscp-based

!

interface FastEthernet0/1

description xxx

bandwidth 12000

ip address xxx

ip accounting output-packets

duplex full

speed 100

service-policy output QOS-QUEUE-OUT

Any help witll be appreciated.

Everyone's tags (3)
5 REPLIES
Cisco Employee

Please help!!! Cisco QoS with MS Lync 2010 client

Hello,

Couple of questions for a thread start:

1) Are you sure that Lync do correct port based marking - I gues sit is worth doing of sniffer (SPAN) on the switch connected to 2811 router and examine those packets

2) What is the config of the incoming port of 2811. You showed only outgoing fa0/1.

Nik

New Member

Please help!!! Cisco QoS with MS Lync 2010 client

On question 1: Yes, we have verified that with Wireshark. It shows dscp marking done based on ports that has been set.

Question 2: I am only applying QoS on outbound traffic. There's no requirement for inbound traffic.

Cisco Employee

Please help!!! Cisco QoS with MS Lync 2010 client

First of all I would recomend that packets with correct marking are actually coming to router input interface.

You can apply ACL below to watch it:

access-list 101 permit udp any any dscp ef

access-list 101 permit ip any any

or the one below to see logs with packet details

access-list 101 permit udp any any dscp ef log-input

access-list 101 permit ip any any

Then we can consider the rest output policies.

Nik

New Member

Please help!!! Cisco QoS with MS Lync 2010 client

Thanks Nik. I'll do that.

The other things is that the Lync client is connected to a switch, and then to a router. I am only doing QoS on the router and not on the switch. Do I need to set anything on the switch to honour the dscp markings based on ports?

Cisco Employee

Please help!!! Cisco QoS with MS Lync 2010 client

well, if switch has mls qos enabled - then the port connected to Lync client should trus the dscp marking coming from it (mls qos dscp trust) That is to reserve marking without it switch will drop precedence to 0.

Nik

8698
Views
0
Helpful
5
Replies
CreatePlease to create content