Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Please help troubleshoot TZO DDNS

Hello,

I am trying to configure TZO DDNS on my 1941.  The DDNS lines in the configuration file were provided one year ago by TZO support for a 1811W router, which was working befor i migrated to the 1941.  I have attached a config file and a debug file.   The unusual part of the debug file is session id 0x95.  I thnk this is the format the router would use if it had been configured using CCP.  I had tried CCP initially but it didnt work, so I deleted it from the configuration and used CLI instead.  Session ID 0x96 is the call the router is making using the CLI configuration, as seen  in the attached config file.

I am not sure where the problem is here.  it appears to be logging on to TZO.  It also appears that the router name is being added to the logon ID in session 0x95...ie instead of myname.net  the router is sending cisco1941.myname.net ---not sure if this is relevant or not.  It also appears that the update happens?  At least that'w what I can garner from the log file.

Thanks for any insight on what is happening

2 REPLIES
New Member

Please help troubleshoot TZO DDNS

I contacted engineering at TZO - and this was their suggestions:

So what is happening is the cisco ddns client is prepending the hostname "hostname cisco1941" to the ddns update method name. When we see the update come in the name doesn't match what we have in our database. we have "myname.net" and the ddns update has "cisco1941.myname.net" so it fails.

One possibility is the removal of client-id from the DHCP conf string for G0/0

change "ip address dhcp client-id GigabitEthernet0/0" to "ip address dhcp" or "ip address dhcp GigabitEthernet0/0".

This might alter the update name so it doesn't pass the units hostname with the ddns update.

interface GigabitEthernet0/0

description $ETH-WAN$

ip ddns update TZO

ip address dhcp client-id GigabitEthernet0/0

ip nat outside

ip virtual-reassembly

duplex auto

speed auto

no cdp enable

no mop enabled

Another possible config to try is to change the hostname of the router to "myname", by doing this the ddns update method will see the names are same and drop the hostname and just use what is in the ddns update method. If it happens that it prepends myname to myname.net and we get myname.myname.net you can try removing the hostname altogether.

Please let me know how you make out.

unfortunately, none of these worked out.  The ip address dhcp client-id changes were not recognized by IOS  and the hostname changes dis not work, in fact, got router prepended to the logon id

does anyone see a way to implement this?  thanks

New Member

Please help troubleshoot TZO DDNS

Try this:

!

interface GigabitEthernet0/1

ip dhcp client hostname yourname.domain.tld

ip dhcp client update dns server both

ip ddns update hostname yourname.domain.tld

ip ddns update YOUR-DDNS-METHOD host yourname.domain.tld

In my case, I'm having trouble with a DHCP server that insists on overriding my domain-name in the DHCP reply (the result is that my domain.tld gets changed to domain2.tld)

~BAS

556
Views
0
Helpful
2
Replies
CreatePlease to create content