Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k

point to multipoint configuration on routers

hello

we having 3 routers main location 2800 and remote location 1800 routers total 3 locations i want to configure point to multi point configuration on 3 locations i having leased line connectivity on 3 locations main location ip se 0/0/0 10.10.10.1,serial 0/0/1 10.10.10.2 eth 192.168.1.1 ,remote serial 0/0/0 10.10.10.3 eth 192.168.2.1 and another site serial 0/0/0 10.10.10.4 eth 192.168.3.1 i want 3 locations intranet configuration.

7 REPLIES
Hall of Fame Super Silver

Re: point to multipoint configuration on routers

Hello Ramnet,

for a point-to-multipoint communication you would need a FR WAN service because having a collection of leased lines is not enough to achieve this.

In the case you have bought access links to a FR service you can implement a classic hub and spoke topology with your central site acting as hub.

the FR service provider will give you the right DLCI to be used on each PVC.

You need three FR PVCs

Central site - remote site1

Central site - remote site2

Central site - remote site3

Hub router 2800

R2800#

int ser0/0

enc frame-relay

no ip address

int ser0/0.100 multipoint

ip address 10.10.10.1 255.255.255.0

frame-relay map ip 10.10.10.2 101 broadcast

frame-relay map ip 10.10.10.3 102 broadcast

frame-relay map ip 10.10.10.4 103 broadcast

Remote1

int ser0/0

enc frame-relay

no ip address

int ser0/0.100 multipoint

ip addr 10.10.10.2 255.255.255.0

frame-rel map ip 10.10.10.1 201 broadcast

you need a routing protocol to advertise the local client vlan subnets

using EIGRP or RIPv2 the central site needs split-horizon to be disabled

central site

router eigrp 100

network 10.0.0.0 0

no auto-summary

int ser0/0.100

no ip eigrp 100 split-horizon

on each remote (the EIGRP AS must be the same)

router eigrp 100

network 10.0.0.0

network 192.168.x.0

no auto-summary

x=1 for remote site1, 2 for remote site2 and so on

Hope to help

Giuseppe

Re: point to multipoint configuration on routers

Hi,

My service provider is not providing FR service i should implement on ppp or hdlc only. please send me the suitable configuration for this application.

Hall of Fame Super Silver

Re: point to multipoint configuration on routers

Hello Ramnet,

>>

My service provider is not providing FR service i should implement on ppp or hdlc only

you need three distinct point to point serial connections from central site to each remote site.

3 serial interfaces on central site router

each point-to-point link will use a different ip subnet

10.10.10.0/30 CS - Remote1

10.10.10.4/30 CS - Remote2

10.10.10.8/30 CS - Remote3

int ser0/0/0

enc ppp

ip address 10.10.10.1 255.255.255.252

desc CS - remotesite1

!

int ser0/0/1

enc ppp

ip address 10.10.10.5 255.255.255.252

desc CS - remotesite2

!

int ser0/1/0

enc ppp

ip address 10.10.10.9 255.255.255.252

desc CS - remotesite3

!

on each remote site

int ser0/0

enc ppp

ip address 10.10.10.x 255.255.255.252

where x is:

2 for remote site1

6 for remote site2

10 for remote site3

Hope to help

Giuseppe

Re: point to multipoint configuration on routers

Dear Giuseppe

ip address 10.10.10.4 255.255.255.252

when i try to serial ip make 252 subnet its not taken i configured 3 sites plz find the attachments its connected 3 sites but some times its breaking connections,so plz advise me.configuration.

Hall of Fame Super Silver

Re: point to multipoint configuration on routers

hello,

the router cannot accept

10.10.10.4 255.255.255.252 that is the subnet address

you need to use

ip address 10.10.10.5 255.255.255.252

please follow my previous post in the part of configuration of interfaces

However, I see that you haven't three serial links in main office so you can connect only two sites not three

Edit:

Now I see that there only three locations including central site you should be fine.

on main office

interface Serial0/0/0

ip address 10.10.10.1 255.255.255.252

no ip redirects

no ip mroute-cache

no cdp enable

!

interface Serial0/0/1

ip address 10.10.10.5 255.255.255.252

!

Hope to help

Giuseppe

Re: point to multipoint configuration on routers

Dear Giuseppe,

main office to two remote offices connectvity

i want to connectvity main office and remote 2 offices intranet connectvity i mean main office to remote 1 office ,main office to remote 2 office,and remote office to remote office total 3 locations must in intranet connectvity.

Hall of Fame Super Silver

Re: point to multipoint configuration on routers

Hello Ramnet,

the configuration examples that I have provided are good for your scenario.

the key point is to use a different ip subnet in the two point-to-point links because they are distinct links.

just skip the config of the third link that is not needed

Hope to help

Giuseppe

399
Views
0
Helpful
7
Replies
CreatePlease to create content