Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

point to point connection

i am having a problem with a point to point ethernet handoff. i can't even ping the other router.

i was looking for some help

internal network 192.168.1.0 255.255.255.0

>

router 192.168.1.2

>

network

>

router 192.168.2.2

>

internet network 192.168.2.0 255.255.255.0

here is my config on my 2.2 router

!INTERFACE AND SUB-INTERFACE

interface FastEthernet1

ip address 172.16.2.2 255.255.255.0

no shutdown

interface FastEthernet2

ip address 192.168.2.2 255.255.255.0

no shutdown

!IP

ip route 0.0.0.0 0.0.0.0 172.16.2.2

ip route 192.168.1.0 255.255.255.0 172.16.2.2

ip route 192.168.1.2 255.255.255.255 172.16.2.2

!RIP

router rip

network 192.168.2.0

network 172.16.0.0

here is my config on my 1.2 router

!INTERFACE AND SUB-INTERFACE

interface FastEthernet1

ip address 172.16.1.2 255.255.255.0

no shutdown

interface FastEthernet2

ip address 192.168.1.2 255.255.255.0

no shutdown

!IP

ip route 192.168.2.0 255.255.255.0 FastEthernet1

ip route 0.0.0.0 0.0.0.0 172.16.1.2

!RIP

router rip

network 172.16.0.0

network 192.168.1.0

5 REPLIES
Hall of Fame Super Silver

Re: point to point connection

Darren

There are several parts of the configs that you posted that do not make sense or are problematic. First you describe this as an Ethernet handoff, but it is not clear whether the routers are connected via FastEthernet 1 or by FastEthernet 2 or by both. But none of these interfaces share a common network. This would explain why you can not ping between routers. If two devices are connected then the interfaces on which they are connected should be in the same subnet (and same network).

Also the static routes that you post on the first router will not work:

ip route 0.0.0.0 0.0.0.0 172.16.2.2

ip route 192.168.1.0 255.255.255.0 172.16.2.2

ip route 192.168.1.2 255.255.255.255 172.16.2.2

They point at an address that is on a local inteface (FastEthernet 1) but the static route should specify a next hop on another router. You have similar issues with the second static route on the other router.

HTH

Rick

New Member

Re: point to point connection

these are connected via ethernet 1

Gold

Re: point to point connection

Don't even know where to start on this there are so many issues.

First the ethernet segments must be on the same subnet to work correctly.

Second you should not route to the interface or to the ip address on the interface. You need to route to a destination that outside the router.

What is very scary is that this might partially work. When you route to your own ip or interface the routers ARP all the traffic. Since cisco runs proxy ARP by default the other router may actually respond if it has a route to the network.

You may want to restart with what you currently have and where you want to get and maybe someone can give you a better design.

New Member

Re: point to point connection

Hi, not even sure how that static to an ip address on that router took. Usually the router will give you an error saying it is this router.

Gold

Re: point to point connection

You are right it does give you a error if you attempt to put it in after you define the interface. If you do it before you get this situation.

As soon as you reload the router it will remove the routes and give you the error message if you saved the configuration like this.

If you do a debug when its misconfigured this way it will act like it is sending the packets out the interface but I have never verfied if it really does.

411
Views
6
Helpful
5
Replies