Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

policy based routing and eigrp

Hi, I have 2 T1s from 2 different ISPs connecting to the internet. One T1 is used for the servers and the second one is used just for users web traffic. I have route-map configured (next hop)to direct the users traffic to the one internet T1. Now I am trying to configure EIGRP and when I put in the user's network into the EIGRP, it does not advertise it but EIGRP advertises all of the other networks fine. The user's network does not show up in the eigrp topolody at all.I know that this is because of the route-map commads but I just can't figure out how to fix this. Any help is greatly appriciated. Thanks

show ip eigrp topology

P 10.0.0.0/24, 1 successors, FD is 2169856

via Connected, Serial0/2/0

P 10.1.0.0/16, 1 successors, FD is 2169856

via Connected, Serial0/1/0

P 172.21.19.0/24, 1 successors, FD is 2816

via Connected, GigabitEthernet0/0

route map to networks

route-map UserInternet permit 7

match ip address 105

set ip next-hop 10.0.0.2

!

route-map UserInternet permit 8

match ip address 106

set ip next-hop 10.1.1.2

!

route-map UserInternet permit 9

match ip address 102

set ip next-hop 69.212.69.241

access-list for route map

access-list 102 permit tcp 172.23.0.0 0.0.255.255 any eq www

access-list 102 permit tcp 172.23.0.0 0.0.255.255 any eq 443

access-list 105 permit ip 172.23.0.0 0.0.255.255 10.0.0.0 0.0.0.255

access-list 105 permit ip 172.23.0.0 0.0.255.255 172.22.19.0 0.0.0.255

access-list 106 permit ip 172.23.0.0 0.0.255.255 10.1.0.0 0.0.255.255

access-list 106 permit ip 172.23.0.0 0.0.255.255 172.24.1.0 0.0.0.255

6 REPLIES
Hall of Fame Super Silver

Re: policy based routing and eigrp

Bart

There is not anything about Policy Based Routing or about the route map that it uses that will prevent EIGRP from advertising a network. I have looked briefly at what you have posted and do not see any information here that will really help us to understand what is going on. It would be very helpful if you would post the configuration of eigrp, post the output of show ip interface brief, and the output of show ip eigrp interface. It would also help to know exactly which interface and which subnet you are wanting to advertise but are not advertising.

HTH

Rick

New Member

Re: policy based routing and eigrp

here is the config. The only thing I can think of is that I have static route of the network (172.23.0.0) that I want to advertise. But the route should still show up in show ip eigrp topology as FD is inaccessible right? The other routes have showed up as inaccessible but after I removed the static routes they showed up as accessible except the 172.23.0.0 network

show ip int brief

GigabitEthernet0/0 104.104.1.34 YES NVRAM up up

GigabitEthernet0/1 56.145.89.235 YES NVRAM up up

Serial0/0/0 unassigned YES NVRAM up up

Serial0/0/0.154 unassigned YES unset deleted down

Serial0/0/0.165 96.22.69.243 YES NVRAM up up

Serial0/1/0 10.1.1.1 YES manual up up

Serial0/2/0 10.0.0.1 YES NVRAM up up

Serial0/3/0 unassigned YES NVRAM up up

Serial0/3/0.500 104.104.1.34 YES TFTP up up

NVI0 unassigned YES unset up up

show ip eigrp topology

P 10.0.0.0/24, 1 successors, FD is 2169856

via Connected, Serial0/2/0

P 10.1.0.0/16, 1 successors, FD is 2169856

via Connected, Serial0/1/0

P 172.21.19.0/24, 1 successors, FD is 2816

via Connected, GigabitEthernet0/0

connection to remore office T1

interface Serial0/1/0

description Minnesota

ip address 10.1.1.1 255.255.0.0

ip virtual-reassembly

ip route-cache flow

show ip eigrp neighbors

IP-EIGRP neighbors for process 10

H Address Interface Hold Uptime SRTT RTO Q Seq

(sec) (ms) Cnt Num

0 10.1.1.2 Se0/1/0 10 01:18:57 15 200 0 27

IP-EIGRP interfaces for process 10 Xmit Queue Mean Pacing Time Multicast Pending

Interface Peers Un/Reliable SRTT Un/Reliable Flow Timer Routes

Se0/1/0 1 0/0 15 0/15 79 0

Gi0/0 0 0/0 0 0/10 0 0

show ip route

S 172.19.0.0/16 [1/0] via 172.21.19.35

S 172.18.0.0/16 [1/0] via 172.21.19.35

172.21.0.0/24 is subnetted, 1 subnets

C 172.21.19.0 is directly connected, GigabitEthernet0/0

S 172.20.0.0/16 [1/0] via 172.21.19.35

S 172.23.0.0/16 [1/0] via 172.21.19.35

172.22.0.0/24 is subnetted, 1 subnets

S 172.22.19.0 [1/0] via 10.0.0.2

172.24.0.0/24 is subnetted, 2 subnets

S 172.24.0.0 [1/0] via 10.1.1.2

S 172.24.1.0 [1/0] via 10.1.1.2

10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks

C 10.0.0.0/24 is directly connected, Serial0/2/0

C 10.1.0.0/16 is directly connected, Serial0/1/0

S* 0.0.0.0/0 is directly connected, Serial0/3/0.500

Hall of Fame Super Silver

Re: policy based routing and eigrp

Bart

Thank you for posting additional information which is helpful. You posted most of what I asked for but did not post the configuration of EIGRP which would help us understand how you are putting the user network into EIGRP. I can not tell from your post whether you are putting a network statement for 172.23.0.0 into EIGRP (which would not work since 172.23.0.0 is not a connected network on this router) or whether you are redistributing static (which probably would work - depending on a couple of details of how the router is configured). Perhaps you can clarify how you are getting that network into EIGRP?

HTH

Rick

New Member

Re: policy based routing and eigrp

eigpr 10

network 172.23.0.0

network 10.0.0.0

network 172.21.19.0

The 172.23.0.0 is a vlan on the switches. The 172.21.19.0 is directly connected. Hope this helps thanks for all of your help.

So how can I put in the vlan into the eigrp that is not directly connected?

New Member

Re: policy based routing and eigrp

Rick we have inter vlan routing on our switches. From the switches we have static route to the router. The 172.21.19.0 network shows up in the eigrp topology as a connected network but the 172.23.0.0 network which I have problems with does not show up as connected. Is this the problem?

Hall of Fame Super Silver

Re: policy based routing and eigrp

Bart

Yes indeed it is the problem. A network statement in EIGRP will look at the connected interfaces and will put any interface that matches a network statement into EIGRP. And it is the inclusion of the interface into EIGRP that will get the subnet advertised. If 172.23.0.0 is not a connected subnet then a network statement will not work to get it into EIGRP.

If the subnet is not connected and you have a static route for it, then to get that subnet into EIGRP you would need to redistribute static into EIGRP. I see that there are several static routes configured. Depending on whether you want EIGRP to advertise all the static routes or only advertise some of them you might need to configure a distribute list in EIGRP to control which static routes are advertised and which are not advertised.

HTH

Rick

1662
Views
5
Helpful
6
Replies
CreatePlease login to create content