Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Policy based routing help

I have a set up betwen 2 locations connected by 2 parallel links.One link is 2M & another is 10M.Between 2 location there are 2 critical servers which needs be communicated on priority.I want to route traffic ONLY for these servers from 2M link. while resr all other traffic between 2 locations should go from 10M link.How can I achieve this by policy based routing or do I need to use tracking option ??

Also if 2M link will be down,all traffic should go via 10M & vice a versa.

Please help

6 REPLIES
Silver

Re: Policy based routing help

You can install two static routes for that server. One for 2M link and other, with higher metric, to 10M link. This assumes that the interface goes down as soon as the 2M link goes down.

Thanks.

Re: Policy based routing help

A standard policy routing configuration should be sufficient. If the next-hop is unreachable the router would, by default, forward the traffic based on the alternate route in the routing table. You can use a config similar to this one;

int e0

ip add 192.168.1.1 255.255.255.0

ip policy route-map test

int s0

descripton 2mb link

ip add 10.1.1.1 255.255.255.252

int s1

description 10mb link

ip add 10.1.2.1 255.255.255.252

route-map test permit 10

match ip add 100

set ip next-hop 10.1.1.2

route-map test permit 20

match ip add 101

set ip next-hop 10.1.2.2

access-list 100 permit ip any

access-list 101 permit ip any any

HTH

Sundar

New Member

Re: Policy based routing help

bt i need also when 10 m down then all traffic should be go through on 2m serial link and vice a versa.

is this possible?

Bronze

Re: Policy based routing help

I would configure your 10Mb as the primary route for all traffic on both sides, and the 2Mb as the secondary. When the primary path goes down the secondary will kick in.

For example

ip route 10.0.0.0 255.255.255.0 172.16.1.2 <-10Mb

ip route 10.0.0.0 255.255.255.0 172.16.1.6 50 <-2Mb

Your policy routing configuration will still use the 2Mb and if it goes down the 10Mb will be used. Just make sure you configure the policy on both sides as noted in a previous posting.

Daniel

New Member

Re: Policy based routing help

I'd like to add one little thing to Sundar's

post. That config should be applied on both

ends of the link otherwise assymetric routing

can have place.

Thx,

OW

New Member

Re: Policy based routing help

Hi,

Is it right to configure by this way

router eigrp 100

redistribute static

network 192.168.54.0

network 192.168.227.0

auto-summary

Regards,

Karthick.M

107
Views
0
Helpful
6
Replies