Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Policy Based Routing - PBR - where to add on a Router on a stick

Hi Experts,

I want to change my routing. I want to send all the traffic ORIGINATING from the
192.168.10.x network to go out thru my ISP  gateway 200.1.1.1, and then add a default
route for my 192.168.2.0. 


I do not know where to apply the policy route since I am using Router on a STICK.
Should I apply it to each sub interface or to the interface Fa0/0: 

In example:
interface FastEthernet0/1.1
interface FastEthernet0/1.2


--- Route map configuration to apply (I think) ---

route-map Router permit 10
description Sends network traffic 192.168.10.
match ip address 101
set ip next-hop 200.1.1.1

!
route-map Router permit 20
description allow other network traffic

access-list 101 permit ip 192.168.10.0 0.0.0.255 any


no ip route 0.0.0.0 0.0.0.0 200.1.1.1
ip route 0.0.0.0 0.0.0.0 192.168.2.1  (my new gateway)
no ip route 192.168.2.0 255.255.254.0 192.168.2.1

-----------------------------------------------------------

Actual Running  configuration:

Router(config)#do sh run

version 12.4
!
hostname Router

interface FastEthernet0/0
description outside
ip address dhcp client-id FastEthernet0/0
ip access-group outside in
ip nat outside

!
interface FastEthernet0/1
description inside
no ip address

!
interface FastEthernet0/1.1
encapsulation dot1Q 1 native
ip address 192.168.2.115 255.255.254.0
ip nat inside

interface FastEthernet0/1.2
encapsulation dot1Q 2
ip address 192.168.10.1 255.255.255.0
ip nat inside


ip classless
ip route 0.0.0.0 0.0.0.0 200.1.1.1
ip route 192.168.2.0 255.255.254.0 192.168.2.1

ip nat inside source static tcp 192.168.2.33 80 200.1.1.10 80 extendable
ip nat inside source static tcp 192.168.10.245 5015 200.1.1.10 5015 extendable
ip nat inside source static tcp 192.168.10.246 5016 200.1.1.10 5016 extendable
!
ip access-list extended outside
permit tcp any host 200.1.1.10 eq www
permit udp X.Y.Z.0 0.0.0.255 any eq bootpc
permit udp any host 255.255.255.255 eq bootps
permit udp any any eq bootpc
permit tcp any host 200.1.1.10 eq 5015
permit tcp any host 200.1.1.10 eq 5016


access-list 12 permit 192.168.2.0 0.0.0.255

Router(config)#

Router(config)#do sh ip int b
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            200.1.1.10    YES DHCP   up                    up
FastEthernet0/1            unassigned      YES NVRAM  up                    up
FastEthernet0/1.1          192.168.2.115    YES NVRAM  up                    up
FastEthernet0/1.2          192.168.10.1     YES NVRAM  up                    up

2 ACCEPTED SOLUTIONS

Accepted Solutions

Re: Policy Based Routing - PBR - where to add on a Router on a s

Hi,

    Just apply it on the interface that PBR traffic is coming in to the router.  It should be FastEthernet0/1.2.

HTH,

Toshi

Re: Policy Based Routing - PBR - where to add on a Router on a s

Hi

I want to change my routing. I want to send all the traffic ORIGINATING from the 

192.168.10.x network to go out thru my ISP  gateway 200.1.1.1,

The answer is in your description .you apply PBR policy where 192.168.10.x is configured which is your fasteth0/1.2

HTH

Kishore

5 REPLIES

Re: Policy Based Routing - PBR - where to add on a Router on a s

Hi,

    Just apply it on the interface that PBR traffic is coming in to the router.  It should be FastEthernet0/1.2.

HTH,

Toshi

New Member

Re: Policy Based Routing - PBR - where to add on a Router on a s

Awesome!

Re: Policy Based Routing - PBR - where to add on a Router on a s

Hi

I want to change my routing. I want to send all the traffic ORIGINATING from the 

192.168.10.x network to go out thru my ISP  gateway 200.1.1.1,

The answer is in your description .you apply PBR policy where 192.168.10.x is configured which is your fasteth0/1.2

HTH

Kishore

New Member

Re: Policy Based Routing - PBR - where to add on a Router on a s

Kishore, perhaps you don't know it but you have helped me twice already!  Thanks a bunch.

Re: Policy Based Routing - PBR - where to add on a Router on a s

Hi Randall. Firstly thanks for your rating and kind words. i am glad I could be of help and will continue to do so

686
Views
0
Helpful
5
Replies
CreatePlease to create content