Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Policy based routing to different ISP's

I want to know if it's possible to route different internal subnets out different interfaces to the Internet. BGP is not an option.

Here is my topology:

ISP 1 ISP 2

Router

Subnet 1 Subnet 2

The basic question is: can I route all internet traffic from subnet 1 to ISP 1 and subnet 2 to ISP 2?

4 REPLIES
Purple

Re: Policy based routing to different ISP's

HI,

Are your subnet1 and subnet2 public IPs or do you need to use NAT ?

Paresh

New Member

Re: Policy based routing to different ISP's

The subnet 1 and 2 are going to use NAT.

Re: Policy based routing to different ISP's

I think the subject of this conversating resolves the problem.

You can configure your route to do policy routing, or route based on source, or better yet use an extended ACL to define traffic going to www and point it to next-hop that you see fit.

check the following example:

http://www.cisco.com/univercd/cc/td/doc/product/software/ios124/124cg/hirp_c/ch20/piconfig.htm#wp1002348

in your case you should use an extedend acl like

access-list 100 permit 10.0.0.0 0.0.0.255 any eq www

something along those lines.

Hope this help!

Vlad

Purple

Re: Policy based routing to different ISP's

Here's a sample config that will do what you want:

interface Serial0

ip address 255.255.255.252

ip nat outside

!

interface Serial1

ip address 255.255.255.252

ip nat outside

!

interface GigabitEthernet0/0

ip address 10.1.1.1 255.255.255.0

ip policy route-map PBR

ip nat inside

!

ip route 0.0.0.0 0.0.0.0 Serial0

ip route 0.0.0.0 0.0.0.0 Serial1

!

ip nat inside source route-map ISP1-map interface serial0

ip nat inside source route-map ISP2-map interface Serial1

!

route-map ISP11-map permit 10

match ip address 1

!

route-map ISP12-map permit 10

match ip address 2

!

route-map PBR permit 10

match ip address 1

set interface serial0

!

route-map PBR permit 20

match ip address 2

set interface serial1

!

access-list 1 permit

access-list 2 permit

Hope that helps - pls rate the post if it does.

Paresh

231
Views
5
Helpful
4
Replies
CreatePlease to create content