Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Policy routing based on ports

Can we set up a policy route to send web/ftp traffic to one interface, and all other traffic to a different interface?

We will also need to nat the web/ftp traffic.

Any help would be greatly appreciated.

Thanks,

Brian

4 REPLIES

Re: Policy routing based on ports

Can we set up a policy route to send web/ftp traffic to one interface, and all other traffic to a different interface?

>> Yes, it's called Policy Based Routing.

Here is a link on cinfigurations guide:

http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122cgcr/fqos_c/fqcprt1/qcfpbr.htm

Please rate helpful posts.

New Member

Re: Policy routing based on ports

PBR is used to make routing decisions based on policies set by the cisco router.

Here is the sample config :

hostname core_testing

!

interface Ethernet0/0

ip address 172.16.10.6 255.255.255.0

!

interface Ethernet0/1

ip address 172.16.64.6 255.255.255.0

ip route-cache policy

ip policy route-map policy_1

!

router eigrp 65001

network 172.16.0.0

no auto-summary

!

!

access-list 100 permit ip host 172.16.64.10 any

access-list 101 permit ip host 172.16.64.5 any

!

route-map policy_1 permit 100

!

match ip address 100

set ip next-hop 172.16.10.4

route-map policy_1 permit 200

!

match ip address 101

set ip next-hop 172.16.10.3

Please rate helpful posts.

Regds

Saji k.s

Network consultant

Bangalore

New Member

Re: Policy routing based on ports

I see how it is set up for source address routing, but what about destination port routing. All the documentation seems to talk about it address matching. Can we do destination port matching for policy based routing?

Hall of Fame Super Silver

Re: Policy routing based on ports

Brian

There may be a semantic issue involved in understanding this. The route map for Policy Based Routing may say match address 101 and it sounds like it is matching on addresses. But it is matching to an IP access list not just to addresses. So if you want to Policy Based Route for destination ports then just create the access list that permits the destination ports that you want to Policy Based Route. It really is pretty simple - and it works.

HTH

Rick

510
Views
0
Helpful
4
Replies
CreatePlease to create content