Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Poor Performance, Internet Router, 1800, Cable Virgin Media.

Hello Guy's

Im getting really poor performance on my 1841, my intial thoughts was a duplex mismatch  however although im getting a few CRC errors (root cause unknown at this point) not enough to suggest that the this is the issue.

Heres the config, if any could lend any ideas.

Building configuration...

Current configuration : 5274 bytes

!

! Last configuration change at 20:31:01 PCTime Sun Dec 18 2011 by admin_x

version 15.1

no service pad

service tcp-keepalives-in

service tcp-keepalives-out

service timestamps debug datetime msec localtime show-timezone

service timestamps log datetime msec localtime show-timezone

service password-encryption

service sequence-numbers

!

hostname   xxxxxx

!

boot-start-marker

boot-end-marker

!

!

security authentication failure rate 10 log

security passwords min-length 6

logging buffered 4096

enable secret 5 $1$PVkz$/eMJav5JfVM1vOtJ/QxTd/

!

aaa new-model

!

!

aaa authentication login local_auth local

!

!

!

!

!

aaa session-id common

!

clock timezone PCTime 0 0

clock summer-time PCTime date Mar 30 2003 1:00 Oct 26 2003 2:00

dot11 syslog

!

dot11 ssid I@mS3cUrE

vlan 1

authentication open

authentication key-management wpa

wpa-psk ascii 7 xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx

!

no ip source-route

no ip gratuitous-arps

!

!

!

no ip dhcp use vrf connected

ip dhcp excluded-address 192.168.199.225

ip dhcp excluded-address 192.168.199.226

!

ip dhcp pool LAN_POOL

import all

network 192.168.199.224 255.255.255.240

dns-server 8.8.8.8

default-router 192.168.199.225

!

!

ip cef

no ip bootp server

ip domain name NoDotCom.Local

ip name-server 8.8.8.8

ip inspect audit-trail

ip inspect udp idle-time 1800

ip inspect dns-timeout 7

ip inspect tcp idle-time 14400

no ipv6 cef

!

multilink bundle-name authenticated

!

crypto pki token default removal timeout 0

!

crypto pki trustpoint TP-self-signed-1977233307

enrollment selfsigned

subject-name cn=IOS-Self-Signed-Certificate-1977233307

revocation-check none

rsakeypair TP-self-signed-1977233307

!

!

crypto pki certificate chain TP-self-signed-1977233307

certificate self-signed 01

  3082024E 308201B7 A0030201 02020101 300D0609 2A864886 F70D0101 04050030

  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274

  69666963 6174652D 31393737 32333333 3037301E 170D3131 31303238 31333335

  34375A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649

  etctetcetc

      quit

!

!

license udi pid CISCO1841 xxxxxxxxxxxx

username xxxxxxxxxxxxxxxxxxxxxxxxx

!        

redundancy

!

!

ip tcp synwait-time 10

ip tcp path-mtu-discovery

ip ssh time-out 60

ip ssh authentication-retries 2

!

!

!

!

!

!

!

interface FastEthernet0/0

description PUBLIC_FACING

ip address dhcp client-id FastEthernet0/0

no ip redirects

no ip unreachables

no ip proxy-arp

ip flow ingress

ip nat outside

ip virtual-reassembly in

speed 100

full-duplex

no mop enabled

!

interface FastEthernet0/1

description $ES_LAN$$FW_INSIDE$

ip address 192.168.199.225 255.255.255.240

no ip redirects

no ip unreachables

no ip proxy-arp

ip flow ingress

ip nat inside

ip virtual-reassembly in

speed 100

full-duplex

no mop enabled

!

interface Dot11Radio0/0/0

no ip address

!

encryption vlan 1 mode ciphers aes-ccm

!

broadcast-key vlan 1 change 30

!

!

ssid I@mS3cUrE

!

mbssid

speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0

station-role root

!        

interface Dot11Radio0/0/0.1

encapsulation dot1Q 1 native

no cdp enable

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 spanning-disabled

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

!

ip forward-protocol nd

no ip http server

ip http authentication local

ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

!

!

ip nat inside source list 1 interface FastEthernet0/0 overload

ip route 0.0.0.0 0.0.0.0 <-- Given by DHCP, by Docsis3 VM superhub in Modem Mode.

!

logging trap debugging

access-list 1 permit any

no cdp run

!

!

!

!

!

!

!

!

control-plane

!

!

banner login ^CAuthorized access only!

Disconnect IMMEDIATELY if you are not an authorized user!^C

!

line con 0

exec-timeout 0 0

transport output telnet

line aux 0

exec-timeout 0 0

transport output telnet

line vty 0 4

privilege level 15

transport input ssh

transport output ssh

line vty 5 15

privilege level 15

transport input ssh

transport output ssh

!

scheduler allocate 4000 1000

The config as you can see is pretty basic at this point,

So the Normal Virgin Media works fine and delivers 50Mb out of the box. When I set the no so "SuperHub" to modem mode (basically passing everything to the 1841) I get barely 2Mb. when I hook the Superhub straight up to my PC in modem mode i get the full 50Mb. So the fault clearly resides with the 1841. 

#show int  f0/0

FastEthernet0/0 is up, line protocol is up

  Hardware is Gt96k FE, address is 001e.7a55.2d8c (bia 001e.7a55.2d8c)

  Description: PUBLIC_FACING

  Internet address is xx.xx.xx.xx/24

  MTU 1500 bytes, BW 100000 Kbit/sec, DLY 100 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation ARPA, loopback not set

  Keepalive set (10 sec)

  Full-duplex, 100Mb/s, 100BaseTX/FX

  ARP type: ARPA, ARP Timeout 04:00:00

  Last input 00:00:39, output 00:00:00, output hang never

  Last clearing of "show interface" counters never

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: fifo

  Output queue: 0/40 (size/max)

  5 minute input rate 621000 bits/sec, 52 packets/sec

  5 minute output rate 23000 bits/sec, 42 packets/sec

     350448 packets input, 280934844 bytes

     Received 3095 broadcasts (0 IP multicasts)

     0 runts, 0 giants, 0 throttles

     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

     0 watchdog

     0 input packets with dribble condition detected

     441425 packets output, 124614124 bytes, 0 underruns

     0 output errors, 0 collisions, 11 interface resets

     0 unknown protocol drops

     0 babbles, 0 late collision, 0 deferred

     0 lost carrier, 0 no carrier

     0 output buffer failures, 0 output buffers swapped out

show int  f0/1

FastEthernet0/1 is up, line protocol is up

  Hardware is Gt96k FE, address is 001e.7a55.2d8d (bia 001e.7a55.2d8d)

  Description: $ES_LAN$$FW_INSIDE$

  Internet address is 192.168.199.225/28

  MTU 1500 bytes, BW 100000 Kbit/sec, DLY 100 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation ARPA, loopback not set

  Keepalive set (10 sec)

  Full-duplex, 100Mb/s, 100BaseTX/FX

  ARP type: ARPA, ARP Timeout 04:00:00

  Last input 00:00:00, output 00:00:00, output hang never

  Last clearing of "show interface" counters never

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: fifo

  Output queue: 0/40 (size/max)

  5 minute input rate 24000 bits/sec, 44 packets/sec

  5 minute output rate 621000 bits/sec, 51 packets/sec

     390507 packets input, 119689602 bytes

     Received 16 broadcasts (0 IP multicasts)

     43 runts, 0 giants, 0 throttles

     321 input errors, 321 CRC, 0 frame, 0 overrun, 0 ignored

     0 watchdog

     0 input packets with dribble condition detected

     315756 packets output, 276929904 bytes, 0 underruns

     0 output errors, 0 collisions, 4 interface resets

     0 unknown protocol drops

     0 babbles, 0 late collision, 0 deferred

     0 lost carrier, 0 no carrier

     0 output buffer failures, 0 output buffers swapped out

Also Performance even to the to web management of the Superhub via the cisco router seems slow.

Cheers Neil

Regards Neil http://uk.linkedin.com/pub/neil-grant/20/5b0/267
7 REPLIES

Re: Poor Performance, Internet Router, 1800, Cable Virgin Media.

what is on the fa0/1 interface? And what is the rest of the default route? Why not just set the default as 0.0.0.0 0.0.0.0 fa0/0?

Sent from Cisco Technical Support iPad App

New Member

Re: Poor Performance, Internet Router, 1800, Cable Virgin Media.

f0/1 is my lan,

the deafult route is obtained automatically via dhcp. I have tried setting my own deafult gateway via f0/0 with no luck, i have also tied using the superhub as a normal router the diasy chaining the 1800, still get poor performance.

it seems like a layer 1/2 issue?

Regards Neil http://uk.linkedin.com/pub/neil-grant/20/5b0/267

Re: Poor Performance, Internet Router, 1800, Cable Virgin Media.

what device is attached to fa0/1? That looks like the problem. A well functioning switch and router should have 0 crcs on that link.

Sent from Cisco Technical Support iPad App

New Member

Re: Poor Performance, Internet Router, 1800, Cable Virgin Media.

Currently a PC,

Internet - Cable modem - Cisco 1800 - PC = Poor Performance

Internet - Cable modem - PC - Great Performance

I'm going to see if i can get another router to test with. But im not convinced...

Regards Neil http://uk.linkedin.com/pub/neil-grant/20/5b0/267

Re: Poor Performance, Internet Router, 1800, Cable Virgin Media.

would bet on a duplex mismatch. Set the internal to half and see if hat helps.

Sent from Cisco Technical Support iPad App

Re: Poor Performance, Internet Router, 1800, Cable Virgin Media.

Better yet after I looked again set both the internal and external interfaces to auto speed, auto duplex and see if that helps.

Sent from Cisco Technical Support iPad App

Re: Poor Performance, Internet Router, 1800, Cable Virgin Media.

hi neil,

Could you remove the DNS server from your DHCP pool and hardcode the default static route. Kindly give it a try and revert if it helps.

Router(config)#ip dhcp pool LAN_POOL

Router(dhcp-config)#no dns-server 8.8.8.8

ip route 0.0.0.0 0.0.0.0 dhcp

Router#renew dhcp f0/0

2220
Views
0
Helpful
7
Replies
CreatePlease to create content