Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Port forwarding 1941 and Comcast

I have my 1941 router connected to my Comcast Modem on G0/0.  I have a 3560 connected to G0/1.  The router is handling my DHCP duties.

 

I have a HAI Omnipro ii (Security/Home Automation) that I would like to access remotely.  It has an IP address of 172.31.101.10 and uses port 4369.

 

I am at a loss on how to configure remote access to my OmniPro.  If I browse to "WhatIsMyIp" it shows it being 98.224.42.53.

 

But when I configured the router I used the following. 


interface GigabitEthernet0/0
 ip address dhcp
 ip nat outside
 ip virtual-reassembly in
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 ip address 172.31.101.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
 duplex auto
 speed auto
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip nat source list 101 interface GigabitEthernet0/0 overload
ip nat inside source list 101 interface GigabitEthernet0/0 overload
ip route 0.0.0.0 0.0.0.0 67.190.192.1
!
access-list 101 permit ip any any
access-list 101 permit ip 172.31.101.0 0.0.0.255 any

 

Can someone point me in the right direction?

 

Thank you,

Everyone's tags (1)
7 REPLIES
New Member

Use this command as example

Use this command as example:

router (config)# ip nat inside source static tcp 10.1.1.2 25 interface serial 0/0 25

New Member

Where did you get 10.1.1.2

Where did you get 10.1.1.2 and the serial interface from?

Mike

New Member

10.1.1.2 as internal (local)

10.1.1.2 as internal (local) IP address of server or another device;

serial 0/0 - as external interface. This parameter used if you get IP address from ISP by DHCP 

Replace these values on your.

 

 

Hi , You cant do port

Hi ,

 You cant do port-forwarding with dynamic public IP address . You need static Public IP address for it . 

Normal Linksys wirless router can support  port nat with dynamic IP address , not cisco IOS

 

HTH

Sandy

New Member

You are wrong.See my example

You are wrong.
See my example

Hi , 

Hi , 

 The IP address which you see in your browser (  f I browse to "WhatIsMyIp" it shows it being 98.224.42.53.) is not going to be static for you all the time , whenever you reboot the router or service restart their modem the IP address assigned to you will be lost . 

with below ip address you can do port-forwarding but this will not be permanent this will work for short time until IP address is assigned to you , Use below command on your router 

ip nat inside source static tcp 172.31.101.10 4369 98.224.42.53 4369

 

HTH

Sandy

 

ip nat inside source static tcp 172.31.101.10 4369 171.68.1.1 80 extendable 

 

 

New Member

Sandy,Where did you get 171

Sandy,

Where did you get 171.68.1.1?

Thanks,

Mike

430
Views
0
Helpful
7
Replies