Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

port forwarding in cisco 2621 router

Hello all,

I have a router 2621. I just want a port forward from public ip to local IP. Port is 8086. I use nat. I just need to forward the public ip 115.115.123.xxx 8086 to 192.168.1.130 8086 ( local ip). But I cant connect it. Here i will show the output of show run command.

Current configuration : 1452 bytes

!

version 12.2

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname RouterA

!

enable secret 5 $1$l/ko$sibpgYNMefNJLRWO477l70

enable password cisco12$

!

ip subnet-zero

!

!

ip name-server 192.168.1.1

ip name-server 208.67.222.222

ip name-server 208.67.220.220

ip name-server 192.168.1.10

ip dhcp excluded-address 192.168.1.10 192.168.1.254

!

ip dhcp pool LAN

   network 192.168.1.0 255.255.255.0

!

!

call rsvp-sync

!

!

!

!

!

!

!

!

interface FastEthernet0/0

description WAN

ip address 115.115.123.xxx 255.255.255.252

ip nat outside

duplex auto

speed auto

no cdp enable

!

interface Serial0/0

no ip address

shutdown

!

interface FastEthernet0/1

description LAN

ip address 192.168.1.1 255.255.255.0

ip nat inside

duplex auto

speed auto

!

interface Serial0/1

no ip address

shutdown

!

ip nat pool mjsoft 115.115.123.xxx 115.115.123.xxx netmask 255.255.255.252

ip nat inside source list 1 pool mjsoft overload

ip nat inside source static tcp 192.168.1.130 8086 115.115.123.xxx 8086 extendable

ip classless

ip route 0.0.0.0 0.0.0.0 115.115.123.xxx

ip http server

!

access-list 1 permit 192.168.1.0 0.0.0.255

!

snmp-server community public RO

snmp-server enable traps tty

!

dial-peer cor custom

!

!

!

!

!

line con 0

password cisco

login

line aux 0

line vty 0 4

exec-timeout 30 0

password cisco

logging synchronous

login

transport input telnet ssh

line vty 5 15

password cisco

login

!

end

RouterA#

Any help would be appreciable

Everyone's tags (2)
1 REPLY
Cisco Employee

port forwarding in cisco 2621 router

Hi Sooraj,

Is this your complete configuration? The DHCP pool configuration is missing vital settings - the default gateway and DNS server, to say the least.

In addition, is the 115.115.123.xxx always the same IP address in your entire configuration? You seem to be using the same address both in NAT, and as your default gateway - which would mean that it is in fact an address of another device, which would be a problem.

Best regards,

Peter

581
Views
0
Helpful
1
Replies