Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

PPP dialing fail

Hi all,

I have a Cisco 1812 with IOS 12.4(15)T17.

I would like to perform pppoe dialing using this device to my ISP. My ISP is using VLAN id 500 for Internet. I configure like below but seem unsuccessful. From the console, I can't even ping to internet.

Please help to analyse.

------

interface FastEthernet0

description --> WAN

no ip address

duplex auto

speed auto

pppoe enable group global

pppoe-client dial-pool-number 1

!

interface FastEthernet0.500

encapsulation dot1Q 500

ip address 210.x.x.x 255.255.255.0

pppoe enable group global

no cdp enable

!

ip route 0.0.0.0 0.0.0.0 Dialer1

!

ip nat inside source route-map nonat interface Dialer1 overload

!

dialer-list 1 protocol ip permit

-------

Everyone's tags (3)
5 REPLIES

PPP dialing fail

Hi all,

I perform below command :

debug  ppp authentication

debug  ppp error

debug  ppp negotiation

debug  pppoe events

debug  pppoe errors

debug  pppoe data

debug  pppoe packets

debug  dialer

This is the result. What does it mean???

*Aug 28 06:38:42.175:  padi timer expired

*Aug 28 06:38:42.175:  Sending PADI: Interface = FastEthernet0

*Aug 28 06:38:42.175: pppoe_send_padi:

FF FF FF FF FF FF 00 18 73 07 DD F0 88 63 11 09

00 00 00 0C 01 01 00 00 01 03 00 04 84 CD BB E0 ...

*Aug 28 06:38:51.227: Di1 DDR: Cannot place call, no dialer string set

*Aug 28 06:39:14.431:  padi timer expired

*Aug 28 06:39:14.431:  Sending PADI: Interface = FastEthernet0

*Aug 28 06:39:14.431: pppoe_send_padi:

FF FF FF FF FF FF 00 18 73 07 DD F0 88 63 11 09

00 00 00 0C 01 01 00 00 01 03 00 04 84 CD BB E0 ...

*Aug 28 06:39:46.695:  padi timer expired

*Aug 28 06:39:46.695:  Sending PADI: Interface = FastEthernet0

*Aug 28 06:39:46.695: pppoe_send_padi:

FF FF FF FF FF FF 00 18 73 07 DD F0 88 63 11 09

00 00 00 0C 01 01 00 00 01 03 00 04 84 CD BB E0 ...

*Aug 28 06:39:55.227: Di1 DDR: Cannot place call, no dialer string set

*Aug 28 06:40:18.951:  padi timer expired

*Aug 28 06:40:18.951:  Sending PADI: Interface = FastEthernet0

*Aug 28 06:40:18.951: pppoe_send_padi:

FF FF FF FF FF FF 00 18 73 07 DD F0 88 63 11 09

00 00 00 0C 01 01 00 00 01 03 00 04 84 CD BB E0 ...

kl-warehouse#

*Aug 28 06:40:51.235:  padi timer expired

*Aug 28 06:40:51.235:  Sending PADI: Interface = FastEthernet0

*Aug 28 06:40:51.235: pppoe_send_padi:

FF FF FF FF FF FF 00 18 73 07 DD F0 88 63 11 09

00 00 00 0C 01 01 00 00 01 03 00 04 84 CD BB E0 ...

*Aug 28 06:40:59.227: Di1 DDR: Cannot place call, no dialer string set

*Aug 28 06:41:23.491:  padi timer expired

*Aug 28 06:41:23.491:  Sending PADI: Interface = FastEthernet0

*Aug 28 06:41:23.491: pppoe_send_padi:

FF FF FF FF FF FF 00 18 73 07 DD F0 88 63 11 09

00 00 00 0C 01 01 00 00 01 03 00 04 84 CD BB E0 ...

*Aug 28 06:41:55.763:  padi timer expired

*Aug 28 06:41:55.763:  Sending PADI: Interface = FastEthernet0

*Aug 28 06:41:55.763: pppoe_send_padi:

FF FF FF FF FF FF 00 18 73 07 DD F0 88 63 11 09

00 00 00 0C 01 01 00 00 01 03 00 04 84 CD BB E0 ...

*Aug 28 06:42:03.227: Di1 DDR: Cannot place call, no dialer string set

*Aug 28 06:42:26.043: Di1 DDR: Cannot place call, no dialer string set

*Aug 28 06:42:27.043: Di1 DDR: Cannot place call, no dialer string set

VIP Purple

PPP dialing fail

Hi Mohd,

In this case, no dialer string dial-string is configured on the Dialer interface. The router wants to place a call but does not know the number to call. Define a dialer-string:

interface Dialer1
      dialer string 8134

Regards

Please rate if it helps.

PPP dialing fail

Hi,

This is the configuration of Dialer 1 interface. What number does it required??

interface Dialer1

ip address negotiated

ip mtu 1492

ip nat outside

encapsulation ppp

dialer pool 1

dialer-group 1

ip tcp adjust-mss 1414

ppp authentication chap pap callin

ppp chap hostname keyencekl5@unifibiz

ppp chap password pFThpMgJBVax8

ppp pap sent-username keyencekl5@unifibiz password pFThpMgJBVax8

ppp ipcp dns request accept

ppp ipcp address accept

VIP Purple

PPP dialing fail

jus try with dialer string<Phone number with country code> and then try

Regards

Please rate if it helps.

PPP dialing fail

Hello Mohd,

I am not sure about adding a phone number for this is PPPoE (not DDR related). I found a message here that could be the key to understand the issue:

*Aug 28 06:41:55.763:  padi timer expired

That means that your router is continuously sending PPPoE Active       Discovery Initiation (PADI) frames to the ISP with no response. If no PPPoE Active Discovery Offer (PADO) is received the PPPoE negotiation will not be successful.

http://www.cisco.com/en/US/tech/tk175/tk15/technologies_configuration_example09186a008071a7c2.shtml

This behavior can be observed if:

  • the modem is not in bridge mode
  • the provider has a problem and for some reason the DSLAM is not responding at all.

Please turn off all the debugging and activate just:

  • debug pppoe errors
  • debug pppoe events
  • debug ppp negotiation
2038
Views
6
Helpful
5
Replies
CreatePlease login to create content