Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

PPP multilink bonding 2x DSL but no resliancy

Hello all,

I have a Cisco 1841,c1841-ipbase-mz.124-20.T4.bin, with 2x HWIC-1ADSL-M.

I have managed to bond 2x DSL with PPP multlink with the config below and traffic is being sent equally across both DSL circuits. However if i disconnect either of the DSL cables connectivity fails. I was expecting connectivity to continue to work just over the one circuit.

Has anyone else come across this issue or have any ideas as to how to resolve this?

Many thanks,

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname ##############1

!

boot-start-marker

boot-end-marker

!

logging message-counter syslog

logging buffered 4096 informational

enable secret 5 $1$Wzt6$.EMlo9.BU5ooN/DDMatc01

!

no aaa new-model

no ip source-route

!

!

no ip dhcp use vrf connected

!

!

!

ip cef

ip name-server 10.3.3.50

ip name-server 10.2.3.50

multilink bundle-name authenticated

!

!

username ####### secret 5 #########.

archive

log config

  hidekeys

!

!

!

!

!

!

interface FastEthernet0/0

description LAN

ip address #.#.#.# 255.255.255.252

ip directed-broadcast

load-interval 30

speed 100

full-duplex

!

interface FastEthernet0/1

ip address #.#.#.# 255.255.255.0

duplex auto

speed auto

!

interface ATM0/0/0

description "DSL"

no ip address

no atm ilmi-keepalive

dsl operating-mode auto

pvc 0/38

  encapsulation aal5mux ppp Virtual-Template1

!

!

interface ATM0/1/0

description "DSL"

no ip address

no atm ilmi-keepalive

dsl operating-mode auto

pvc 0/38

  encapsulation aal5mux ppp Virtual-Template1

!

!

interface Virtual-Template1

mtu 1486

ip address negotiated

ip tcp adjust-mss 1446

ppp pap sent-username mlppp password 7 ########

ppp multilink

!

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 #.#.#.#

!

!

ip http server

!

access-list 101 permit tcp any any eq 3389

snmp-server community public RO

!

!

control-plane

!

banner motd ^C

******************************************************************************

******************************************************************************

            IF YOU ARE NOT AUTHORISED TO ACCESS THIS DEVICE PLEASE

                            DISCONNECT IMMEDIATELY!

******************************************************************************

******************************************************************************

^C

!

line con 0

line aux 0

line vty 0 4

login local

transport input telnet

!

scheduler allocate 20000 1000

ntp server #.#.#.#

end

Everyone's tags (3)
1 REPLY
New Member

PPP multilink bonding 2x DSL but no resliancy

We managed to resolve this using:

http://www.cisco.com/en/US/docs/ios-xml/ios/qos_latjit/configuration/12-4/qos-mlppp.html#GUID-680C1343-FE78-4553-A6BC-93D3B2CBD4BE

The final config is:

interface ATM0/0/0

description "DSL"

no ip address

load-interval 30

no atm ilmi-keepalive

dsl operating-mode auto

pvc 0/38

  encapsulation aal5snap

  protocol ppp Virtual-Template1

!

!

interface ATM0/1/0

description "DSL"

no ip address

load-interval 30

no atm ilmi-keepalive

dsl operating-mode auto

pvc 0/38

  encapsulation aal5snap

  protocol ppp Virtual-Template1

!

!

interface Virtual-Template1

mtu 1486

ip address negotiated

ip tcp adjust-mss 1446

keepalive 1 2

ppp pap sent-username ##### password ########

ppp multilink

ppp multilink interleave

1908
Views
0
Helpful
1
Replies