Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

PPP MultiLink Issue. Urgent!

There are two CE1 Line between HQ and Branch office router. Router in HQ is Cisco 7204VXR with PA-MC-STM-1SMI card and Router in Branch is Cisco 7204VXR with two CE1 cards. After use the following configuration to bundle two CE1 link to improve the bandwith, it's ok during the low traffic between the links(2.8Mbps or so). But when the traffic exceed 3Mbps or so, there will be some of packet lose and the speed showed in command 'show interface virtual-access 2' will drop sharply to very low speed such as 800kbps, then will go up slowly. Before use ppp multilink, I test two CE1 links which showed the quality is ok. so could you pls give me some comments and advice. Thanks. the configuration is showed as follows:

HQ:

multilink virtual-template 1

controller SONET 1/0

framing sdh

clock source internal

!

au-4 1 tug-3 1

tug-2 1 e1 2 channel-group 0 timeslots 1-31

tug-2 1 e1 2 framing no-crc4

tug-2 1 e1 3 channel-group 0 timeslots 1-31

tug-2 1 e1 3 framing no-crc4

interface Serial1/0.1/1/1/2:0

description link to branch

no ip address

encapsulation ppp

fair-queue

ppp multilink

ppp multilink group 1

interface Serial1/0.1/1/1/3:0

description link to branch-backup

no ip address

encapsulation ppp

fair-queue

ppp multilink

ppp multilink group 1

interface Virtual-Template1

ip address 10.201.115.1 255.255.255.252

ip ospf authentication message-digest

ip ospf message-digest-key 1 md5 xxx

ip ospf cost 48

ppp multilink

ppp multilink group 1

router ospf 1

network 10.201.115.0 0.0.0.3 area 115

area 115 authentication message-digest

Branch Office:

multilink virtual-template 1

controller E1 1/0

framing NO-CRC4

channel-group 0 timeslots 1-31 speed 64

description Connect to SH HQ

controller E1 1/1

framing NO-CRC4

channel-group 0 timeslots 1-31 speed 64

interface Serial1/0:0

description the First Connect to HQ

no ip address

encapsulation ppp

fair-queue

ppp multilink

ppp multilink group 1

interface Serial1/1:0

description the Second Connect to HQ

no ip address

encapsulation ppp

fair-queue

ppp multilink

ppp multilink group 1

interface Virtual-Template1

ip address 10.201.115.2 255.255.255.252

ip ospf authentication message-digest

ip ospf message-digest-key 1 md5 xxx

ip ospf cost 48

ppp multilink

ppp multilink group 1

router ospf 1

network 10.201.115.0 0.0.0.3 area 115

area 115 authentication message-digest

3 REPLIES
Hall of Fame Super Gold

Re: PPP MultiLink Issue. Urgent!

Really one would need to see the show interface output to see amount of drops an possibly compare with a traffic graph to understand under which conditions they occur.

Beside this, what is the reason for mlppp in this design, given that fragmentation nor qos are enabled ?

Do you need perfect load balance, wouldn't be per-flow sufficient ?

New Member

Re: PPP MultiLink Issue. Urgent!

You might want to turn off fair-queue. With fair-queue on you are trying to create seperate queues for each flow.

New Member

Re: PPP MultiLink Issue. Urgent!

thanks for your reply.

I just changed to use ospf two equal-cost path to load balance. Although the load balance isn't very accurate as mlppp, it work. So customer at least accept this method. By the way, in the trouble shooting phase, i try to turn off fair-queue, but it didn't work well: speed of interface will still drop to a very low rate.

could you give me some further information and comments? thks.

213
Views
0
Helpful
3
Replies
CreatePlease to create content